当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [分享]关于ubuntu上的偶尔只有单声道响,声音小以及音质差的解决办法
帖子发表于 : 2007-08-13 11:31 
头像

注册: 2007-08-10 16:18
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
偶装Ubuntu不久,确实是个非常好的系统,不过声音这方面让我郁闷了好久,有时只有一个声道响,并且声音奇小,音质差的离谱。
baidu来google去,找到个不错的方法,现在与大家共分享 :D

i :到http://www.alsa-project.org/main/index.php/Main_Page下载最新驱动,库文件...

alsa-driver-1.0.14.tar.bz2
alsa-lib-1.0.14a.tar.bz2
alsa-utils-1.0.14.tar.bz2

ii :安装需要的一些文件
sudo apt-get install build-essential ncurses-dev
安装内核头文件
sudo apt-get install linux-headers-`uname -r`

iii :
Setup installation directories 解压缩下载的文件
sudo mkdir -p /usr/src/alsa
cd /usr/src/alsa
sudo cp /home/具体文件位置/* .
sudo tar xjf alsa-driver-1.0.14.tar.bz2
sudo tar xjf alsa-lib-1.0.14a.tar.bz2
sudo tar xjf alsa-utils-1.0.14.tar.bz2

iv :
重新编译安装,没有make和gcc的自己解决
cd alsa-driver-1.0.14
sudo ./configure
sudo make
sudo make install

cd alsa-lib-1.0.14a
sudo ./configure
sudo make
sudo make install

cd alsa-utils-1.0.14
sudo ./configure
sudo make
sudo make install

v :编辑alsa-base文件
sudo gedit /etc/modprobe.d/alsa-base
在最后一行加入以下内容:
options snd-hda-intel model=你自己机器的具体型号

reboot,OK搞定!

在ubuntu7.04下顺利通过,解决了单声道问题,声音很大,音质是否提升就在你自己怎么去看待喽,祝大家都能搞成功(特别像偶们这种新手) :lol:


_________________
嘛叫个性签名?
LINUX乐园,QQ群:18515236 ^_^


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-23 16:36 

注册: 2007-10-23 16:34
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也遇到同样的问题了~~不过我ms是双击小喇叭后,在文件中 更改设备 然后再调下音量就好了


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-01 12:36 

注册: 2008-04-27 22:44
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
warlocklau
我像你这样作了之后,重启电脑就没有声音了。。。
帮帮忙。。。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-01 16:41 
头像

注册: 2008-02-20 0:09
帖子: 413
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
没有Lenovo F41这个型号吧 :em65


_________________
生活就像对待Linux一样,要敢于折腾也要学会折腾。
──────────────────────────────────
@picobird


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-04 11:09 

注册: 2006-12-06 16:21
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
呵呵 楼上的也所联想F41M,我也是的,现在8。04就是声音时有时无


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-04 16:54 

注册: 2007-10-24 19:58
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
keepmoving 写道:
呵呵 楼上的也所联想F41M,我也是的,现在8。04就是声音时有时无



用相近的代替!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-06 20:02 

注册: 2008-02-22 10:53
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
把smlayer里的声卡驱动alsa,所有的都用alsa,不用pulse就行


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译