ubuntu 7.04对无线网卡:TP-Link TL-wN321G及电信天翼通网络的支持问题!

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
saky
帖子: 12
注册时间: 2007-08-13 1:13
送出感谢: 0
接收感谢: 0

ubuntu 7.04对无线网卡:TP-Link TL-wN321G及电信天翼通网络的支持问题!

#1

帖子 saky » 2007-08-15 11:19

os: ubuntu 7.04
无线网卡:TP-Link TL-wN321G

系统认到无线网卡,并发现了天翼通的网络ChinaNet,但是无法设置pppoe拨号,解析dns时也无法跳到无线网络帐号登录页面。无线强度显示为0%
同台机子在同一个地方可以通过天翼通上网,一切正常。
感觉ubuntu应该对无线网络应该有很好的支持才对,而且硬件都认到了,极度郁闷中,望各位兄弟帮我指点一二,谢谢了!
原帖来自于网易社区:http://club.163.com/viewArticleByWWW.m? ... 4fa04a95_1
saky
帖子: 12
注册时间: 2007-08-13 1:13
送出感谢: 0
接收感谢: 0

#2

帖子 saky » 2007-08-15 15:07

为何没有人回应?期待着哪位高手来指点迷津! 8)
xplayer
帖子: 43
注册时间: 2007-06-13 19:47
送出感谢: 0
接收感谢: 0

Re: ubuntu 7.04对无线网卡:TP-Link TL-wN321G及电信天翼通网络的支持问题!

#3

帖子 xplayer » 2007-08-16 1:08

saky 写了:os: ubuntu 7.04
无线网卡:TP-Link TL-wN321G

系统认到无线网卡,并发现了天翼通的网络ChinaNet,但是无法设置pppoe拨号,解析dns时也无法跳到无线网络帐号登录页面。无线强度显示为0%
同台机子在同一个地方可以通过天翼通上网,一切正常。
感觉ubuntu应该对无线网络应该有很好的支持才对,而且硬件都认到了,极度郁闷中,望各位兄弟帮我指点一二,谢谢了!
原帖来自于网易社区:http://club.163.com/viewArticleByWWW.m? ... 4fa04a95_1
  我现在就用这个wn321g无线网卡上网的,用的是中国电信。也想帮你,不过不知道你是什么问题。无法设置拨号是什么问题?总得 有个错误提示吧。dns解析本来就不会跳转到什么登录界面,dns和http两个协议是不同的。我是自己另外编译的wn321g驱动,用自带的那个我会死机的。
milton611
帖子: 2
注册时间: 2007-08-14 7:41
送出感谢: 0
接收感谢: 0

#4

帖子 milton611 » 2007-08-16 3:46

我的wn321g插到电脑里以后,系统识别为有线网络(Unknown USB Vendor Specific Interface)我装的是1.0.4.0的rt73 linux驱动,因为我是新手 有可能装错了步骤,哪位高手帮忙解决一下啊!
saky
帖子: 12
注册时间: 2007-08-13 1:13
送出感谢: 0
接收感谢: 0

#5

帖子 saky » 2007-08-16 13:39

我现在就用这个wn321g无线网卡上网的,用的是中国电信。也想帮你,不过不知道你是什么问题。无法设置拨号是什么问题?总得 有个错误提示吧。dns解析本来就不会跳转到什么登录界面,dns和http两个协议是不同的。我是自己另外编译的wn321g驱动,用自带的那个我会死机的。

---用中国电信的网络,是Adsl+自带AP还是用天翼通所提供的AP?
目前的问题是信号强度0,无法设置pppoe拨号。怀疑是无线网卡没有真正的驱动起来。
另外编译的wn321g有地方下载吗?方便的话提供一下,谢谢!

p.s. windows下如果连接到天翼通的热点AP后无线网卡自动获取了一个IP和远端DNS,这时候有两种方法上网,一种是利用这个无线链路进行PPPOE拨号,另外一种是直接输入网站的地址,天翼通的系统会把你的页面导向一个输入天翼通帐号的网站,在那里你能用天翼通帐号登录,并且自动下载一个activex控件到本地来控制网络的连接和断开。估计是用DNS解析的时候跳转的。 DNS和HTTP协议不同我是知道的,但是HTTP发出的请求如果是域名的话必须经过DNS先解析。
saky
帖子: 12
注册时间: 2007-08-13 1:13
送出感谢: 0
接收感谢: 0

#6

帖子 saky » 2007-08-16 13:40

没错误提示,只是显示信号强度为0
saky
帖子: 12
注册时间: 2007-08-13 1:13
送出感谢: 0
接收感谢: 0

#7

帖子 saky » 2007-08-16 15:41

i found this article on internet and now there's no problem using my wn321g.
Many thanks to Mr. Xplayer.

在linux下面使用 TP-link TL-WN321G USB 无线网卡

接上无线网卡用usbview查看,可知其中置芯片是ralink公司的2573号产品。到公司网站上下载驱动:http://www.ralinktech.com/drivers/Linux ... 3.0.tar.gz

注意一定要是RT73这一款驱动。我开始搞成了11g-RT2500,所以一直都不对,

后来在windows下安装其驱动时发现驱动程序是c/windows/system32/drivers/rt74.sys

才估计驱动应该和RT73有关系。

下下来以后照着README上的说明就行了,我在这里还是简要写一下:

解压缩以后有两个文件夹,

进Module那个,

用chmod 644 把所有的文件都改成可读写的。

如果是kernel 2.4

就cp Makefile.4 Makefile

如果是2.6, cp Makefile.6 Makefile.

然后就可以make和 make install了。

中间缺什么东西不能make 的话自己找来装上就行了。

因为本人用的是ubuntu,安装软件工具非常简单,故而一般就不关心这些在RedHat 或FC下面比较烦人的事了。

安装好以后:用insmod rt73.ko装载驱动模块。

装上以后,接上无线网卡用usbview再看的时候,对应的wlan应该不再是红色的,而是正常的黑色。

用iwconfig可以看到网卡被识别出来了。

然后把以太网卡禁掉,配置好无线网卡就行了。本文主要是说安装驱动,相信配置这些小问题大家也不会并得麻烦。

总结:从该事例可以看出,TP-link公司用的芯片是ralink公司的,TP-link只是给它加了层壳而已。



网卡无法工作的罪魁祸首原来是Ubuntu Feisty自带的无线网卡驱动在rt73上不能正常工作!因此在插入无线网卡时,错误地加载了rt73usb、rt2570、rt2x00lib这三个模块(其中rt73usb在理想情况下应该是可以工作的才对-_-!),于是在/etc/modprobe.d/blacklist中禁用他们!OK,现在一切问题都解决了Smile不需要额外的配置。

作者: Edu-Map.com/chinakr 日期: 2007-04-21

来源: http://quickbest.com.cn/blog/index.php?id=chinakr
365402989
帖子: 6
注册时间: 2007-10-03 16:38
送出感谢: 0
接收感谢: 0

#8

帖子 365402989 » 2007-10-07 15:03

用usbview查看怎么弄?
wlan?
iwconfig?
怎么配置好无线网卡?
网卡无法工作的罪魁祸首原来是Ubuntu Feisty自带的无线网卡驱动在rt73上不能正常工作!因此在插入无线网卡时,错误地加载了rt73usb、rt2570、rt2x00lib这三个模块(其中rt73usb在理想情况下应该是可以工作的才对-_-!),于是在/etc/modprobe.d/blacklist中禁用他们!OK,现在一切问题都解决了Smile不需要额外的配置。
怎么禁用不是很明白,一定要禁用吗?
365402989
帖子: 6
注册时间: 2007-10-03 16:38
送出感谢: 0
接收感谢: 0

#9

帖子 365402989 » 2007-10-07 15:07

我也是这个毛病
不知道怎么办?
回复

回到 “常用硬件支持”