[问题]求助,ubuntu7.04中安装 compaq 的 无线网卡 w200

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
join330
帖子: 17
注册时间: 2007-08-17 18:01
送出感谢: 0
接收感谢: 0

[问题]求助,ubuntu7.04中安装 compaq 的 无线网卡 w200

#1

帖子 join330 » 2007-08-20 10:52

大家好,
我是ubuntu的新人,
昨天晚上装好了emule上下载的ubuntu 7.04的版本,
我电脑是compaq evo n410c 768mb ram 60g hdd p3 1g ,装好后其他硬件系统都能识别,
也能非常正常的上网,用gaim,用了14年微软的系统,感觉这个ubuntu非常不错,

但是单位都是 无线上网的,我笔记本无线网卡是 compaq 带的 w200
ubuntu 7.04没有 自带驱动,
于是我上网找安装方法,还是给我找到了:https://help.ubuntu.com/community/WifiD ... CompaqW200,不过按照上面的内容没能安装成功



zhanghao@zhanghao-laptop:~$ cd usb
zhanghao@zhanghao-laptop:~/usb$ dir
airport.c hermes.h net orinoco_nortel.c orinoco_usb.c TODO
compat.h hermes_rid.h NEWS orinoco_pci.c prism_usb.c
dump_recs.c Kbuild orinoco.c orinoco_pci.h README
firmware Makefile orinoco_cs.c orinoco_plx.c README.orinoco
hermes.c mkconf orinoco.h orinoco_tmd.c spectrum_cs.c
zhanghao@zhanghao-laptop:~/usb$ make
make -C /usr/src/linux-headers-2.6.20-15-generic M=/home/zhanghao/usb KERNELRELEASE=2.6.20-15-generic modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.20-15-generic'
CC [M] /home/zhanghao/usb/orinoco.o
/home/zhanghao/usb/orinoco.c: 在函数 ‘orinoco_get_drvinfo’ 中:
/home/zhanghao/usb/orinoco.c:4287: 错误: ‘struct net_device’ 没有名为 ‘dev’ 的成员
/home/zhanghao/usb/orinoco.c:4288: 错误: ‘struct net_device’ 没有名为 ‘dev’ 的成员
make[2]: *** [/home/zhanghao/usb/orinoco.o] 错误 1
make[1]: *** [_module_/home/zhanghao/usb] 错误 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.20-15-generic'
make: *** [modules] 错误 2

之前所有的都正常,就是 到了 make这一步 ,报错了,大家能帮我看看是什么问题么?
另外 我用的是 系统自带的 附件 中 的终端 ,来输入这些命令的,对不对?
join330
帖子: 17
注册时间: 2007-08-17 18:01
送出感谢: 0
接收感谢: 0

#2

帖子 join330 » 2007-08-20 12:40

找到片解释的比较清楚的文章,我回去再试试,嘿嘿

http://www.sunshow.net/blog/archives/445.html

1. 下载驱动源码
由于驱动在svn上,首先安装subversion,然后从svn上获取最新驱动
sudo apt-get install subversion
svn co https://svn.sourceforge.net/svnroot/ori ... anches/usb

或者可以直接在本站下载:orinoco_usb.zip

2. 编译安装

For 2.6.20-15-generic download SVN rev 1276. In order to compile, edit lines 4287, 4288 of orinoco.c replacing dev->dev.parent with dev->class_dev.dev

如果是从本站下载的直接跳到下一步;
如果是从svn获取,以当前版本的驱动(1276),查找4287行和4288行,将dev->dev.parent修改为dev->class_dev.dev;

如果尚未安装编译环境:
sudo apt-get install build-essential

编译并安装:
sudo make
sudo make install

3. 下载并复制firemware
下载脚本是驱动源码包中现成的,运行即可:
cd firmware
sudo ./get_ezusb_fw
sudo cp orinoco_ezusb_fw /lib/firmware/`uname -r`/

4. 启用无线网卡

测试并启用网卡:
sudo modprobe -v orinoco_usb

如果一切正常,这时候万通宝上的指示灯应该已经亮了,在网络设置中应该也能看见无线网卡的设置了,接下来让系统启动时自动加载驱动:
sudo vim /etc/modules

在文件末尾加入:
orinoco_usb

5. 安装network-manager-gnome

我使用的是xfce,如果Gnome可以直接忽略这一步。
安装步骤:
sudo apt-get install network-manager-gnome network-manager
sudo /etc/init.d/dbus restart

这时候系统栏应该出现网络连接的图标,单击图标即可以查看目前可用的无线网络并可以选择连接了。
join330
帖子: 17
注册时间: 2007-08-17 18:01
送出感谢: 0
接收感谢: 0

#3

帖子 join330 » 2007-08-20 12:51

不过据说 不管用什么方法 只要 进加密的网站,系统会死机。。。。
好像有人搞定了,不过等我驱动出来了,再说吧。
join330
帖子: 17
注册时间: 2007-08-17 18:01
送出感谢: 0
接收感谢: 0

#4

帖子 join330 » 2007-08-20 21:44

用了改过的驱动,
装是装上了
不过连无线的时候就死机。。。。
试过多种方法,
后来问一个朋友,他建议我用用看 ubuntu 6.06的版本。

现在我正下载 6.06版本,
虽然,只用了一天ubuntu ,不过我已经爱上这个系统了。
join330
帖子: 17
注册时间: 2007-08-17 18:01
送出感谢: 0
接收感谢: 0

#5

帖子 join330 » 2007-08-21 16:14

系统换成ubuntu 6.06后,无线一切正常,
不过6.06没 7.04漂亮,
内置的软件也都比较老。
Sunshow
帖子: 33
注册时间: 2006-07-05 8:43
送出感谢: 0
接收感谢: 0

#6

帖子 Sunshow » 2007-08-22 8:42

等7.10,呵呵
feiwx88
帖子: 3
注册时间: 2007-08-18 2:22
送出感谢: 0
接收感谢: 0

#7

帖子 feiwx88 » 2007-08-25 22:19

我的情况和你一样,因为要计算一些东西用到linux,装了ubuntu,结果发现W200无法正常驱动,一连接无线AP就死机。51nb.com论坛上有个人解决了W200无线加密死机的问题,你可以问问去。我现在不用W200,改用pcmcia卡上网了。
join330
帖子: 17
注册时间: 2007-08-17 18:01
送出感谢: 0
接收感谢: 0

#8

帖子 join330 » 2007-08-27 17:47

谢谢楼上的热心人。

我装回 ubuntu 7.04了,
暂时先用 有线网卡,

无线的慢慢找办法,
6.06 用起来 7.04舒服
Sunshow
帖子: 33
注册时间: 2006-07-05 8:43
送出感谢: 0
接收感谢: 0

#9

帖子 Sunshow » 2007-09-23 12:10

今天更新了7.10的内核
死机问题依旧啊
join330
帖子: 17
注册时间: 2007-08-17 18:01
送出感谢: 0
接收感谢: 0

#10

帖子 join330 » 2007-09-25 9:17

看来得换硬件了
回复

回到 “常用硬件支持”