求救!无线网卡突然找不到,lspci中也看不到

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
cleven
帖子: 18
注册时间: 2005-11-17 9:25
送出感谢: 0
接收感谢: 0
联系:

求救!无线网卡突然找不到,lspci中也看不到

#1

帖子 cleven » 2007-08-31 1:40

我的无线网卡为Broadcom 43xx,上个月还工作得很正常,使用本地驱动和ndiswrapper都可以正常使用,lspci显示为:
01:00.0 Network controller: Broadcom Corporation BCM4310 UART (rev ff)
但是一段时间没用后,突然不见了,无线网卡的指示灯一直是红色的(正常是蓝色),lspci中也彻底没有了这个设备,lshal中也找不到。我试过完全断电(连电池都取下),然后重开机,n+n次后还是无法解决,各位大大帮忙看看,实在解决不了了,google都被我翻到服务器崩溃了。 :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2007-08-31 9:53

lsmod看模块加载了没?是那ndiswrapper加的。具体不清楚应该是什么名字。
● 鸣学
cleven
帖子: 18
注册时间: 2005-11-17 9:25
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 cleven » 2007-08-31 10:09

lsmod中没列出来,ndiswrapper已经被我删掉了。这个和设备应该没关系,即使没驱动,lspci以前也是可以看到无线网卡的。
$ lsmod
Module Size Used by
bluetooth 55908 0
vmnet 32932 15
vmmon 185676 0
binfmt_misc 12680 1
dev_acpi 12292 0
sony_acpi 6284 0
tc1100_wmi 8068 0
pcc_acpi 13184 0
container 5248 0
dock 10268 0
button 8720 0
ac 6020 0
sbs 15652 0
battery 10756 0
video 16388 0
asus_acpi 17308 0
i2c_ec 6016 1 sbs
powernow_k8 16064 1
backlight 7040 1 asus_acpi
cpufreq_userspace 5408 0
cpufreq_ondemand 9228 1
cpufreq_stats 7360 0
freq_table 5792 3 powernow_k8,cpufreq_ondemand,cpufreq_stats
cpufreq_conservative 8200 0
cpufreq_powersave 2688 0
nls_iso8859_1 5120 1
nls_cp437 6784 1
vfat 14208 1
fat 53916 1 vfat
sbp2 23812 0
parport_pc 36388 0
lp 12452 0
parport 36936 2 parport_pc,lp
fuse 46612 0
snd_hda_intel 21912 0
snd_hda_codec 205056 1 snd_hda_intel
snd_pcm_oss 44544 0
snd_mixer_oss 17408 1 snd_pcm_oss
snd_pcm 79876 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 4740 0
snd_seq_oss 32896 0
joydev 10816 0
snd_seq_midi 9600 0
snd_rawmidi 25472 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_seq 52592 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 23684 2 snd_pcm,snd_seq
snd_seq_device 9100 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
pcspkr 4224 0
snd 54020 10 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
sdhci 18700 0
nvidia 4713780 22
soundcore 8672 1 snd
mmc_core 26756 1 sdhci
i2c_nforce2 6784 0
serio_raw 7940 0
k8temp 6656 0
agpgart 35400 1 nvidia
snd_page_alloc 10888 2 snd_hda_intel,snd_pcm
psmouse 38920 0
shpchp 34324 0
pci_hotplug 32576 1 shpchp
i2c_core 22656 3 i2c_ec,nvidia,i2c_nforce2
evdev 11008 6
tsdev 8768 0
ext3 133128 7
jbd 59816 1 ext3
mbcache 9604 1 ext3
sg 36252 0
sd_mod 23428 10
ide_cd 32672 0
cdrom 37664 1 ide_cd
ata_generic 9092 0
usbhid 26592 0
hid 27392 1 usbhid
forcedeth 46728 0
ehci_hcd 34188 0
ohci1394 36528 0
ieee1394 299448 2 sbp2,ohci1394
ohci_hcd 22532 0
amd74xx 15260 0 [permanent]
usbcore 134408 4 usbhid,ehci_hcd,ohci_hcd
sata_nv 20868 10
libata 125720 2 ata_generic,sata_nv
scsi_mod 142348 4 sbp2,sg,sd_mod,libata
generic 5124 0 [permanent]
thermal 14856 0
processor 31048 2 powernow_k8,thermal
fan 5636 0
fbcon 42656 0
tileblit 3584 1 fbcon
font 9216 1 fbcon
bitblit 6912 1 fbcon
softcursor 3200 1 bitblit
vesafb 9220 0
capability 5896 0
commoncap 8192 1 capability
cleven
帖子: 18
注册时间: 2005-11-17 9:25
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 cleven » 2007-08-31 14:20

哪位大哥帮帮忙,有类似情况的提示一下
头像
jaywee
帖子: 517
注册时间: 2006-06-18 21:49
送出感谢: 0
接收感谢: 0
联系:

Re: 求救!无线网卡突然找不到,lspci中也看不到

#5

帖子 jaywee » 2009-06-21 11:13

我也是。。唉。。煩燥中。。
Time waits for no man!
头像
ha_ha_xiao
帖子: 43
注册时间: 2008-03-11 22:58
送出感谢: 0
接收感谢: 0

Re: 求救!无线网卡突然找不到,lspci中也看不到

#6

帖子 ha_ha_xiao » 2009-06-21 14:39

我的也是啊,本来用的好好的,后来有此更新完之后broadcom的无线网卡就不能工作了,“硬件驱动”里有个broadcom b43 wireless driver,但激活不了...郁闷中
onlywang
帖子: 23
注册时间: 2006-09-29 11:35
来自: nanjing
送出感谢: 0
接收感谢: 0
联系:

Re: 求救!无线网卡突然找不到,lspci中也看不到

#7

帖子 onlywang » 2009-09-16 21:22

我的安装的是9.04的,装好后就lspci找不到。在vmware里装的。在windows系统下正常。
hobowang
帖子: 1
注册时间: 2009-06-06 19:49
送出感谢: 0
接收感谢: 0

Re: 求救!无线网卡突然找不到,lspci中也看不到

#8

帖子 hobowang » 2010-03-23 8:50

我的bcm4311,硬盘安装的ubuntu9.10下正常,virtualbox下安装的ubuntu9.10里找不到,lspci里也没有显示。
回复

回到 “常用硬件支持”