当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]移动硬盘无法使用,dmesg 有错误信息
帖子发表于 : 2007-09-19 9:31 

注册: 2005-12-16 6:42
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
我的系统为 Debian etch,内核为2.6.18-4-amd64,机器为ThinkPad T60。移动硬盘是三星120G的,分了三个区,均为NTFS格式。

当我把移动硬盘接上后 /dev 下只有一个 sdb,看不见分区,fidsk -l /dev/sdb 什么信息都得不到。查看 dmesg 信息,发现系统已经认出了我的三星硬盘

代码:
scsi6 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 6
usb-storage: waiting for device to settle before scanning
  Vendor: SAMSUNG   Model: HM120JC           Rev:  0 0
  Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sdb: 234441648 512-byte hdwr sectors (120034 MB)
sdb: Write Protect is off
sdb: Mode Sense: 03 00 00 00
sdb: assuming drive cache: write through
SCSI device sdb: 234441648 512-byte hdwr sectors (120034 MB)
sdb: Write Protect is off
sdb: Mode Sense: 03 00 00 00
sdb: assuming drive cache: write through


但紧接着出现一堆错误信息:
代码:
 sdb:<6>sd 6:0:0:0: SCSI error: return code = 0x10070000
end_request: I/O error, dev sdb, sector 0
printk: 10 messages suppressed.
Buffer I/O error on device sdb, logical block 0
sd 6:0:0:0: SCSI error: return code = 0x10070000
end_request: I/O error, dev sdb, sector 0
Buffer I/O error on device sdb, logical block 0
 unable to read partition table
sd 6:0:0:0: Attached scsi disk sdb
usb-storage: device scan complete
sd 6:0:0:0: SCSI error: return code = 0x10070000
end_request: I/O error, dev sdb, sector 234441472
Buffer I/O error on device sdb, logical block 29305184
sd 6:0:0:0: SCSI error: return code = 0x10070000
end_request: I/O error, dev sdb, sector 234441472

...

sd 6:0:0:0: SCSI error: return code = 0x10070000
end_request: I/O error, dev sdb, sector 0
sd 6:0:0:0: SCSI error: return code = 0x10070000
end_request: I/O error, dev sdb, sector 0
sd 6:0:0:0: SCSI error: return code = 0x10070000

...


因为我朋友的移动硬盘也是三星的,同样为NTFS格式。在我这里就可以正确识别并挂载。所以实在不知道是什么原因导致的。请各位朋友指教。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [求助]移动硬盘无法使用,dmesg 有错误信息
帖子发表于 : 2008-12-09 12:55 

注册: 2008-12-09 12:53
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
呵呵,刚刚解决这个问题,我把硬盘重新在XP下格式化一次,默认的单元格=1K,问题就解决了。你可以试一下。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译