当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]关于HD2000系列驱动
帖子发表于 : 2007-09-19 20:39 

注册: 2007-04-11 23:01
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
我用HD2400Pro AGP显卡,安装驱动后不能进入图形界面
SaX.log里最后有如下记录
(EE) AIGLX error: dlopen of /usr/lib/dri/fglrx_dri.so failed (/usr/lib/dri/fglrx_dri.so: invalid ELF header)
(EE) AIGLX: reverting to software rendering

最后
(II) Loading local sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions//libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
compiled for 7.1.99.902, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0

Backtrace:
0: /usr/sbin/xw(xf86SigHandler+0x81) [0x80cbf81]
1: [0xb7f6f420]
2: /usr/lib/xorg/modules//glesx.so [0xb5c03a24]
3: /usr/lib/xorg/modules//glesx.so [0xb5bfd09c]
4: /usr/lib/xorg/modules//glesx.so [0xb5b903fb]
5: /usr/lib/xorg/modules//glesx.so [0xb5ba2196]
6: /usr/lib/xorg/modules//glesx.so [0xb5b8f3d9]
7: /usr/lib/xorg/modules//glesx.so [0xb5bb8c12]
8: /usr/lib/xorg/modules//glesx.so [0xb5ba6ebd]
9: /usr/lib/xorg/modules//glesx.so [0xb5ba8469]
10: /usr/lib/xorg/modules//glesx.so [0xb5b2f6e3]
11: /usr/lib/xorg/modules//glesx.so [0xb5b24f88]
12: /usr/lib/xorg/modules//glesx.so [0xb5b25670]
13: /usr/lib/xorg/modules//glesx.so(esutInit+0x74) [0xb5b24484]
14: /usr/lib/xorg/modules//glesx.so [0xb5b2017b]
15: /usr/lib/xorg/modules//glesx.so(GlesxExtensionInit+0x9b) [0xb5b1f3fb]
16: /usr/sbin/xw(InitExtensions+0xa2) [0x80eef32]
17: /usr/sbin/xw(main+0x2af) [0x806e66f]
18: /lib/libc.so.6(__libc_start_main+0xdc) [0xb7ce3f9c]
19: /usr/sbin/xw(FontFileCompleteXLFD+0x1e1) [0x806db71]

Fatal server error:
Caught signal 11. Server aborting

即使在Xorg.conf的Section "ServerFlags"中加入Option "AIGLX" "off"
也还是同样的提示AIGLX enabled

另外glrinfo命令不能执行,提示如下
name of display: :0.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
Xlib: extension "XFree86-DRI" missing on display ":0.0".
段错误

不知为何
请高手指点


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-19 21:02 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
看你的驱动用的是什么。也就是用aticonfig配置过了没。

看看这篇文章有用没

http://www.linuxsir.org/bbs/showthread.php?t=312346


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译