当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]又一次被Atheros无线网卡击败。。。。。郁闷中。
帖子发表于 : 2007-09-20 0:18 

注册: 2007-09-17 12:09
帖子: 122
送出感谢: 0 次
接收感谢: 0 次
Ubuntu7.04,ThinkPad T41
安装好后Google到如下步骤,
start up a root console
iwconfig
iwconfig ath0 channel 6
iwlist scan
iwconfig ath0 essid xxxxxx
iwconfig ath0 ap xx.xx.xx.xx.xx.xx
iwconfig ath0 key
dhclient
然后就能上网了,结果刚才莫名其妙的突然就上不去了,再执行一遍也不行,太郁闷了。
另外,我的AP没有设任何WEP密码,结果点桌面右上角网络设置小图标,里面无线连接一栏说 漫游模式已启用
如果选属性进去,取消 启用漫游模式 的话,发现密码类型里面没有 无 这个选项(Windows里面有),结果非得输入密码
不然下面的 确定 按钮就是灰的,这又是怎么回事呢?

看来atheros网卡真是Linux的死对头啊。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-20 8:56 
头像

注册: 2006-10-27 11:14
帖子: 1140
地址: 悉尼
送出感谢: 0 次
接收感谢: 0 次
不是有madWifi么?我的pcmcia卡atheros卡一贯是插上就用的。。。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-09-20 9:05 

注册: 2007-09-17 12:09
帖子: 122
送出感谢: 0 次
接收感谢: 0 次
羡慕。。。。

7。04内置对atheros的支持,是作为被限制的硬件,大概内部用的就是madwifi
现在的问题是貌似网卡也在正常工作,右上角的网络设置小图标里面我的AP也有30%的信号(因为在不同的屋子里)
可是就是上不了网,ping ap也是unreachable,我的ap设置成无密码,结果就只能用漫游模式:啥叫漫游模式?

关键是正常的用了两天了,莫名其妙的就不行了,也不知道从哪儿下手检查。。。。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-09-20 11:37 

注册: 2005-09-29 17:58
帖子: 394
送出感谢: 0 次
接收感谢: 0 次
我的atheros从5.10用到现在都很正常


_________________
Linux debian 2.6.18.1lemote #1 Sat Jan 13 16:02:26 CST 2007 mips GNU/Linux
top - 10:13:17 up 70 days, 11:32 , 1 user, load average: 0.63, 0.61, 0.55


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-09-20 11:56 
头像

注册: 2006-10-27 11:14
帖子: 1140
地址: 悉尼
送出感谢: 0 次
接收感谢: 0 次
JustPS 写道:
羡慕。。。。

7。04内置对atheros的支持,是作为被限制的硬件,大概内部用的就是madwifi
现在的问题是貌似网卡也在正常工作,右上角的网络设置小图标里面我的AP也有30%的信号(因为在不同的屋子里)
可是就是上不了网,ping ap也是unreachable,我的ap设置成无密码,结果就只能用漫游模式:啥叫漫游模式?

关键是正常的用了两天了,莫名其妙的就不行了,也不知道从哪儿下手检查。。。。


atheros的支持很完整了,漫游模式应该是抓到哪个ap用哪个,可以在那个nm-applet直接建立profile,你看看是不是ip没获取到?实在不行的话取消漫游模式,自己指定下静态ip,那个加密选项的确做得很傻,没有的话空白就可以了,不影响的,无法点确定应该是其他选项的问题。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-09-20 12:07 
头像

注册: 2007-08-27 10:46
帖子: 248
送出感谢: 0 次
接收感谢: 0 次
我旧电脑上的Atheros5006可以被7.04正常安装,
新的Atheros5007就完全不行了, 不知7.10会不会修正这个问题呢?
再等一个月看看吧


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-09-20 22:22 

注册: 2007-09-17 12:09
帖子: 122
送出感谢: 0 次
接收感谢: 0 次
我关掉漫游模式,设置essid,密码为空,启用DHCP,果然可以(确定)了,
可是,尽管能够ping通ap,从另外一台win机器上也能ping通T41,可就是上不了网,简直要抓狂。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-09-20 23:11 

注册: 2007-09-17 12:09
帖子: 122
送出感谢: 0 次
接收感谢: 0 次
晕死,现在能ping通AP,Gaim也能上,就是不能上网浏览网页。

我已经把network-manager删掉了,在网络设置里面还是设的dhcp,就是不能上网。抓狂啊。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-09-20 23:31 
头像

注册: 2006-05-26 23:40
帖子: 357
地址: http://ubuntufans.com
送出感谢: 0 次
接收感谢: 0 次
JustPS 写道:
晕死,现在能ping通AP,Gaim也能上,就是不能上网浏览网页。

我已经把network-manager删掉了,在网络设置里面还是设的dhcp,就是不能上网。抓狂啊。


DNS 的问题嘛


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-06-28 11:38 
头像

注册: 2007-08-27 10:46
帖子: 248
送出感谢: 0 次
接收感谢: 0 次
http://www.anywlan.com/bbs/dispbbs.asp? ... r=1&page=1
AR5007的朋友可以用madwifi驱动了


_________________
<a><img></a>


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译