我去哪里找 fglrx-kernel-2.6.12-9-686_8.18.8-1_i386.deb呢???(已解决)

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
yanguang
帖子: 104
注册时间: 2005-12-12 0:30
送出感谢: 0
接收感谢: 0

我去哪里找 fglrx-kernel-2.6.12-9-686_8.18.8-1_i386.deb呢???(已解决)

#1

帖子 yanguang » 2005-12-24 12:06

代码:
sudo apt-get install gcc-3.4 module-assistant build-essential fakeroot dh-make debconf
sudo sh ./ati-driver-installer-8.20.8-i386.run --buildpkg Ubuntu/breezy
cd /tmp
sudo dpkg -i fglrx-control_8.20.8-1_i386.deb
sudo dpkg -i fglrx-kernel-source_8.20.8-1_i386.deb
sudo dpkg -i xorg-driver-fglrx_8.20.8-1_i386.deb
sudo apt-get -f upgrade


现在编译核心驱动:


代码:
sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant a-i fglrx

译注:如果出现错误

代码:
Package fglrx-kernel-source was not built successfully, see
/var/cache/modass/fglrx-kernel-source*buildlog* for details!

这样做:

代码:
cd /usr/src
sudo dpkg -i fglrx-kernel-2.6.12-9-686_8.18.8-1_i386.deb


但是到了这步。。。。。

Updated infos about 1 packages
justin@justin:~$ sudo module-assistant a-i fglrx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
将会安装下列的额外的软件包:
dpatch
建议安装的软件包:
curl
推荐安装的软件包:
patchutils xorg-driver-fglrx kernel-package devscripts
下列【新】软件包将被安装:
dpatch fglrx-kernel-source
共升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 503kB 的软件包。
解压缩后会消耗掉 799kB 的额外空间。
获取:1 http://archive.ubuntu.org.cn breezy/main dpatch 2.0.13 [78.4kB]
获取:2 http://archive.ubuntu.org.cn breezy-security/multiverse fglrx-kernel-source 8.16.20-0ubuntu16.1 [425kB]
下载 503kB,耗时 15s (31.8kB/s)

正在预设定软件包 ...
选中了曾被取消选择的软件包 dpatch。
(正在读取数据库 ... 系统当前总共安装有 88033 个文件和目录。)
正在解压缩 dpatch (从 .../archives/dpatch_2.0.13_all.deb) ...
选中了曾被取消选择的软件包 fglrx-kernel-source。
正在解压缩 fglrx-kernel-source (从 .../fglrx-kernel-source_8.16.20-0ubuntu16.1_i386.deb) ...
正在设置 dpatch (2.0.13) ...
正在设置 fglrx-kernel-source (8.16.20-0ubuntu16.1) ...

Updated infos about 1 packages
Extracting the package tarball, /usr/src/fglrx-kernel-source.tar.gz
justin@justin:~$ cd /usr/src
justin@justin:/usr/src$ sudo dpkg -i fglrx-kernel-2.6.12-9-686_8.18.8-1_i386.deb
dpkg:处理 fglrx-kernel-2.6.12-9-686_8.18.8-1_i386.deb (--install)时出错:
无法访问打包文件: 没有那个文件或目录
在处理时有错误发生:
fglrx-kernel-2.6.12-9-686_8.18.8-1_i386.deb


我去哪里找 fglrx-kernel-2.6.12-9-686_8.18.8-1_i386.deb呢???
就差这步就能装上ati的驱动了阿。。。请大家帮帮忙。。。
我的是k7的最新内核。。。。
yanguang
帖子: 104
注册时间: 2005-12-12 0:30
送出感谢: 0
接收感谢: 0

#2

帖子 yanguang » 2005-12-24 12:43

自己解决了问题。。。。我把tmp里面的fglrx-kernel-source_8.20.8-1_i386.deb 拷贝到/usr/src中。。。然后把命令

译注:如果出现错误

代码:
Package fglrx-kernel-source was not built successfully, see
/var/cache/modass/fglrx-kernel-source*buildlog* for details!

这样做:

代码:
cd /usr/src
sudo dpkg -i fglrx-kernel-source_8.20.8-1_i386.deb

这样就可以了。。。现在9550的3D加速开了。。。好爽阿。。。。
回复

回到 “常用硬件支持”