当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]dell vostro1400 sigmatel 9228音响没声,耳机有声。
帖子发表于 : 2007-10-05 22:08 
头像

注册: 2007-01-16 12:41
帖子: 171
送出感谢: 0 次
接收感谢: 0 次
我的机器是dell vostro1400,主板北桥是ich8m,声卡是HDA的,codes是sigmatel stac9228。

我安装的是ubuntu7.10

安装后,声卡没有正确驱动。没认出来。安装后一直处于联网状态。重启了一次后识别了声卡,估计是更新了。识别后,系统并没有声音。但是耳机测试后是有声音的。

耳机状态,系统启动的声音没有。音量图标显示正常。可以调节。如果就耳机来看,一起正常。

为了解决这个问题,我google了一下,得到这个东西。但是看不明白是啥意思。请英文比较硬的同学来看看。
https://lists.ubuntu.com/archives/kernel-team/2006-June/000899.html

[PATCH] [UBUNTU:sound/pci/hda/] Add support for Sigmatel 922[7-9] HDA codecs
crimsun at fungus.sh.nu crimsun at fungus.sh.nu
Fri Jun 2 22:20:46 BST 2006

* Previous message: [PATCH] [UBUNTU:sound/pci/hda/] Add support for more Sony Vaio models
* Next message: [PATCH] [UBUNTU:sound/pci/ac97/] Add ThinkPad T41p to Jack Sense blacklist
* Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

Subject: [PATCH] [UBUNTU:sound/pci/hda/] Add support for Sigmatel 922[7-9] HDA codecs

UpstreamStatus: Added in upstream alsa-kernel hg changeset 40ddbbdaa655
http://hg-mirror.alsa-project.org/alsa- ... ;style=raw

This commit from Takashi Iwai adds support for the Sigmatel 922[7-9]
HDA codecs.

Signed-off-by: Daniel T Chen <crimsun at ubuntu.com>
Signed-off-by: Matt Porter <mporter at embeddedalley.com>

---

sound/pci/hda/patch_sigmatel.c | 6 ++++++
1 files changed, 6 insertions(+), 0 deletions(-)

9aebbcf7384cd1f9ec522feee0634ffafaa1e3a0
diff --git a/sound/pci/hda/patch_sigmatel.c b/sound/pci/hda/patch_sigmatel.c
index 3d4967c..b2e38fd 100644
--- a/sound/pci/hda/patch_sigmatel.c
+++ b/sound/pci/hda/patch_sigmatel.c
@@ -1367,6 +1367,12 @@ struct hda_codec_preset snd_hda_preset_s
{ .id = 0x83847681, .name = "STAC9220D/9223D A2", .patch = patch_stac922x },
{ .id = 0x83847682, .name = "STAC9221 A2", .patch = patch_stac922x },
{ .id = 0x83847683, .name = "STAC9221D A2", .patch = patch_stac922x },
+ { .id = 0x83847618, .name = "STAC9227", .patch = patch_stac922x },
+ { .id = 0x83847619, .name = "STAC9227", .patch = patch_stac922x },
+ { .id = 0x83847616, .name = "STAC9228", .patch = patch_stac922x },
+ { .id = 0x83847617, .name = "STAC9228", .patch = patch_stac922x },
+ { .id = 0x83847614, .name = "STAC9229", .patch = patch_stac922x },
+ { .id = 0x83847615, .name = "STAC9229", .patch = patch_stac922x },
{ .id = 0x83847620, .name = "STAC9274", .patch = patch_stac927x },
{ .id = 0x83847621, .name = "STAC9274D", .patch = patch_stac927x },
{ .id = 0x83847622, .name = "STAC9273X", .patch = patch_stac927x },
--
1.1.3


--
Daniel T. Chen crimsun at ubuntu.com
GPG key: www.sh.nu/~crimsun/pubkey.gpg.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : https://lists.ubuntu.com/archives/kerne ... chment.pgp

* Previous message: [PATCH] [UBUNTU:sound/pci/hda/] Add support for more Sony Vaio models
* Next message: [PATCH] [UBUNTU:sound/pci/ac97/] Add ThinkPad T41p to Jack Sense blacklist
* Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

More information about the kernel-team mailing list


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-05 23:45 
头像

注册: 2007-01-16 12:41
帖子: 171
送出感谢: 0 次
接收感谢: 0 次
今天我实在受不了了决定尝试一下编译新驱动。上网找教程。
找到这个《Ubuntu 7.04 安装 High Definition Audio Controlle0驱动》根据教程我下载了相关的程序。
在安装前,我查看了我的系统alsa驱动的版本。结果是我的驱动已经是最新的了。就在我踌躇是否自己编译驱动时看到了文章的最后一节:

到这里后,你重启一下机器,看看有没有声音,如果还是没有,那就修改/etc/modprobe.d/alsa-base
sudo gedit /etc/modprobe.d/alsa-base
在最后加上下面两行
options snd-hda-intel model=3stack
options snd-hda-intel probe_mask=1

我想既然我的驱动已经是最新的了,还没有声音,会不会是没有这两行的原因。死马当活马医了。是试试不是坏事。

修改,重启。进入系统发现有一些变化。系统音量图标上有个红叉叉。我打开一看是“front“项目被禁用了。打开,启动播放器,声音从音响里出来了。

哦,天阿!妙不可言!


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-21 2:03 

注册: 2005-03-30 19:38
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
呵呵!不错做个标记


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-21 2:08 
头像

注册: 2006-12-23 13:46
帖子: 9203
地址: Azores Islands
送出感谢: 0 次
接收感谢: 1
Ubuntu 写道:
呵呵!不错做个标记


现在最便宜的低配1400-n 官方报价是4099元------4000元级别最超值的本本。


_________________
no security measure is worth anything if an attacker has physical access to the machine


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-22 12:06 

注册: 2007-04-20 10:14
帖子: 61
送出感谢: 0 次
接收感谢: 0 次
非常感谢,已经解决声卡问题,真是太棒了!!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-05 5:36 

注册: 2008-04-17 11:10
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
谢谢二楼
问题已解决


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [问题]dell vostro1400 sigmatel 9228音响没声,耳机有声。
帖子发表于 : 2009-11-09 17:41 
头像

注册: 2007-01-16 12:41
帖子: 171
送出感谢: 0 次
接收感谢: 0 次
用上1400两年多。ubuntu对其支持是越来越好了(全是intel的东西,哈哈)。找到这个老帖回顾一下。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [问题]dell vostro1400 sigmatel 9228音响没声,耳机有声。
帖子发表于 : 2009-11-09 17:49 
头像

注册: 2008-11-13 11:39
帖子: 1745
送出感谢: 4
接收感谢: 2
晕,我还想 是谁把这么老的帖翻出来了呢。

呵呵.

我也用 dell vostro 1400,没到两年。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译