当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求教OSS声卡驱动安装问题?
帖子发表于 : 2007-10-11 21:21 

注册: 2007-10-07 15:12
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
本人是清华同方K100笔记本,Nvidia MCP51芯片组,声卡显示是sigmatel stac9200,安装ubuntu 7.04后始终没有声音,按论坛中相关帖子都试了一遍,都没用,故下载OSS试试,出现错误信息如下,请教是什么问题,如何解决?


kaiquan@tubuntu:~/Desktop$ sudo dpkg -i oss-linux_v4.0-1006_i386.deb
(正在读取数据库 ... 系统当前总共安装有 93843 个文件和目录。)
正预备替换 oss-linux v4.0-1006 (使用 oss-linux_v4.0-1006_i386.deb) ...
sh: Can't open /usr/lib/oss/scripts/restore_drv.sh
dpkg:警告 - 原先的 pre-removal 脚本 退出时返回了错误号 2
dpkg - 现转而试用新软件包所带的脚本...
sh: Can't open /usr/lib/oss/scripts/restore_drv.sh
dpkg:处理 oss-linux_v4.0-1006_i386.deb (--install)时出错:
子进程·新的 pre-removal 脚本·返回了错误号·2
Building OSS Modules for Linux-unknown 2.6.20-15-generic
cd: 3: can't cd to /usr/lib/oss/build
sh: Can't open install.sh
Starting Open Sound System
/usr/sbin/soundon: 27: cannot create /usr/lib/oss/logs/soundon.log: Directory nonexistent
cat: /usr/lib/oss/version.dat: No such file or directory
/usr/sbin/soundon: 28: cannot create /usr/lib/oss/logs/soundon.log: Directory nonexistent
/usr/sbin/soundon: 30: cannot create /usr/lib/oss/logs/soundon.log: Directory nonexistent
/usr/sbin/soundon: 32: cannot create /usr/lib/oss/logs/soundon.log: Directory nonexistent
/usr/sbin/soundon: 38: cannot create /usr/lib/oss/logs/soundon.log: Directory nonexistent
/usr/sbin/soundon: 38: cannot create /usr/lib/oss/logs/soundon.log: Directory nonexistent
/usr/sbin/soundon: 45: cannot create /usr/lib/oss/logs/soundon.log: Directory nonexistent
No /usr/lib/oss/etc/installed_drivers - cannot continue
在处理时有错误发生:
oss-linux_v4.0-1006_i386.deb


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-15 22:01 

注册: 2007-10-07 15:12
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
以上问题我终于搞定了,参照这个帖子http://forum.ubuntu.org.cn/viewtopic.php?t=72757&highlight=soundon总算装上了oss,播放mp3终于有了声音,但没有系统音效,面板上的小喇叭打着叉,请高手赐教!

以下是安装错误的解决方法:
1) cd /var/lib/dpkg/info
2) sudo rm oss-linux*
3) sudo gedit /var/lib/dpkg/status
寻找下面一段话删除掉
Package: oss-linux
Status: install ok installed
Priority: extra
Section: alien
Installed-Size: 8440
Maintainer: root <root@dev-desktop>
Architecture: amd64
Version: v4.0rc9-999
Depends: libatk1.0-0 (>= 1.12.1), libc6 (>= 2.4-1), libcairo2 (>= 1.2.4), libfontconfig1 (>= 2.3.0), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.10.3), libpango1.0-0 (>= 1.14.5), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxfixes3, libxi6, libxinerama1, libxrandr2, libxrender1
Conffiles:
/etc/oss.conf 055432d38aaf37fc6de3dba4a95accc3
Description: Open Sound System sound drivers for Linux
Open Sound System for Linux (OSS/Linux) is a commercial quality sound driver
distributed by 4Front Technologies (http://www.opensound.com). OSS provides
support for practically all sound cards on the market including PnP and
many PCI ones. Installation and configuration is higly automated and easy to
perform. To obtain technical support and additional features, you will need to
order a license key from http://www.opensound.com/order.html
.
(Converted from a rpm package by alien version 8.64.)

然后重装oss驱动即可。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-02-12 19:57 

注册: 2008-02-02 20:27
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我的 也是这状况!!期盼高手阿!!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-04-30 18:23 

注册: 2007-01-06 12:20
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
我的本跟楼主一样啊。
貌似oss安装起来没问题。。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译