当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ati x700 安装7.10默认驱动 无法正常进入界面(已经解决,显示器参数原因)
帖子发表于 : 2007-10-17 9:34 

注册: 2007-08-15 15:10
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
如题
很奇怪的问题
前天升级的时候顺利安装过驱动 正常使用
但是昨天改了一下xorg.conf (改之前已备份)
但是重新启动X以后 出现问题 首先驱动已经无效,登录界面花屏,然后屏幕闪几下
进入到一个提示:低效果配置,需要配置显示器和显卡驱动.
然后配置fglrx ,LCD 1027*768@60 再重启 结果还是花屏 ,跟上面一样
后来进入到回复命令行 。恢复备份的xorg.conf。结果还是样.登录界面花屏.后来论坛一些帖子说的手工配置FGLRX但是还是一样结果
无奈。只要是用vesa了.我是新手 下面附带我的xorg.conf
希望哪位朋友可以帮忙看看
代码:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
#   sudo dpkg-reconfigure -phigh xserver-xorg
Section "Files"
   FontPath   "/usr/share/fonts/wenquanyi/wqy-bitmapfont/"
EndSection

Section "Module"
   Load      "glx"
   Load      "GLcore"
   Load      "v4l"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"   "/dev/input/mice"
   Option      "Protocol"   "ImPS/2"
   Option      "ZAxisMapping"   "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "Device"
   Identifier   "Failsafe Device"
   Boardname   "vesa"
   Busid      "PCI:5:0:0"
   Driver      "vesa"
   Screen   0
EndSection

Section "Monitor"
   Identifier   "Failsafe Monitor"
   Vendorname   "Generic LCD Display"
   Modelname   "LCD Panel 1024x768"
   Horizsync   31.5-48.0
   Vertrefresh   56.0 - 65.0
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
   Gamma   1.0
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Failsafe Device"
   Monitor      "Failsafe Monitor"
   Defaultdepth   24
   SubSection "Display"
      Depth   24
      Virtual   1024   768
      Modes      "1024x768@60"   "800x600@60"   "800x600@56"   "640x480@60"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen 0 "Default Screen" 0 0
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
EndSection
Section "device" #
   Identifier   "device1"
   Boardname   "vesa"
   Busid      "PCI:5:0:0"
   Driver      "vesa"
   Screen   1
EndSection
Section "screen" #
   Identifier   "screen1"
   Device      "device1"
   Defaultdepth   24
   Monitor      "monitor1"
EndSection
Section "monitor" #
   Identifier   "monitor1"
   Gamma   1.0
EndSection
Section "ServerFlags"
EndSection


最后由 bzzjh 编辑于 2007-10-18 14:48,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-17 17:25 

注册: 2007-08-23 8:05
帖子: 57
送出感谢: 0 次
接收感谢: 0 次
我也是X700的显卡哦

代码:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/fonts/wenquanyi/wqy-bitmapfont/"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"   "/dev/input/mice"
   Option      "Protocol"   "ImPS/2"
   Option      "ZAxisMapping"   "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "stylus"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "eraser"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"   "cursor"
   Option      "ForceDevice"   "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "ATI Technologies Inc RV410 [Radeon X700 (PCIE)]"
   Driver      "fglrx"
   Busid      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "Philips 107S6"
   Option      "DPMS"
   Horizsync   28-69
   Vertrefresh   43-85
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Technologies Inc RV410 [Radeon X700 (PCIE)]"
   Monitor      "Philips 107S6"
   Defaultdepth   24
   SubSection "Display"
      Modes      "1024x768"   "800x600"   "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
  screen "Default Screen"
   Inputdevice   "Generic Keyboard"
   Inputdevice   "Configured Mouse"
   
   # Uncomment if you have a wacom tablet
   #   InputDevice     "stylus"   "SendCoreEvents"
   #   InputDevice     "cursor"   "SendCoreEvents"
   #   InputDevice     "eraser"   "SendCoreEvents"
EndSection
Section "Module"
   Load      "glx"
EndSection
Section "Extensions"
   Option      "Composite"   "0"
EndSection


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-18 14:47 

注册: 2007-08-15 15:10
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上这位朋友的帮忙 ,不管如何现在我的问题解决了.
主要的原因是7.10新增加的一个功能Screen and Graphics Preferences 里面配置不了我的显示器(三星151s ,比较老的一款15寸液晶),如果选择默认的LCD 1024*768 无法进入到桌面,登录界面花屏,然后是低配置进入桌面

大致跟LS这位朋友的xorg.conf差不多,唯一的差别是自己在网上找了一下我的显示器的水平和垂直扫描的参数

引用:
Section "Monitor"
Identifier "Syncmaster 153v/153s/153b"
Option "DPMS"
Horizsync 30-60
Vertrefresh 56-75



Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc RV410 [Radeon X700 (PCIE)]"
Monitor "Syncmaster 153v/153s/153b"
Defaultdepth 24
SubSection "Display"
Depth 24
Viewport 0 0
Virtual 1024 768
Modes "1024x768" "800x600" "640x480"
EndSubSection

EndSection


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Sogou [Spider] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译