当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [大道消息]AMD 8.42.4 display driver is here!
帖子发表于 : 2007-10-19 6:32 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
虽然只是昙花一现,但还是有部分眼尖的家伙记录下来了。
http://digg.com/linux_unix/AMD_8_42_4_D ... LX_Is_Here

现在phoronix的这个链接换成了ubuntu studio 7.10,但原来可是轰动一时的ati 8.42.4的相关信息。

现摘录原文,大家不要太兴奋哦~
估计要不明天,要不就这几天。

引用:
For ATI Linux customers, last month was certainly an exciting time from AMD announcing open specifications (and the subsequent delivery of the first batch and the creation of the RadeonHD driver) to the release of the fglrx 8.41 display driver. The AMD 8.41.7 driver was the first driver to be based upon AMD's new code-base and had not only delivered R600 support for the Radeon HD 2900XT, but clear performance improvements across the board from the R300 to the R500. However, this 8.41.7 driver was not well received by all. AMD had intended this driver to be targeted solely for the R600 customers, but many with older GPUs had immediately upgraded with some then having a foul experience.

Today it's now time where the fglrx driver reaches yet another milestone.
Not only does today's release address many of the outstanding bugs for the earlier GPUs while also introducing a few new features, but also it delivers AIGLX support! Yes, you read that right. You can finally run your ATI graphics card with the fglrx driver and run Compiz, Beryl, or Compiz Fusion without using XGL! This is coming 13 months after NVIDIA had introduced its AIGLX support, but now in time for Ubuntu 7.10 Gutsy Gibbon it's here for ATI hardware. Granted, if you were using an older ATI GPU with the open-source Radeon driver, you could have been benefiting from AIGLX already.

In addition to the AIGLX support, the fglrx 8.42.4 driver includes X.Org server 1.4 support, video playback improvements, more performance improvements, and Rialto AGP fixes. While this driver quite promptly supports X.Org 7.3 / X server 1.4, it does not contain Linux 2.6.23 kernel support. The Linux 2.6.23 support isn't found in fglrx 8.42.4 due to issues with x86_64 support. However, we do expect that fglrx 8.43 will contain the Linux 2.6.23 kernel support.

The video playback improvements consist of a fix in TexturedVideo playback, which should result in smoother video playback. Though if you do continue running into TexturedVideo (X-Video) playback problems, be sure to report them in the Phoronix Forums. Likewise, the AGP (Rialto bridge) problem should be resolved, but report it if you're continuing to run into problems.

This release is tested for all ATI Radeon GPU products from the R300 to R600 series. This does not include support for the FireGL series, but the workstation compatibility will be introduced next month in fglrx 8.43.

While not nearly as exciting as the AIGLX support, the fglrx 8.42.4 driver also contains a few AMD Catalyst Control Center (AMDCCCLE) improvements. The 3D area of the control center (AMDCCCLE v1.5) has been reworked and now features improved anti-aliasing and anisotropic filtering controls as well as a vertical refresh control. When adjusting the AA and AF overrides, there is now a preview pane that shows a picture at that AA or AF level and a close-up view where any jaggies can be seen.

While this is a great improvement for the Catalyst Control Center, the anti-aliasing and anisotropic filtering can be improved. Presently the AA can be overridden only up to 8x while AF goes up to 16x. Now that the fglrx performance problems have been resolved, it would be really nice to see 16x AA support and ideally even their new adaptive or multi-sampling AA modes supported by their newer GPUs. This driver does introduce support for AA and AF on the R600 series.

From the "More Settings" page, the vertical refresh setting can be set to: always off, off - unless application specifies, on - unless application specifies, or always on. Now that the fglrx driver is on its new codebase and there are a few AMDCCCLE improvements already, don't be surprised if CATALYST AI makes its debut on Linux in the very near future for enhanced performance.

Now onto arguably the most sought after feature... AIGLX. It's been a long time coming, and it's here today, but there are a few words of caution. Be forewarned that there is a bug in Compiz 0.3 affecting the fglrx 8.42.4 driver and there may be a few other situations where Compiz or Compiz Fusion may not work immediately. The bug found in Compiz 0.3 and that's causing havoc with fglrx 8.42.4, has been resolved in Compiz 0.6. Next month in fglrx 8.43, AMD will be introducing a workaround for Compiz 0.3 support. If you try enabling the "desktop effects" in Fedora 7 with fglrx 8.42.4, it will fail. However, if you install Beryl or Compiz Fusion on Fedora 7 from a repository, it should work.

At Phoronix we have tested Ubuntu 7.10 "Gutsy Gibbon" quite extensively with the fglrx 8.42 series and have found it to work well with Compiz Fusion and its default effects. Whether you're using Ubuntu or another distribution, be sure to add "fglrx" to the Compiz driver white list, if needed. If you want more than pictures, in the new video area of Phoronix announced earlier today, there is a video of the fglrx 8.42 driver with Compiz Fusion Ubuntu 7.10. We also have two videos of the Radeon HD 2900XT with fglrx 8.42 running Enemy Territory: Quake Wars with all settings maxed (Video 1 and Video 2).

We'll have another article out shortly dedicated to using the fglrx driver with Compiz Fusion, but we will say that the experience has been very smooth and has been working great. Using a Radeon HD 2900XT has worked out great with Compiz Fusion as well, but we have run into a few small bugs where for example when alt-tabbing the windows during that effect have been white. Nevertheless, the bugs we have run into have not been show stopping aside from the compatibility issues with old versions of Compiz. If you are running an ATI Radeon X300 or another low-end Radeon graphics card with a slow single-core CPU, don't expect to get much out of AIGLX. Like NVIDIA, you do need a modestly powered graphics card and processor in order to be able to handle the advanced Compiz or Compiz Fusion effects.

Last month with fglrx 8.41.7 we saw some massive performance improvements on all of ATI's supported Radeon products, but that's not the end of the performance improvements. With fglrx 8.42.4 we had experienced some smaller performance boosts as well. We are continuing our testing of the fglrx 8.42.4 driver and may deliver some additional benchmarks shortly.

With Unreal Tournament 3 and Enemy Territory: Quake Wars for Linux, this timing of AMD's 8.41.7/8.42.4 driver has worked out phenomenally. With the 8.42.4 driver and a supported Radeon graphics card, you should be able to experience a great frame-rate for your hardware, stunning image quality and be easily able to manipulate the 3D settings through AMDCCCLE, AIGLX support with Compiz or Compiz Fusion should you chose to do so, smooth video playback through TexturedVideo, and all around a great experience. We have been running the ATI 8.42 driver for a couple weeks internally on different graphics cards, and aside from the problems mentioned in this article, we haven't been plagued by any other issues.

If you run into any new problems or still outstanding bugs with fglrx 8.42.4, be sure to report them in the Phoronix Forums. The fglrx 8.42 doesn't include Linux 2.6.23 kernel support by default, but if you are in a rush, check out the forums for patches. We'll be back next month telling you about the new features in fglrx 8.43.


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译