当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [讨论]我的A9550在7.10驱动的安装问题,用的是XGL+受限驱动,基本上可以解决3D效果
帖子发表于 : 2007-10-20 23:46 

注册: 2007-04-08 1:32
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
7.04从网上找到的a卡官方驱动及XGL的安装方法
首先是XGL的安装和设置
下面是XGL的安装,很简单的.
首先下载安装
代码:
sudo apt-get install xserver-xgl

然后,创建一个开机加载XGL的脚本文件
代码:
sudo gedit /usr/local/bin/startxgl.sh

在文件中输入
代码:

#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session

给刚才的文件赋予相关权限
代码:
sudo chmod a+x /usr/local/bin/startxgl.sh

再创建一个XGL进程的文件
代码:
sudo gedit /usr/share/xsessions/xgl.desktop

输入
代码:

[Desktop Entry]
Encoding=UTF-8
Name=GNOME with XGL
Comment=
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application

赋予文件可执行权限
代码:
sudo chmod a+x /usr/share/xsessions/xgl.desktop

官方驱动的安装,7.04我是直接先装受限驱动,然后从官网上下载最新的驱动用sudo ./驱动名就可以安装成功了
到了7.10只能装完受限驱动后,升级到最新的驱动版本(8.40)总是不成功,不过虽然不能升级,COMPIZ我已经可以正常使用了[/quote]


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-20 23:49 

注册: 2007-04-11 17:39
帖子: 153
送出感谢: 0 次
接收感谢: 0 次
会觉得卡吗
我的a9600
觉得系统自带的驱动还不错
用xgl反而更卡,开个ff半天才出来


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-20 23:57 

注册: 2007-04-08 1:32
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
“自带的驱动”是指不安装受限驱动吗?
不安装XGL我这里不能开启compiz


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译