昨天晚上试到2点的,结果:发现删除xorg.conf就可以进入X了!!!!

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
头像
uusky
帖子: 159
注册时间: 2006-09-02 10:02
送出感谢: 0
接收感谢: 0
联系:

昨天晚上试到2点的,结果:发现删除xorg.conf就可以进入X了!!!!

#1

帖子 uusky » 2007-10-23 9:07

当时,我发现有这样的规律的时候,我大吃一惊!

我的显卡是nvidia GeForce FX5200 Ultra的。刚装系统(装过6.04,6.10,7.04)的时候都是很正常的。包括刚升级到7.10时都是很正常的。(这里正常的概念就是X能进入,不会出现什么错误提示!但不是说3D能搞定!)

7.10之前,弄3D的时候,都是从nvidia官网上下载驱动安装的。每次升级内核后,就是一阵子捣鼓!(尤其是6.10时,痛苦死了啊!7.04时,不知道怎么搞的,升级内核都没有让重装显卡驱动。但是有一点可以确定,就是进入X前,都是出现nvidia的lego画面的!)

本来相安无事,正印证那句话“世间本无事,庸人自扰之!”问题导火线在这里:升级到7.10时,发现自己以前一直用的很好的Compiz Fusion,居然开启不了了!我就到处找什么原因啊!自认为显卡驱动有问题!于是把什么“”改成“nv nvidia_new”,xorg.conf重新配置了一下!受限驱动什么的,勾号去调,提示卸载驱动,我yes了,再把勾号勾上,提示我安装驱动。我也yes了!提示重启,我觉得这么一折腾,应该查不错了啊!呵呵,结果,连X都进不了了!

我一直不想安装官网下载的驱动,以免升级内核时的痛苦。(当然这里还有一个疑问,7.04为什么没有提示重装驱动呢?)经历漫长的google和泡坛子,经历了“无数次”(大于20次以上)失败,发现有几次搞定后,能进入X。在X搞了一下,重启后就进入不了了!

昨天晚上按着这个好帖“刚搞定Nvidia显卡驱动安装(已更新)”viewtopic.php?t=75933。上面提到一些删除驱动的方法。我反复试验,重启机器。
(这里卸载和安装都是使用新立得)按上贴的办法把nvidia-glx-new删了,再重装nvidia-glx-new。当然我的DISABLED_MODULES改了"nv nvidia_new"以后一直没有变!再把xorg.conf配置好了后,X就是进入不了。当时反复都是这样,搞得X11目录下,xorg.conf.*文件巨多,我一怒之下把他们都部拉出去砍了!本想休息的,也偶然输错了命令,关机变成了重启!呵呵。居然能进入X。呵呵。有实验了几次,发现只要把xorg.conf删了就可以进入X。虽然进入的时候,屏幕向右偏。但是也没有办法调整。(似乎一调整,就需要xorg.conf文件!)在什么受限驱动界面里面,我那两个都是没有打勾的。即使我把它勾上,然后安装重启。似乎就进不了了X。但是再在终端里面把xorg.conf删了,就可以X了。

当然skyx倡导的把live CD时的xorg.conf拷贝过来,我也试过。也没有用。唉,跟xorg.conf有仇啊!跟它拼了!
望诸位出谋划策啊!
头像
夜泊枫桥
帖子: 333
注册时间: 2007-04-03 22:18
送出感谢: 0
接收感谢: 0

#2

帖子 夜泊枫桥 » 2007-10-23 11:14

:shock: 楼主有耐心
头像
uusky
帖子: 159
注册时间: 2006-09-02 10:02
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 uusky » 2007-10-23 12:27

NND!这次拼了,我一定要用源里面的东西把他搞定!不搞定也查出是什么原因。

MMD,老子跟它矛上了!!!
头像
zzswang
帖子: 15
注册时间: 2007-03-07 11:01
送出感谢: 0
接收感谢: 0

#4

帖子 zzswang » 2007-10-23 13:02

就是驱动的问题 我也是8600GT显卡 装上驱动后重起 无法进入X

看这个帖子的最后一部分,就是症状描述 和楼主类似
viewtopic.php?t=82651&highlight=

我的解决办法是把driver 改为默认的“nv” 于是可以进入系统
这是迫不得已的办法.我想楼主曾今能进X 也可能是使用了原有驱动吧

望解决后一定要告知一声
头像
ptptptptptpt
帖子: 3711
注册时间: 2006-09-19 18:16
送出感谢: 0
接收感谢: 1 次

#5

帖子 ptptptptptpt » 2007-10-23 13:12

偶记得装了 nvidia-glx-new 之后,还得运行一下 nvidia-config 什么的
头像
ptptptptptpt
帖子: 3711
注册时间: 2006-09-19 18:16
送出感谢: 0
接收感谢: 1 次

#6

帖子 ptptptptptpt » 2007-10-23 13:15

删除 xorg.conf 后用的是 xorg 自带的 nv 驱动
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#7

帖子 jarryson » 2007-10-23 13:59

xorg-server 1.3以上似乎是不需要xorg.conf文件的。不过大多数时候是在你用户目录下应该有xorg.conf文件。
头像
uusky
帖子: 159
注册时间: 2006-09-02 10:02
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 uusky » 2007-10-24 3:39

jarryson:

可是我的home目录下也没有xorg.conf文件阿!照样能启动。呵呵。

home目录下多了一个.nvidia-settings-rc文件
-------------------------------------------
#
# /home/uusky/.nvidia-settings-rc
#
# Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
# Generated on Tue Oct 23 00:03:36 2007
#

# ConfigProperties:

RcFileLocale = C
ToolTips = Yes
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = No
ShowQuitDialog = Yes

# Attributes:
-------------------------------------------
不知道是什么意思?
头像
uusky
帖子: 159
注册时间: 2006-09-02 10:02
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 uusky » 2007-10-24 9:02

昨晚最新战况:

其实有无xorg.conf文件并不是关键,关键在于xorg.conf文件中Section "Device中的Driver "nvidia"!如果他设为nvidia,就是启动不了X!(改成nv就可以启动X了。呵呵。我个人觉得这里“显卡驱动”的模块名,待高手确认!名字一改就找不到模块了。是不是就启动不来了???)如果,在X界面首先驱动管理器里面,选择nvidia驱动的话,这里就会被改成“nvidia”,X就启动不来!

还有就nvida-xconfig不知道是不是只是修改xorg.conf文件啊?因为我没有证实到底是那一步把/etc/default/linux-restricted-modules-common文件中的DISABLED_MODULES老是修改成="nvidia nvidia_legacy"不知道这个是什么意思啊?就是说这两个模块不能载入???

还请诸位高手指点啊!
头像
uusky
帖子: 159
注册时间: 2006-09-02 10:02
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 uusky » 2007-10-24 9:14

请高手确认,要不我晚上回去再试试。

1:Driver 指定的是不是显卡驱动的模块名?
2:DISABLED_MODULES指定的是不是禁止载入的模块名?

如果两个问题回答都是yes的话。
那么Driver指定的东西出现在DISABLED_MODULES中话,是不是启动就会失败呢?

这样的话,为什么好多帖子建议把DISABLED_MODULES改成“nv nvidia_new”!nvidia_new是不是对应的是nvidia-glx-new安装的模块呢?
spectator
帖子: 178
注册时间: 2007-10-20 20:15
送出感谢: 0
接收感谢: 0

#11

帖子 spectator » 2007-10-24 10:04

uusky 写了:jarryson:
可是我的home目录下也没有xorg.conf文件阿!照样能启动。呵呵。
这个文件应该是执行Xorg -configure后自动生成的配置文件吧,而且不是在当前用户目录下,而是 /root,
如果没有 /etc/X11/xorg.conf这个文件,可能是会先调用 Xorg-configure生成一个临时的.以上个人猜测,不要当真.

代码: 全选

spectator@disguise / # ls /root/
xorg.conf.new
头像
zzswang
帖子: 15
注册时间: 2007-03-07 11:01
送出感谢: 0
接收感谢: 0

#12

帖子 zzswang » 2007-10-24 22:07

可能问题还是出在新驱动本身上
唉,心衰力竭啊
头像
uusky
帖子: 159
注册时间: 2006-09-02 10:02
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 uusky » 2007-10-25 9:35

昨天在IRC里面,遇到了aeo,ee,smallzhan……等一批高手!呵呵。

但是最后,我不幸累倒(睡着了)!(前两天一直没有睡好,前天夜里才睡了几个钟头。早晨差点迟到!)我发现自己在蛮干,不得法!

还是想好,怎么查,才能查出原因!这才是正道!唉!aeo昨天帮了不少忙!还有ee等!!
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#14

帖子 dogfox » 2007-10-25 10:17

看源代码啊

字体路径

代码: 全选

Section "Files"
	Fontpath	"/usr/share/fonts/yahei"
GDM分辨

代码: 全选

		Depth	24
		Modes		"1024x768"  "1280x1024" "1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"	"640x350"
	EndSubSection
EndSection
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
炎羽
帖子: 91
注册时间: 2007-09-22 2:05
送出感谢: 0
接收感谢: 0

#15

帖子 炎羽 » 2007-10-25 11:12

很明显的驱动冲突了,看看这里http://hi.baidu.com/csx163/blog/item/033c8735aeb5881290ef39ae.html

本人系统为UBUNTU7.10,其他发行版请触类旁通。。。

1、下载驱动
http://www.nvidia.com/page/home.html
在下下载的就是NVIDIA-Linux-x86-100.14.23-pkg1.run这个文件
2.删除原驱动包
sudo apt-get --purge remove nvidia-glx
然后删除 /lib/linux-restricted-modules/2.6.22-14-generic/文件夹下面带有nvidia字样的内容,这里是内核自带的驱动
再检查一下
/etc/init.d/nvidia-glx
/etc/init.d/nvidia-kernel
这两个文件是否存在,删除


3、安装要用到的软体
sudo apt-get install build-essential pkg-config xserver-xorg-dev linux-headers-`uname -r`
安装编译包

4备份
sudo cp /etc/default/linux-restricted-modules-common /etc/default/linux-restricted-modules-common.backup
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

5.禁止系统使用默认的驱动
sudo gedit /etc/default/linux-restricted-modules-common
在最后的双引号中添加nv nvidia_new,即“”改成“nv nvidia_new”
如果前面第二步删除完整了其实也可以不用执行这一步

6.停止GDM进程
sudo /etc/init.d/gdm stop
按Ctrl+Alt+F1,登录后

7.进入下好的驱动所在目录(用ls命令确认文件在不在)
sudo sh NVIDIA-Linux-x86-100.14.23-pkg1.run
安装过程中,
如果提示有旧驱动,询问是否删除旧驱动,选Yes;
如果提示缺少某某模块(modules),询问是否上网下载,选no;
如果提示编译模块,询问是否进行编译,选ok;
如果提示将要修改Xorg.conf,询问是否允许,选Yes;
接下来就是等待安装完成

8.安装完成就回到终端,重启GDM
sudo /etc/init.d/gdm restart

ok了,当看到NV的logo后,安装成功。

如果实在不想看NVIDIA的LOGO,可以修改 /etc/X11/xorg.conf
在Section "Device"中添加Option "NoLogo" "True"
如:
Section "Device"
Identifier "通用显示卡"
Driver "nvidia"
Option "NoLogo" "True"
EndSection
回复

回到 “常用硬件支持”