[问题] Ubuntu 7.04 升级7.10 后不能自动挂载U盘 [已解决]

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
lfjlost
帖子: 10
注册时间: 2007-05-30 20:52
送出感谢: 0
接收感谢: 0

[问题] Ubuntu 7.04 升级7.10 后不能自动挂载U盘 [已解决]

#1

帖子 lfjlost » 2007-10-25 13:31

郁闷!Ubuntu 7.04 升级7.10 后不能自动挂载U盘
在7.04下是非常正常的,通过网络升级以后7.10后,先后也出现了一些小的问题,差不多已经解决了,可是突然发现不能自动挂载U盘了,光盘还是能够自动的认出的
下面是
antonio@antonio-desktop:~$ dmesg |tail
[11275.184000] sdb: assuming drive cache: write through
[11275.184000] sdb: unknown partition table
[11275.188000] sd 6:0:0:0: Attached scsi removable disk sdb
[11275.188000] sd 6:0:0:0: Attached scsi generic sg1 type 0
[11276.348000] FAT: Unrecognized mount option "usefree" or missing value
[11311.244000] FAT: Unrecognized mount option "usefree" or missing value
[11463.004000] FAT: Unrecognized mount option "usefree" or missing value
[11504.908000] FAT: Unrecognized mount option "usefree" or missing value
[11534.796000] FAT: Unrecognized mount option "usefree" or missing value
[11540.708000] FAT: Unrecognized mount option "usefree" or missing value
/etc/fstab信息为
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda10
UUID=fad40e0f-90a9-416b-968e-11327283b552 / ext3 defaults,errors=remount-ro 0 1
# /dev/sda1
# UUID=45F5-78C9 /media/sda1 vfat defaults,utf8,umask=007,gid=46 0 0
# /dev/sda5
# UUID=8BEA-F196 /media/sda5 vfat defaults,utf8,umask=007,gid=46 0 0
# /dev/sda6
# UUID=AC10326CB7F478C1 /media/sda6 ntfs defaults,nls=utf8,umask=007,gid=46 0 0
# /dev/sda7
# UUID=68BF206C4821B4C4 /media/sda7 ntfs defaults,nls=utf8,umask=007,gid=46 0 0
# /dev/sda8
# UUID=46AD-COOB /media/sda8 vfat defaults,utf8,umask=007,gid=46 0 0
# /dev/sda9
UUID=e2f14bf9-1448-91a0-6a9b-883b846adacb none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/sda8 /media/sda8 vfat defaults,utf8,umask=007,gid=46 0 0
你们有没有出现这种情况,论坛里有一个是这个样子的,貌似现在还没有解决
请指教


已解决
其实,都是我瞎折腾,我用了一个老的内核,结果就出问题了,这里还要谢谢maninred,是他的提醒使我意识到问题的所在
附件
Screenshot-gnome-mount.png
提示框
Screenshot-gnome-mount.png (10.31 KiB) 查看 967 次
上次由 lfjlost 在 2007-10-27 18:13,总共编辑 2 次。
头像
maninred
帖子: 164
注册时间: 2007-08-24 20:16
来自: Hangzhou, China
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 maninred » 2007-10-26 9:17

同学同学,我找到方法了,我的情况和你一样。我好像改了locale和装了autofs就正常了,你试试。
mouse1234567
帖子: 8
注册时间: 2007-09-22 7:58
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 mouse1234567 » 2007-10-28 20:55

我装了autofs但是还是没用阿!locale怎么改阿?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2007-10-29 22:00

gnome-volume-manager。使用gnome的整套管理。包括gconf,hald, d-bus。

进程有这个?
● 鸣学
glassprogrammer
帖子: 75
注册时间: 2006-05-13 18:08
送出感谢: 2 次
接收感谢: 0
联系:

#5

帖子 glassprogrammer » 2007-11-08 5:18

请参考 http://thinkbase.net/w/main/Wiki?2007-1 ... 8%E6%9C%BA

原因是 feisty kernel 不再支持挂载 vfat 时的 usefree 选项.
回复

回到 “常用硬件支持”