当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 21 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : geforce go 7300 ,用nv官方驱动系统经常假死
帖子发表于 : 2007-11-01 19:27 

注册: 2006-12-14 3:00
帖子: 614
送出感谢: 0 次
接收感谢: 0 次
我的本本是acer aspire 5583wxci,显卡是geforce go 7300,目前的系统是全新安装的 7.10,如果启用显卡的受限驱动,即nvidia-glx-new,系统就会经常假死(没有开启compiz),如果改用开源驱动(Section "Device"中,Driver该为 nv)连续使用2个小时都没有假死的问题,因此可以确认是显卡驱动问题。以前用7.04也有这个问题,不过当时没把驱动换成开源驱动测试过。

在网上看到这篇帖子

http://www.linuxdiyf.com/bbs/redirect.p ... o=lastpost

照5楼的方法,在xorg.conf中添加红字部分后,假死现象相比以前,有所减少,不过还是有,平常上网倒没什么,不过看片子的时候老要中断几秒还是非常不爽的。不知道哪位有彻底的解决办法?

附:我的xorg.conf的部分内容,红字部分为自己添加,可部分解决假死问题


引用:
Section "Device"
Identifier "nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300]"
Driver "nvidia"
Busid "PCI:1:0:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "NoLogo" "True"
EndSection

Section "Module"
Load "glx"
Load "extmod"
EndSection


_________________
提问的智慧


页首
 用户资料  
 
2 楼 
 文章标题 : 7200
帖子发表于 : 2007-11-02 12:43 

注册: 2007-10-30 0:40
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
我的7200也有这个问题。。。怎么完全解决呢???


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-02 14:00 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
用源的。不要官方的。说很多次了。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-04 20:29 

注册: 2007-11-04 20:20
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
我也有這情形,可問題出在我根本沒去官方網站抓過driver,系統內用的是nvidia-glx-new,
我機子不一定假死,通常是使用了約兩到三小時以後,畫面會一段時間閃一下(不是閃爍,而是突然黑屏個0.幾秒),
偶爾出現假死狀況,是否有辦法解決?


最后由 yikeouch 编辑于 2007-11-04 21:38,总共编辑了 1 次

页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-04 21:10 

注册: 2007-11-04 20:20
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
我換成nvidia-glx,不用new了,可是一啟用3D系統仍然會抓glx-new來使用,
仍然得二至三小時重開一次機,讓人煩躁。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-05 8:49 

注册: 2007-10-31 0:07
帖子: 32
地址: 中国四川
送出感谢: 0 次
接收感谢: 0 次
我的也一样,比你们的还严重,连系统都进入不了


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-05 12:27 

注册: 2006-12-14 3:00
帖子: 614
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
用源的。不要官方的。说很多次了。

用的就是源里面的。今天升级了下,正在测试中。


_________________
提问的智慧


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-05 16:53 

注册: 2006-06-18 14:13
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
dongping0903 写道:
我的也一样,比你们的还严重,连系统都进入不了



我的GF4 440显卡,装了驱动后,就进了桌面了,按数字键也没反应,估计是死机了。到现在都不知道如何去解决呢。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-11-06 9:24 

注册: 2007-11-06 9:19
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
晕菜了
我电脑就是宏碁的5585 显卡和83是一样的
而且刚下完7.10 准备回家后安装


页首
 用户资料  
 
10 楼 
 文章标题 : reply
帖子发表于 : 2007-11-07 22:27 

注册: 2007-10-18 18:54
帖子: 38
地址: NANJING UNIVERSITY
送出感谢: 0 次
接收感谢: 0 次
这个问题应该重视起来的~~~~
我也是geforce go 7300 的卡!!
而且按照方法做了还是会屏幕突然闪一下~~
还有就是无辜死机,系统未响应,然后有恢复,太烦~~~
大虾解决一下拉~~~
谢谢~~~


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-11-07 22:45 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
如果确定某版本驱动有问题,学会禁止。hold/keep部分软件。具体man aptitude/apt-get


_________________
● 鸣学


页首
 用户资料  
 
12 楼 
 文章标题 : reply
帖子发表于 : 2007-11-07 22:48 

注册: 2007-10-18 18:54
帖子: 38
地址: NANJING UNIVERSITY
送出感谢: 0 次
接收感谢: 0 次
能不能稍微说的详细点阿~~~
我是新人~~~
就是我的显卡驱动是nvidia-glx-new


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-11-07 23:06 

注册: 2007-11-04 20:20
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
我已經兩天沒發生閃螢幕的情形了,提供一下我還不太確定的處理方式,供各位參考:
系統:ubuntu 7.10 灌好後未灌任何新版本nvidia驅動
一、啟用你的3d功能(開受限驅動),然後至系統>管理>螢幕及顯示卡挑螢幕型號,按確定。
二、開終端機 sudo nvidia-settings
三、選xserver display configuration, Detect display,選好要的解析度跟更新率,按 apply,然後save to X configuration file.重新開機,這時開機應該會看到nvidia 畫面。現在開始,你用的是nvidia的驅動,不是源裡的。
四、去compiz setting manager的general option >display setting將更新率設置得與驅動設定一樣
五、若使用一會後仍有螢幕閃動情形發生,重覆二、三,不同者只是把更新率改為auto,
六、永遠不要再去碰『系統>管理>螢幕及顯示卡』

死機可能有另外一個原因:請把firefox裡有關ubuntu的插件移除(忘記叫什麼名字了,好像叫ubu啥的)

目前兩天沒發生閃屏事件了,這個我不確定有效的方法大家可以試試,我反倒覺得可能是源裡的驅動在干擾nv的驅動正常運行,反正以後要調整螢幕一律開終端機就是了。千萬千萬不要去碰『系統>管理>螢幕及顯示卡』


页首
 用户资料  
 
14 楼 
 文章标题 : reply
帖子发表于 : 2007-11-09 18:23 

注册: 2007-10-18 18:54
帖子: 38
地址: NANJING UNIVERSITY
送出感谢: 0 次
接收感谢: 0 次
问题依旧阿~~~~~麻烦阿~~~


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-11-09 23:14 

注册: 2007-11-04 20:20
帖子: 48
送出感谢: 0 次
接收感谢: 0 次
nvidia的官方論壇有在討論:

http://www.nvnews.net/vbulletin/showthread.php?t=100568

經小弟看文結果,已確認元兇:
nvidia 100.14.19 以及 23 驅動程式似乎是造成當機之主因。
解決方式有三:
1.換用nv驅動,但那表示沒有3D功能。
2.換用較低版本驅動:但ubuntu 7.10似乎跟100.14.10之前版本不相容。有人說可以用這個舊版本:
Install older version of driver by Envy, use this: ftp://download.nvidia.com/XFree86/Linux-x86/96.43.01
但是小弟一點進去,不知道用兩個檔案中的哪一個,小弟不願當白老鼠,放棄!
3.另外有人在樓上的連結內po了自行編譯程式的方法,小弟不在行,放棄。期望有大神能看完提供詳細解決方式。
4.nvidia內部人員說:如果你遇到這種不穩定的問題blah blah,請等下版本的驅動程式。

所以....小弟要等時間來解決問題。

另,國外網站中有人提到,不光firefox與此驅動衝突,連swiftweasel也會,小弟推測連swiftfox大概也不妙,go系列使用者請用opera擋擋先。

報告完畢。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 21 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译