当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 还是Intel GMA900 ,mplayer不支持xv输出的说[已解决]
帖子发表于 : 2007-11-02 16:16 
头像

注册: 2007-03-16 15:42
帖子: 366
送出感谢: 0 次
接收感谢: 0 次
主板 Intel 910GML 显卡 Intel GMA900
显示器:LCD 14.1 宽屏

xorg.conf文件内容为
代码:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Identifier   "Synaptics Touchpad"
   Driver      "synaptics"
   Option      "SendCoreEvents"   "true"
   Option      "Device"      "/dev/psaux"
   Option      "Protocol"      "auto-dev"
   Option      "HorizEdgeScroll"   "0"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "Generic Video Card"
   Driver      "vesa"
   BusID      "PCI:0:2:0"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-96
   VertRefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "Generic Video Card"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Modes      "1920x1440"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"

# Uncomment if you have a wacom tablet
#   InputDevice     "stylus"   "SendCoreEvents"
#   InputDevice     "cursor"   "SendCoreEvents"
#   InputDevice     "eraser"   "SendCoreEvents"
   InputDevice   "Synaptics Touchpad"
EndSection

# 打开xorg.conf中的混色开关
Section "Extensions"
    Option  "Composite"  "Enable"
EndSection


从该文件中 粗看好像没有识别出Intel GMA 900显卡的说

不知要如何处理亚


最后由 INUYASHA 编辑于 2007-11-03 19:46,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-02 16:19 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
没有装这个试试? xserver-xorg-video-intel


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-02 16:38 

注册: 2006-01-10 19:09
帖子: 1334
送出感谢: 0 次
接收感谢: 0 次
Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
BusID "PCI:0:2:0"
EndSection

你确定你安装完全了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-02 20:16 
头像

注册: 2007-03-16 15:42
帖子: 366
送出感谢: 0 次
接收感谢: 0 次
xserver-xorg-video-intel 装了的说


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-02 20:18 

注册: 2007-10-19 21:15
帖子: 90
送出感谢: 0 次
接收感谢: 0 次
sed -i -e 's/vesa/intel/g' /etc/X11/xorg.conf

然后试试。
mplayer打了xv补丁后可以在compiz下用xv的。不过我记得ubuntu已经打过了。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-02 21:05 
头像

注册: 2007-03-16 15:42
帖子: 366
送出感谢: 0 次
接收感谢: 0 次
郁闷呀

我自作聪明将xsever-xorg-video -*全部卸载le
重装xorg 和xsever-xorg-video -intel 和915resolution

X进不了了 5555555~~~~~~

而且 命令模式中中文显示不了 不知怎样切换到英文模式

另:以前xsever-xorg-video -*
amd ati 几乎都自动装上了

现在不知道怎么做了


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-02 21:13 

注册: 2007-10-19 21:15
帖子: 90
送出感谢: 0 次
接收感谢: 0 次
export LC_ALL=C
重复我上面的。之后就能经x的。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-02 21:53 
头像

注册: 2007-03-16 15:42
帖子: 366
送出感谢: 0 次
接收感谢: 0 次
panchoat 写道:
export LC_ALL=C
重复我上面的。之后就能经x的。

谢了 mplayer(smplayer)能用xv模式了

另:在smplayer播放时
在屏幕上右击,弹出的右键菜单周围有一圈蓝的的东东
正常吗


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-11-02 22:00 
头像

注册: 2007-03-16 15:42
帖子: 366
送出感谢: 0 次
接收感谢: 0 次
原理似乎是
xorg.conf文件中
Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
BusID "PCI:0:2:0"
EndSection
将vesa改为intel的说


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-11-02 22:26 
头像

注册: 2007-03-16 15:42
帖子: 366
送出感谢: 0 次
接收感谢: 0 次
又有新问题了
mplayer用了xv模式后
色彩有问题亚 字也模糊了


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-11-03 19:31 
头像

注册: 2007-03-16 15:42
帖子: 366
送出感谢: 0 次
接收感谢: 0 次
INUYASHA 写道:
另:在smplayer播放时
在屏幕上右击,弹出的右键菜单周围有一圈蓝的的东东
正常吗

关闭xfce 的 窗口加强混合设置

INUYASHA 写道:
又有新问题了
mplayer用了xv模式后
色彩有问题亚 字也模糊了

调节合理的对比度 并设为默认值


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-01-12 17:12 

注册: 2007-03-19 12:28
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
INUYASHA 写道:
panchoat 写道:
export LC_ALL=C
重复我上面的。之后就能经x的。

谢了 mplayer(smplayer)能用xv模式了

另:在smplayer播放时
在屏幕上右击,弹出的右键菜单周围有一圈蓝的的东东
正常吗



可以请问一下具体怎么操作吗?
我的mplayer倒是可以用xv,但smplayer不行,有声音,不过图像只有调整设置或移动窗口的瞬间才有。
本来一直用x11也没什么,但是一看1024系列的影片CPU就有点扛不住了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译