安装alsa-driver-1.0.9b驱动出现的问题

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
herotaotao
帖子: 74
注册时间: 2006-01-04 15:38
送出感谢: 0
接收感谢: 0
联系:

安装alsa-driver-1.0.9b驱动出现的问题

#1

帖子 herotaotao » 2006-01-09 12:27

我在安装alsa-driver-1.0.9b驱动的时候,键入./configure --with-cards=hda-intel --with-sequencer=yes后,出现下列文字:

checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /usr/src/alsa/alsa-driver-1.0.9b
checking cross compile...
checking for directory with kernel source... /usr/src/linux
checking for directory with kernel build...
checking for kernel version... The file /usr/src/linux/include/linux/version.h does not exist.
Please, install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).
herotaotao@ubuntu:/usr/src/alsa/alsa-driver-1.0.9b$ sudo ./configure --with-cards=hda-intel --with-sequencer=yes
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /usr/src/alsa/alsa-driver-1.0.9b
checking cross compile...
checking for directory with kernel source... /usr/src/linux
checking for directory with kernel build...
checking for kernel version... The file /usr/src/linux/include/linux/version.h does not exist.
Please, install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).


请问,我是什么东西没有装呢?如何安装?

另外,我的声卡是intel high defination audio的,应该是按照下面的官方方法做吧?
http://www.alsa-project.org/alsa-doc/do ... =hda-intel
头像
oneleaf
论坛管理员
帖子: 10227
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#2

帖子 oneleaf » 2006-01-09 14:21

The file /usr/src/linux/include/linux/version.h does not exist
安装内核头文件,并建立链接为 /usr/src/linux
herotaotao
帖子: 74
注册时间: 2006-01-04 15:38
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 herotaotao » 2006-01-09 17:28

如何安装内核头文件啊?不懂。
头像
yang119345
帖子: 570
注册时间: 2005-06-19 14:22
来自: 上海
送出感谢: 0
接收感谢: 1 次
联系:

#4

帖子 yang119345 » 2006-01-09 23:22

herotaotao 写了:如何安装内核头文件啊?不懂。

sudo apt-get install linux-headers-`uname -r`
garconcn
帖子: 14
注册时间: 2006-01-13 22:10
送出感谢: 0
接收感谢: 0

#5

帖子 garconcn » 2006-01-15 15:32

谢谢.
我已经完成这2步 compile & install the drivers and ALSA libraries

但在安装 ALSA Utils时又出现问题了:

------------------------------------
make[1]: Entering directory `/usr/src/alsa/alsa-utils-1.0.10/alsaconf'
Making all in po
make[2]: Entering directory `/usr/src/alsa/alsa-utils-1.0.10/alsaconf/po'
mv: cannot stat `t-ja.gmo': No such file or directory
make[2]: *** [ja.gmo] Error 1
----------------------------------------
lrf
帖子: 140
注册时间: 2005-10-05 23:33
来自: 北京
送出感谢: 0
接收感谢: 0

#6

帖子 lrf » 2006-01-16 10:17

你自己用新立得装这些东西好了,一切的问题都能够搞定。自己找软件安装编译,主要的问题就是软件包的依赖。特别的麻烦
garconcn
帖子: 14
注册时间: 2006-01-13 22:10
送出感谢: 0
接收感谢: 0

#7

帖子 garconcn » 2006-01-16 10:52

可synaptic没有新版的Alsa :cry:
lrf
帖子: 140
注册时间: 2005-10-05 23:33
来自: 北京
送出感谢: 0
接收感谢: 0

#8

帖子 lrf » 2006-01-16 11:15

你的源有问题,我的有,嘿嘿
garconcn
帖子: 14
注册时间: 2006-01-13 22:10
送出感谢: 0
接收感谢: 0

#9

帖子 garconcn » 2006-01-16 11:30

我用的国外的源,我昨天加了新手指南里提供的源,可我这里连的很慢,大多都fail了
回复

回到 “常用硬件支持”