当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [分享]7.10 ICH7声卡问题解决方法
帖子发表于 : 2007-11-07 12:21 

注册: 2007-03-12 11:28
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我的声卡驱动更新到alsa-driver-1.0.15以后出现声卡无法被识别的现象,搜索发现很多朋友也遇到了类似问题

后来经过搜索国外的ubuntu论坛发现了一个解决方法(至少我的问题得到了解决)
# Perform audio fix (I've included my steps, and alternatives from others - choose only one)

* Fix suggested by "alexander.forster" (preferred)
o sudo apt-get install linux-backports-modules-generic
* Alternative 1 (* see below for other models this is reported to have worked on)
o sudo apt-get install libc6-dev
o sudo apt-get install patch
o wget ftp:// ftp.alsa-project.org/pub/driver/alsa-driver-1.0.15.tar.bz2 (remove the space after the double-slash)
o tar xvpjf alsa-driver-1.0.15.tar.bz2
o cd alsa-driver-1.0.15
o ./configure --with-cards=hda-intel,emu10k1
o make
o sudo make install
* Alternative fix suggested by "lefthand"
o sudo apt-get install module-assistant
o sudo m-a update
o sudo m-a prepare
o sudo m-a a-i alsa

# Reboot so all changes take effect; you should now have sound
# Change amixer settings so the microphone plugging in to the side will work (haven't got internal to work yet)

* If you installed the backports
o amixer set Capture 15 cap
o amixer set Mux,0 3 cap
* If you installed the 1.0.15 alsa drivers...
o amixer set InMux 4
o amixer set ADCMux cap

要注意两个方案选其一,建议安装新alsa驱动失败的人尝试第二种方法
附上原文链接:[url]http://ubuntuforums.org/showthread.php?t=577469&highlight=ich7
[/url]最后希望大家的问题都能够得到解决[/i]


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译