当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [教学]刚搞定了nvidia的官方最新驱动169.04(重写版)
帖子发表于 : 2007-11-18 10:40 
头像

注册: 2007-10-07 15:22
帖子: 134
送出感谢: 0 次
接收感谢: 0 次
其他步骤没太多问题,主要是当时我的menu.lst里面的vga没有注释掉,导致无法显示控制台,这点一直没意识到,每次/etc/init.d/gdm stop就黑屏……汗自己一个,后来注释了vga就可以了~~~

169.04的驱动还是测试版本的,开机的时候显示的还是nvidia beta,哈哈,甘心作小白鼠~~~

——————————————————————————————————————————————————

教程在4楼


_________________
DualCore Intel Core 2 Duo T5250 1.5G
PM965
1 GB DDR2-533
NVIDIA GeForce 8600M GS 512MB/128Bit
Kubuntu 7.10 & KDE4 RC2 / Windows XP SP2
--------------------------------------------------
http://www.x5dj.com/xin123hua/


最后由 xin123hua 编辑于 2007-11-19 8:10,总共编辑了 3 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-18 10:45 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
是编译安装? 你简要些个过程,不比你在这发感慨更有意义么?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-18 10:45 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
误入A门

:em18


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-18 10:56 
头像

注册: 2007-10-07 15:22
帖子: 134
送出感谢: 0 次
接收感谢: 0 次
具体方法:
打开新立得软件包管理器,搜索nvidia,删除所有相关的包
或者使用envy卸载已经安装的驱动,或者二者都用


(提示,envy是驱动管理软件,能够为你安装驱动,不过鉴于我们要安装的是最新的官方驱动,所以这里只是用来卸载而非安装驱动,当然,如果你仅仅想安装驱动的,并不在乎版本的话,envy是个不错的选择)

删除 /lib/linux-restricted-modules/文件夹下面的所有内容(不会命令行的就进入到目录下然后用sudo rm -rf 命令删除非空文件夹)

sudo gedit /etc/default/linux-restricted-modules-common,将 DISABLED_MODULES="" 改为DISABLED_MODULES="nv nvidia_new"

下载最新驱动放置到/home/username下 NVIDIA-Linux-x86-169.04-pkg1.run(自己去搜索,网上到处都有了)http://us.download.nvidia.com/XFree86/Linux-x86/169.04/NVIDIA-Linux-x86-169.04-pkg1.run

此处就是我个人的问题:如果开机启动过程显示为黑屏然后直接到桌面不显示命令行的朋友可能要和我一样了
sudo gedit /boot/grub/menu.lst 将你内核对应的那个启动选项后面的vga及其后的数值什么的删除,当然,像我那样用换行并用##注释掉也行,保存退出,然后重启一下,进入下一步


sudo apt-get install libc6-dev

sudo /etc/init.d/gdm stop进入命令行模式

按ctrl+arl+F1登录

sudo sh NVIDIA-Linux-x86-169.04-pkg1.run开始安装

过程中全部accept next agree yes,在问是否要下载对应的内核的时候选否就好(英语不好的提示一下kernel是内核download是下载)

全过程结束之后sudo nvidia-xconfig

然后sudo /etc/init.d/gdm start

然后sudo apt-get install nvidia-settings

sudo nvidia-settings 在图形界面下的设置选项中点左边第二项x server display configuration选择正确的分辨率应用并save to configuration file.重启 Done


附件:
envy_0.9.8-0ubuntu10_all.deb [599 KiB]
被下载 169 次


_________________
DualCore Intel Core 2 Duo T5250 1.5G
PM965
1 GB DDR2-533
NVIDIA GeForce 8600M GS 512MB/128Bit
Kubuntu 7.10 & KDE4 RC2 / Windows XP SP2
--------------------------------------------------
http://www.x5dj.com/xin123hua/


最后由 xin123hua 编辑于 2007-11-19 8:44,总共编辑了 5 次
页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-18 10:56 
头像

注册: 2007-10-07 15:22
帖子: 134
送出感谢: 0 次
接收感谢: 0 次
这不正在写吗~~~年轻人不要急嘛,刚楼上发的就是


附件:
Screenshot.png
Screenshot.png [ 314.09 KiB | 被浏览 1793 次 ]



_________________
DualCore Intel Core 2 Duo T5250 1.5G
PM965
1 GB DDR2-533
NVIDIA GeForce 8600M GS 512MB/128Bit
Kubuntu 7.10 & KDE4 RC2 / Windows XP SP2
--------------------------------------------------
http://www.x5dj.com/xin123hua/
页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-18 10:59 
头像

注册: 2007-10-07 15:22
帖子: 134
送出感谢: 0 次
接收感谢: 0 次
上图了,看驱动版本~~


_________________
DualCore Intel Core 2 Duo T5250 1.5G
PM965
1 GB DDR2-533
NVIDIA GeForce 8600M GS 512MB/128Bit
Kubuntu 7.10 & KDE4 RC2 / Windows XP SP2
--------------------------------------------------
http://www.x5dj.com/xin123hua/


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-18 16:58 

注册: 2006-12-30 20:24
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
怎么我的装完之后桌面效果用不了了呢?3d都没问题了,还老提示要用那个受限驱动!。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-18 19:51 
头像

注册: 2007-10-07 15:22
帖子: 134
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get remove --purge nvidia-glx nvidia-glx-new

删除 /lib/linux-restricted-modules/文件夹下面的所有内容(不会命令行的就进入到目录下然后用sudo rm -rf 命令删除非空文件夹)

sudo gedit /etc/default/linux-restricted-modules-common,将 DISABLED_MODULES="" 改为DISABLED_MODULES="nv nvidia_new"

这几步是用来卸载受限驱动的,是否有做?


_________________
DualCore Intel Core 2 Duo T5250 1.5G
PM965
1 GB DDR2-533
NVIDIA GeForce 8600M GS 512MB/128Bit
Kubuntu 7.10 & KDE4 RC2 / Windows XP SP2
--------------------------------------------------
http://www.x5dj.com/xin123hua/


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-11-18 20:03 
头像

注册: 2007-10-07 15:22
帖子: 134
送出感谢: 0 次
接收感谢: 0 次
tanzi3023 写道:
怎么我的装完之后桌面效果用不了了呢?3d都没问题了,还老提示要用那个受限驱动!。


开机的时候有看到nvidia的图片吗?(左下有个红色的beta)


_________________
DualCore Intel Core 2 Duo T5250 1.5G
PM965
1 GB DDR2-533
NVIDIA GeForce 8600M GS 512MB/128Bit
Kubuntu 7.10 & KDE4 RC2 / Windows XP SP2
--------------------------------------------------
http://www.x5dj.com/xin123hua/


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-11-18 22:30 

注册: 2006-12-30 20:24
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
照上面做的,有那个图片,版本也是169.04。但不知是怎么回事,一选择桌面效果就要输密码,然后提示“启用驱动?”。。。。点确定之后就开始自动下载安装那个受限驱动去了,装完之后驱动又用不了,还得照上面说的重新再来。试了几次,都一样的。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-11-19 8:07 
头像

注册: 2007-10-07 15:22
帖子: 134
送出感谢: 0 次
接收感谢: 0 次
当时安装完驱动没有仔细看,只是按照前人推荐的方式安装官方驱动,后来发现我自己的3d特效也打不开,研究了一下,发现其实这样不行,前面的步骤中缺少一个重要的步骤,就是卸载已经存在的相关nvidia的包

用新得利软件包搜索nvidia,将相关的全部卸载之,然后再执行安装驱动的步骤就可以了,我是用envy卸载驱动再装的,结果是一样,envy也仅仅是作了卸载这一步。


附件:
Screenshot.png
Screenshot.png [ 845.76 KiB | 被浏览 1639 次 ]



_________________
DualCore Intel Core 2 Duo T5250 1.5G
PM965
1 GB DDR2-533
NVIDIA GeForce 8600M GS 512MB/128Bit
Kubuntu 7.10 & KDE4 RC2 / Windows XP SP2
--------------------------------------------------
http://www.x5dj.com/xin123hua/
页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-11-19 16:22 
头像

注册: 2007-10-07 15:22
帖子: 134
送出感谢: 0 次
接收感谢: 0 次
应该不会有问题了吧?


_________________
DualCore Intel Core 2 Duo T5250 1.5G
PM965
1 GB DDR2-533
NVIDIA GeForce 8600M GS 512MB/128Bit
Kubuntu 7.10 & KDE4 RC2 / Windows XP SP2
--------------------------------------------------
http://www.x5dj.com/xin123hua/


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-11-19 19:11 

注册: 2006-12-30 20:24
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
搞定了。。谢谢阿!!


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-11-19 22:47 
头像

注册: 2007-10-07 15:22
帖子: 134
送出感谢: 0 次
接收感谢: 0 次
呵呵,你不提醒我我还没发现,我默认没开特效,所以只知道驱动装上了,不知道不能开特效呢,呵呵。


_________________
DualCore Intel Core 2 Duo T5250 1.5G
PM965
1 GB DDR2-533
NVIDIA GeForce 8600M GS 512MB/128Bit
Kubuntu 7.10 & KDE4 RC2 / Windows XP SP2
--------------------------------------------------
http://www.x5dj.com/xin123hua/


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-11-21 9:16 

注册: 2007-11-21 3:02
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
多谢Xin123hua兄的教程。
我的老本子也终于搞定了显卡驱动!

不过问题还是有,特效还是打不开。
我的具体问题http://forum.ubuntu.org.cn/viewtopic.php?t=90405

希望老兄指点一下,谢谢


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译