当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [原创]声卡问题终于完美解决了!82801G(ICH7 Family)High Definition Audio Con
帖子发表于 : 2007-11-29 19:16 

注册: 2007-11-15 7:47
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
一直以来困扰我的声卡问题终于得到完美解决,不但可以正常发声,而且爆音也没了!!!哈哈……

其实以前就在WIKI上找到过这个方法,可是当时由于忘记完整卸载之前安装的oss驱动,没成功,直到今天无聊重试才搞定!唉……粗心害人啊!!!

首先,删除之前安装的oss驱动,方法有很多,请在论坛自行查找。

接下来就是具体的安装过程了:

sudo apt-get install libc6-dev

sudo apt-get install ncurses-dev

现在将光盘取出,最好能重启一下系统

mkdir alsa-fix && cd alsa-fix

wget ftp://ftp.alsa-project.org/pub/driver/a ... 15.tar.bz2
wget ftp://ftp.alsa-project.org/pub/lib/alsa ... 15.tar.bz2
wget ftp://ftp.alsa-project.org/pub/utils/al ... 15.tar.bz2
wget http://tfc.duke.free.fr/coding/hdaintel ... 0908.patch

tar -xvf alsa-driver-1.0.15.tar.bz2
tar -xvf alsa-lib-1.0.15.tar.bz2
tar -xvf alsa-utils-1.0.15.tar.bz2

cd alsa-driver-1.0.15
patch -p1 < ../hdaintel-laptop-eapd-hg20070908.patch
./configure --with-cards=hda-intel --with-sequencer=yes --with-oss=yes
make
sudo make install
cd ..

cd alsa-lib-1.0.15
./configure
make
sudo make install
cd ..

cd alsa-utils-1.0.15
./configure
make
sudo make install
cd ..

安装过程中有几个问题需要注意:首先,如果make的时候报错,别害怕,重新运行make就可以了,具体原因懒得翻译了;其次,最后一步,make alsa-utils-1.0.15的时候如果重做几次都出现错误,那就放弃此步,直接重启机器,应该没问题。

至此,安装完毕,重启机器就可以了。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-10 11:18 

注册: 2006-10-24 23:40
帖子: 97
送出感谢: 0 次
接收感谢: 0 次
我的还是不行。
lsmod |grep snd
snd_hda_intel 293792 0
snd_pcm 80644 1 snd_hda_intel
snd_timer 24580 1 snd_pcm
snd_page_alloc 11656 2 snd_hda_intel,snd_pcm
snd_hwdep 10628 1 snd_hda_intel
snd 56708 4 snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
soundcore 8800 1 snd


_________________
Laptop:HP Compaq Presario V3511

OS:Ubuntu 7.10

Phone:nokia 6600

OS:sybian s60 2nd


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-10 16:02 

注册: 2007-11-15 7:47
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
首先确认你的声卡,这种方法我只在“82801G(ICH7 Family)High Definition Audio”上使用。

接下来,确认你每一步都做了,千万别落下,特别是最开始安装那两个包。

还有,patch一定要打,然后“./configure --with-cards=hda-intel --with-sequencer=yes --with-oss=yes ”参数一定要全。

你的驱动明显没有装全,建议仔细检查一下,然后将目前的驱动删掉在重新安装。

lsmod |grep snd
snd_hda_intel 293792 3
snd_pcm_oss 43008 0
snd_mixer_oss 17920 1 snd_pcm_oss
snd_pcm 80644 3 snd_hda_intel,snd_pcm_oss
snd_page_alloc 11656 2 snd_hda_intel,snd_pcm
snd_hwdep 10628 1 snd_hda_intel
snd_seq_oss 35456 0
snd_seq_midi_event 8704 1 snd_seq_oss
snd_seq 54256 4 snd_seq_oss,snd_seq_midi_event
snd_timer 24580 3 snd_pcm,snd_seq
snd_seq_device 9740 2 snd_seq_oss,snd_seq
snd 56708 13 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_oss,snd_seq,snd_timer,snd_seq_device
soundcore 8800 1 snd


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-10 20:06 

注册: 2007-08-07 10:45
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
好像不行哦。
不过楼主指的完全删除OSS?是怎么操作。
我都没有找到相关文档哦。
还望指明地址。谢谢!
新手请见量。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-11 11:53 

注册: 2006-10-24 23:40
帖子: 97
送出感谢: 0 次
接收感谢: 0 次
rgaobj 写道:
首先确认你的声卡,这种方法我只在“82801G(ICH7 Family)High Definition Audio”上使用。

接下来,确认你每一步都做了,千万别落下,特别是最开始安装那两个包。

还有,patch一定要打,然后“./configure --with-cards=hda-intel --with-sequencer=yes --with-oss=yes ”参数一定要全。

你的驱动明显没有装全,建议仔细检查一下,然后将目前的驱动删掉在重新安装。

lsmod |grep snd
snd_hda_intel 293792 3
snd_pcm_oss 43008 0
snd_mixer_oss 17920 1 snd_pcm_oss
snd_pcm 80644 3 snd_hda_intel,snd_pcm_oss
snd_page_alloc 11656 2 snd_hda_intel,snd_pcm
snd_hwdep 10628 1 snd_hda_intel
snd_seq_oss 35456 0
snd_seq_midi_event 8704 1 snd_seq_oss
snd_seq 54256 4 snd_seq_oss,snd_seq_midi_event
snd_timer 24580 3 snd_pcm,snd_seq
snd_seq_device 9740 2 snd_seq_oss,snd_seq
snd 56708 13 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_oss,snd_seq,snd_timer,snd_seq_device
soundcore 8800 1 snd


patch也打了,不过不知道适不适合我的声卡。都安装了,还是这个结果


_________________
Laptop:HP Compaq Presario V3511

OS:Ubuntu 7.10

Phone:nokia 6600

OS:sybian s60 2nd


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-27 16:11 

注册: 2007-09-04 16:28
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
强,你的方法很成功,我就装alsa-driver就可以了。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-27 19:53 
头像

注册: 2005-12-23 19:20
帖子: 1677
送出感谢: 0 次
接收感谢: 0 次
昨天自己编译声卡驱动 显示成功 alsaconf 也能ok 最后还是崩溃了 彻底无声了……
今天重装 好不容易才设定好 不敢搞了
:oops: :oops: :oops:


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-29 17:29 
头像

注册: 2007-10-23 21:11
帖子: 461
地址: 香港
送出感谢: 0 次
接收感谢: 0 次
我求你教一下怎移除OSS drive 吧 :? :? :? :?


我底板內置了 Realtek ACL888 ,剛安裝好系統是正常工作的,可以輸出 DTS AC3,後來不知裝了什麼就不工作了, 就算我怎麼重新安裝 ALSA driver 都沒成功 Confused Confused Confused Confused Confused

後來我又找了一個外置的 creative USB soundcard, 裝 alsa 跑了不久不能輸出 dts ac3....

我又找了一張 yamaha DS-1S , 裝了 ALSA ,沒聲 Confused Confused Confused Confused

後來又裝了 OSS drive ,都不成Exclamation

我不想重裝系統啊 Confused Confused Confused Confused Confused


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-01-01 17:31 
头像

注册: 2007-10-23 21:11
帖子: 461
地址: 香港
送出感谢: 0 次
接收感谢: 0 次
這句是什麼意思???????????????

$ patch -p1 < ../hdaintel-laptop-eapd-hg20070908.patch
bash: ../hdaintel-laptop-eapd-hg20070908.patch: 沒有此一檔案或目錄


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-01-22 15:34 

注册: 2007-12-28 11:17
帖子: 84
送出感谢: 0 次
接收感谢: 0 次
他也不会删除OSS的貌似


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [原创]声卡问题终于完美解决了!82801G(ICH7 Family)High Definition Audio
帖子发表于 : 2013-04-11 13:52 

注册: 2013-04-09 22:29
帖子: 20
系统: ubuntu12.04+win7
送出感谢: 0 次
接收感谢: 0 次
好文章啊 相信你的文章可以帮助很多人


_________________
A芯A卡 ubuntu


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译