当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 为什么我开机IOwait就占用cpu100%
帖子发表于 : 2007-12-06 21:52 

注册: 2007-04-03 19:29
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
下面是iostat -x 的结果:
avg-cpu: %user %nice %system %iowait %steal %idle
2.79 1.03 1.76 45.09 0.00 49.33

Device: rrqm/s wrqm/s r/s w/s rsec/s wsec/s avgrq-sz avgqu-sz
await svctm %util
hda 18.75 16.76 33.74 4.16 972.21 167.42 30.07 6.39 1
68.69 12.92 48.95

硬盘在不停的转
但是过了两三分钟就恢复正常了。。
我该怎么解决,谢谢
btw:ubuntu7.10的系统


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 为什么我开机IOwait就占用cpu100%
帖子发表于 : 2010-05-24 13:33 

注册: 2008-07-24 20:49
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
同样情况发生于我这里

版本 : ubuntu 10.04
uname -a
Linux qign-desktop 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:27:30 UTC 2010 i686 GNU/Linux

vmstat -2
procs -----------memory---------- ---swap-- -----io---- -system-- ----cpu----
r b swpd free buff cache si so bi bo in cs us sy id wa
0 3 0 589036 393924 1501108 0 0 0 10 3549 2766 7 1 34 58
0 4 0 589036 393924 1501108 0 0 0 4 1613 2507 4 1 0 94
0 2 0 589036 393932 1501104 0 0 0 16 1709 2676 6 1 40 53
0 2 0 589036 393932 1501108 0 0 0 8 1003 2528 4 1 45 50
0 3 0 588912 393932 1501108 0 0 0 0 1520 2615 6 1 0 92
0 2 0 588912 393948 1501108 0 0 0 44 1138 2512 5 2 0 93
0 3 0 588912 393952 1501108 0 0 0 100 976 2624 5 2 0 93
0 2 0 588788 393960 1501112 0 0 0 22 1956 2599 5 2 0 93
0 3 0 588788 393960 1501112 0 0 0 2 973 2381 6 1 0 93
0 3 0 588788 393964 1501112 0 0 0 2 1335 2674 5 1 0 94
0 3 0 588788 393992 1501108 0 0 0 100 3637 2817 6 1 32 61
0 2 0 588540 394000 1501156 0 0 0 34 1396 2543 7 1 6 87
0 2 0 588664 394012 1501116 0 0 0 4 3334 2783 5 2 43 50
0 2 0 588664 394024 1501116 0 0 0 112 3249 2754 5 2 44 50
0 2 0 588540 394036 1501116 0 0 0 16 2473 2755 5 2 21 72
0 2 0 588540 394040 1501116 0 0 0 4 2333 2582 5 1 18 76
0 2 0 588540 394044 1501116 0 0 0 78 2046 2661 5 1 28 66
0 4 0 588416 394052 1501116 0 0 0 2 1148 2654 6 2 0 93
0 2 0 588416 394076 1501100 0 0 0 102 2790 2740 5 1 40 54
0 2 0 588292 394088 1501112 0 0 0 72 1899 2724 5 2 43 50
0 1 0 588292 394096 1501112 0 0 0 4 989 2398 6 1 45 48

这里可以看到 硬盘读写几乎没有,但 b 显示的等待io的进程一直block,可用 id 非常少,wa很高

怎么才能知道 b中被block的进程是什么那? 怎么才能知道是什么问题导致的?
坐等高人解答


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 为什么我开机IOwait就占用cpu100%
帖子发表于 : 2010-05-24 13:36 

注册: 2008-01-09 22:41
帖子: 18311
送出感谢: 0 次
接收感谢: 6
安iotop看哪个进程有问题直接kill


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译