当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Ubuntu 7.10中不能正常使用耳机的解决方法
帖子发表于 : 2007-12-07 13:49 

注册: 2006-12-22 20:40
帖子: 108
送出感谢: 0 次
接收感谢: 0 次
安装完Ubuntu 7.10后,发现一些基本的功能模块都有GUI的,程序的安装/卸载,一些基本的日常软件。不用装其他的软件就可以实现笔记本的快捷键功能,如亮度调节、音量调节等。其他的硬件都可以正常使用,很高兴,以前给用CRT的台式机装Redhat,显卡不能驱动,呵,对着它就像开新闻发布会,眼睛给闪得不行。这次是没什么问题了,一切是那么正常——至少看上去很好。晚上为了不打扰其他人休息,想用耳机听下音乐。插上去,内置的音箱是没声音了,可耳机却怎么也静悄悄。调遍能按、能拖的,没办法解决,看来只能自己慢慢找了。终于找到了解决办法,如下:

如果你的/etc/目录下有modprobe.conf或者modules.conf或者conf.modules,那么只要将其中有关声卡的部分用#注释掉,然后加入以下内容:

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=z71v position_fix=1

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

然后重新启动,打开alsamixer看一下,应该有headphone这一项了。

如果你用的是Ubuntu,在/etc/目录下找不到那些文件,这时候需要打开/etc/modprobe.d目录,编辑下面的aliases文件,将上面以alias开头的行加入其中,同时将

options snd-hda-intel model=z71v position_fix=1

加到/etc/modprobe.d/options里,然后重启,这样耳机应该能够使用了。

希望大家都能够解决问题。


页首
 用户资料  
 
2 楼 
 文章标题 : 开启你的pulseaudio服务器吧
帖子发表于 : 2007-12-08 20:09 

注册: 2007-11-17 15:25
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
声音支持绝对没问题


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-08 23:26 

注册: 2006-12-22 20:40
帖子: 108
送出感谢: 0 次
接收感谢: 0 次
我的有问题啊!只输出给笔记本的音箱


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译