当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 各位大哥大姐帮帮忙吧,装了ATI的驱动,可是没有用阿~~~郁闷ING
帖子发表于 : 2007-12-25 10:26 

注册: 2007-12-13 21:55
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
就是按照这个帖子一步步安装的
http://forum.ubuntu.org.cn/viewtopic.php?t=91719

装好了,可是系统没有变化哦,桌面的一些效果也没了

贴出xorg.conf清各位大侠帮忙看看


# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "dri"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "altwin:meta_win"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "Failsafe Monitor"
VendorName "Plug 'n' Play"
ModelName "Plug 'n' Play"
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "640x480@72" 31.5 640 664 704 832 480 489 491 520 -hsync -vsync
ModeLine "640x480@75" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
ModeLine "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "832x624@75" 57.3 832 864 928 1152 624 625 628 667 -hsync -vsync
ModeLine "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
ModeLine "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
ModeLine "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
ModeLine "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
ModeLine "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1280x960@75" 129.9 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
ModeLine "1400x1050@60" 122.6 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
ModeLine "1400x1050@75" 155.8 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
ModeLine "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
ModeLine "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
EndSection

Section "Monitor"

#
Identifier "monitor1"
VendorName "Plug 'n' Play"
ModelName "Plug 'n' Play"
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "640x480@72" 31.5 640 664 704 832 480 489 491 520 -hsync -vsync
ModeLine "640x480@75" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
ModeLine "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "832x624@75" 57.3 832 864 928 1152 624 625 628 667 -hsync -vsync
ModeLine "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
ModeLine "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
ModeLine "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
ModeLine "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
ModeLine "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1280x960@75" 129.9 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
ModeLine "1400x1050@60" 122.6 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
ModeLine "1400x1050@75" 155.8 1400 1496 1648 1896 1050 1051 1054 1096 -hsync +vsync
ModeLine "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
ModeLine "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Failsafe Device"
Driver "fglrx"
VendorName "ATI"
BoardName "ATI Radeon"
Option "MergedFB" "off"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
BusID "PCI:1:0:0"
EndSection

Section "Device"

#
Identifier "device1"
Driver "ati"
VendorName "ATI"
BoardName "ATI Radeon"
Option "MergedFB" "off"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Failsafe Device"
Monitor "Failsafe Monitor"
DefaultDepth 24
SubSection "Display"
Virtual 1280 1024
Depth 24
Modes "1280x1024@75" "1280x960@60" "1152x864@75" "1280x1024@60" "1024x768@60" "1280x960@75" "1024x768@70" "1400x1050@60" "1024x768@75" "1400x1050@75" "832x624@75" "1600x1200@65" "800x600@60" "1600x1200@60" "800x600@75" "800x600@72" "800x600@56" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "Screen"

#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "640x480@60" "640x480@72" "640x480@75" "800x600@56" "800x600@72" "800x600@75" "800x600@60" "832x624@75" "1024x768@75" "1024x768@70" "1024x768@60" "1152x864@75" "1280x1024@75" "1280x960@60" "1280x1024@60" "1280x960@75" "1400x1050@60" "1400x1050@75" "1600x1200@65" "1600x1200@60"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "0"
EndSection


_________________
我是一只小小鸟,多么渴望飞得高~


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-12-25 18:18 
头像

注册: 2007-10-21 18:36
帖子: 3235
地址: 汕头/广东/中国
送出感谢: 2
接收感谢: 3
用ATI的要学会满足


_________________
老子的哲学是“”,庄子的哲学是“
人有一技在身,则逍遥游而无不为


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-12-25 18:25 
头像

注册: 2007-12-19 21:42
帖子: 1163
送出感谢: 0 次
接收感谢: 0 次
试试:
代码:
glxinfo | grep render

如果显示:
代码:
direct rendering:Yes

就证明驱动已装,么问题了!


_________________
北極熊都是左撇子…………


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-12-25 18:48 
头像

注册: 2007-12-02 14:09
帖子: 705
送出感谢: 0 次
接收感谢: 0 次
珍惜生命 远离a卡~~
学会满足 能显示 24位色 85hz 标准分辨率的图像 看电影不闪烁我就满足了


_________________
悟以往之不鉴,知来者之可追
识迷途其未远 觉今是而昨非


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-12-25 19:06 

注册: 2007-12-13 21:55
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
晶晶守护神 写道:
珍惜生命 远离a卡~~
学会满足 能显示 24位色 85hz 标准分辨率的图像 看电影不闪烁我就满足了










不要吧,让我们A卡也享受3D的绚丽吧~~~~~~~~~~~~~`


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-12-25 19:29 

注册: 2007-12-13 21:55
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
Neoriva 写道:
试试:
代码:
glxinfo | grep render

如果显示:
代码:
direct rendering:Yes

就证明驱动已装,么问题了!




$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: ATI RADEON 9600 Series

显示yes了,可是还没有变化阿
什么效果也没有哦

$ glxgears
305 frames in 5.0 seconds = 60.997 FPS
296 frames in 5.0 seconds = 58.981 FPS
288 frames in 5.0 seconds = 57.464 FPS
283 frames in 5.0 seconds = 56.417 FPS
300 frames in 5.0 seconds = 59.831 FPS
301 frames in 5.0 seconds = 60.018 FPS
$ fgl_glxgears
Using GLX_SGIX_pbuffer
240 frames in 5.0 seconds = 48.000 FPS
300 frames in 5.0 seconds = 60.000 FPS
300 frames in 5.0 seconds = 60.000 FPS
300 frames in 5.0 seconds = 60.000 FPS
300 frames in 5.0 seconds = 60.000 FPS
300 frames in 5.0 seconds = 60.000 FPS

性能越来越低了,急ing~~~~~~~~~~


_________________
我是一只小小鸟,多么渴望飞得高~


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-12-27 16:23 

注册: 2007-09-06 16:07
帖子: 466
送出感谢: 0 次
接收感谢: 0 次
把你的系统硬件配置、安装驱动的过程的命令说一下啊。

看你的输出说明驱动装好了,但是速度有问题?
你装的驱动版本?
有没有开xgl?

如果是7.11 或者 7.12 驱动
不要开启xgl
并且在xorg.conf里面应该是:
Section "Extensions"
Option "Composite" "1"
EndSection
Section "ServerFlags"
Option "AIGLX" "on"
EndSection


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-12-28 10:02 

注册: 2007-12-13 21:55
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
装得是7.11的驱动
按照这个帖子一步步地安装的
http://forum.ubuntu.org.cn/viewtopic.php?t=91719

我机器的配置如下
CPU 类型 Intel Pentium 4 515, 2933 MHz (22 x 133)
主板名称 ECS 661FX-M (Deluxe) / 661FX-M7 / SF2 / Abit SG-72 / Acer E61ML / AOpen s661FXm-US/s661FXm-7US/s661GXm-U
主板芯片组 SiS 661FX
系统内存 512 MB (PC3200 DDR SDRAM)
DIMM1: Ramaxel's Making 256 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz) (2.0-2-2-6 @ 133 MHz)
DIMM2: Kingston K 256 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz) (2.0-2-2-6 @ 133 MHz)
BIOS 类型 Award (11/26/04)

显示卡 RADEON 9600 SERIES - Secondary (128 MB)
显示卡 RADEON 9600 SERIES (128 MB)
3D 加速器 ATI Radeon 9600 SE (RV350)
显示器 Legend LXH-P17L3 [17" LCD] (3M23543)

声卡 Realtek ALC655 @ SiS 7012 Audio Device

IDE 控制器 SiS 5513 IDE UDMA Controller
存储控制器 SiS 180/181 RAID Controller

硬盘驱动器 ST3120022A (120 GB, 7200 RPM, Ultra-ATA/100)
硬盘驱动器 WDC WD100AB-00BPA1 (9 GB, IDE)

键盘 Legend Standard Keyboard
鼠标 HID-compliant mouse
网络适配器 Realtek RTL8139/810x Family Fast Ethernet NIC









非常感谢楼上的热心指点~~~~~谢谢!


_________________
我是一只小小鸟,多么渴望飞得高~


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-29 12:15 

注册: 2007-09-06 16:07
帖子: 466
送出感谢: 0 次
接收感谢: 0 次
难道你从头到尾所有的都做了?包括compiz、awn等等?

我以前安装的时候都没有执行12、13两步,照样用

最近一次按装7.12驱动,过程是这样的:
sudo lrm-manager
sudo apt-get autoremove fglrx*
sudo ./ati-......x86-xxxxxxxx.run 这个是你下载的驱动文件名
如果安装了xgl,那么在~/.config什么的目录下建立一个空的文件名字为disable,这样下次启动后,xgl就不会加载了。

然后,xorg.conf里面:
Section "Extensions"
Option "Composite" "1"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection
估计你是这个问题,因为看你给的xorg.conf里面,你的"Composite"值是"0"

其他的什么ati-config什么的,就按你说的帖子里面一样做,配置好xorg.conf。
然后重新启动。
所有的就都好了。
如果要搞什么透明主题,安装个emerad。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译