[问题]CDMA1X(华为EC321)如何设置上网,我的方法如下,但不成,请大家帮忙???

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
red_bl
帖子: 16
注册时间: 2007-12-26 18:08
送出感谢: 0
接收感谢: 0

[问题]CDMA1X(华为EC321)如何设置上网,我的方法如下,但不成,请大家帮忙???

#1

帖子 red_bl » 2007-12-29 13:06

我的卡是华为EC321,PCMCIA口的
我的设置方法如下:

第一:
dmesg | grep tty
[ 3.752452] 00:0a: ttyS0 at I/O 0x3f8 (irq = 4) is a NS16550A
[ 20.736000] usb 5-1: GSM modem (1-port) converter now attached to ttyUSB0
[ 20.736000] usb 5-1: GSM modem (1-port) converter now attached to ttyUSB1
[ 24.292000] audit(1198903162.861:3): type=1503 operation="inode_permission" requested_mask="a" denied_mask="a" name="/dev/tty" pid=4866 profile="/usr/sbin/cupsd"
然后:
root@today-lm:~# sudo ln -sf /dev/ttyS1 /dev/modem
root@today-lm:~# sudo gedit /etc/wvdial.conf
把内容改成如下:
代码:
[Modem0]
Modem = /dev/ttyUSB1
Baud = 115200
SetVolume = 0
Dial Command = ATDT
Init1 = ATZ
FlowControl = Hardware (CRTSCTS)
[Dialer Defaults]
Username = CARD
Password = CARD
Phone = #777
Stupid Mode = 1
Inherits = Modem0
执行:
root@today-lm:~# sudo apt-get install setserial
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
setserial 已经是最新的版本了。
已经不需要下列自动安装的软件包:
libchewing3-data libchewing3 openoffice.org-l10n-zh-cn
openoffice.org-l10n-zh-tw openoffice.org-help-zh-cn
mozilla-firefox-locale-zh-cn openoffice.org-help-zh-tw
mozilla-firefox-locale-zh-tw libqt3-mt libaudio2
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
执行:
root@today-lm:~# sudo setserial /dev/ttyS1 baud_base 230400
拨号:
root@today-lm:~# sudo wvdial
WvDial<*1>: WvDial: Internet dialer version 1.56
WvModem<*1>: Cannot get information for serial port.
WvDial<*1>: Initializing modem.
WvDial<*1>: Sending: ATZ
WvDial<*1>: Sending: ATQ0
WvDial<*1>: Re-Sending: ATZ
WvDial<Err>: Modem not responding.

到了上一步,显示Modem not responding 无响应
我就不知道怎么弄了
请各位帮忙
还有是不是需要设置MODEM的参数,我不太清楚,请指教!!!
red_bl
帖子: 16
注册时间: 2007-12-26 18:08
送出感谢: 0
接收感谢: 0

#2

帖子 red_bl » 2007-12-31 11:53

大家没人回答

无奈……

不过我自己搞定了

我看了几篇文章都是最后的一个设备ttyS1

我自己胡弄了一下 ,全部改成ttyS0了,就好了

很感谢大家的 无私奉献!!
头像
追疯少年
帖子: 950
注册时间: 2008-03-13 23:37
送出感谢: 0
接收感谢: 1 次
联系:

全部改成ttyS0????

#3

帖子 追疯少年 » 2008-03-20 22:51

我的是huawei E220.我去试试看。谢谢了
我已经找了很久很久了啊
回复

回到 “常用硬件支持”