apt安装postgresql-8.1出错

数据库服务和管理,MySQL/PostgreSQL/Oracle/Sybase 等
回复
ciw
帖子: 28
注册时间: 2005-09-10 21:20
来自: 江苏南京
送出感谢: 0
接收感谢: 0
联系:

apt安装postgresql-8.1出错

#1

帖子 ciw » 2006-03-28 17:01

root@ubuntu:~# apt-get install postgresql-8.1
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
将会安装下列额外的软件包:
postgresql-common
下列【新】软件包将被安装:
postgresql-8.1 postgresql-common
共升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 0B/3093kB 的软件包。
解压缩后会消耗掉 13.3MB 的额外空间。
您希望继续执行吗?[Y/n]y
正在预设定软件包 ...
预设定 postgresql-common 失败,退出状态为 1
选中了曾被取消选择的软件包 postgresql-common。
(正在读取数据库 ... 系统当前总共安装有 14814 个文件和目录。)
正在解压缩 postgresql-common (从 .../postgresql-common_48ubuntu2_all.deb) ...
选中了曾被取消选择的软件包 postgresql-8.1。
正在解压缩 postgresql-8.1 (从 .../postgresql-8.1_8.1.3-2build1_i386.deb) ...
正在设置 postgresql-common (48ubuntu2) ...
dpkg:处理 postgresql-common (--configure)时出错:
子进程·post-installation script·返回了错误号·1
dpkg:依赖关系问题使得 postgresql-8.1 的配置工作不能继续:
postgresql-8.1 依赖于 postgresql-common (>= 39);然而:
软件包 postgresql-common还没有被配置。
dpkg:处理 postgresql-8.1 (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
postgresql-common
postgresql-8.1
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@ubuntu:~#
好好学习,天天向上
ciw
帖子: 28
注册时间: 2005-09-10 21:20
来自: 江苏南京
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 ciw » 2006-03-29 12:50

今天已经OK了!

apt-get update apt-get upgrade后,今天没有错误了! !

看来是个bug
好好学习,天天向上
zhangwei
帖子: 1
注册时间: 2006-03-31 13:48
送出感谢: 0
接收感谢: 0

我也准备用这个版本的LINUX安装一下postgresql

#3

帖子 zhangwei » 2006-03-31 13:53

试了许多版本的linux,FC4感觉用起来总是有些不太爽,可能是硬件的兼容性吧,我现在用的是centos这是一个很不错的版本,很稳定,但软件好象比较老一点:)现在想试下Ubuntu,因为毕竟是一个排名第一的东东:)
回复

回到 “数据库管理”