当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : Oracle安装问题,多次解决无果,求助
帖子发表于 : 2008-05-15 21:07 

注册: 2007-11-06 19:39
帖子: 82
送出感谢: 0 次
接收感谢: 0 次
我在安装oracle时,到了系统自检那一步一下就跳过去,终端显示
rpm: To install rpm packages on Debian systems, use alien. See README.Debian.
error: cannot open Packages index using db3 - No such file or directory (2)
error: cannot open Packages database in /var/lib/rpm
rpm: To install rpm packages on Debian systems, use alien. See README.Debian.
error: cannot open Packages index using db3 - No such file or directory (2)
error: cannot open Packages database in /var/lib/rpm
我返回上一步看到自检只进行了11%,到第二步:检查系统软件包过不去,我该装的包都装了,我用的是804,在704时也遇到该问题,难道是我包没装全?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-16 8:59 

注册: 2007-11-06 19:39
帖子: 82
送出感谢: 0 次
接收感谢: 0 次
不能吧,去年这个问题就没人能解决,今年还没有人?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-16 11:23 
头像

注册: 2008-01-02 17:26
帖子: 199
送出感谢: 0 次
接收感谢: 0 次
你没仔细看错误信息还是你不懂English?
rpm: To install rpm packages on Debian systems, use alien. See README.Debian.
你下的是rpm格式的


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-16 12:22 

注册: 2008-05-02 10:33
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install alien


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-16 12:51 

注册: 2007-11-06 19:39
帖子: 82
送出感谢: 0 次
接收感谢: 0 次
alien包我装了,再说我装的Oracle10g企业版还有deb的?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-16 13:34 
头像

注册: 2008-01-02 17:26
帖子: 199
送出感谢: 0 次
接收感谢: 0 次
给你个地址 http://ubuntu.cn99.com/oracle/10g/10201 ... inux32.zip


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-16 14:23 

注册: 2007-11-06 19:39
帖子: 82
送出感谢: 0 次
接收感谢: 0 次
能不能问一下这个zip包跟Oracle官方网站上下载的有啥区别?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-05-16 14:48 
头像

注册: 2008-01-02 17:26
帖子: 199
送出感谢: 0 次
接收感谢: 0 次
没啥区别,只不过我从oracle官网上下载速度慢些


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-16 15:31 

注册: 2007-11-06 19:39
帖子: 82
送出感谢: 0 次
接收感谢: 0 次
这个我有,我用的就是这个!!!!我说的就是这个包出现了上述问题!


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-06-08 18:33 

注册: 2008-04-27 23:37
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
别用Ubuntu装Oracle Enterprise版,Oracle只支持RedHat AS和Oracle自己发行的Enterprise Linux

如果你用Ubuntu,安装Oracle XE版,学习够用了
http://littlebrain.org/2008/05/12/how-t ... tu-64-bit/
32位的安装类似


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-06-09 2:16 

注册: 2008-06-01 19:01
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
建议你到书店去买本书,今天小弟我看了一下感觉不错,也写的挺详细的,书的名字叫"基于linux的oracle数据库管理"北京邮电大学出版社,价格只有26元很便宜,其中的平台是esa4+oracel 10g,和ubuntu应该区别不是太大,不过建议你还是装rd的好,毕竟是ORACLE官方支持的,然后配合书一起看相信不会出什么问题,书留着以后还能当字典翻翻,有问题的时候可以查查。书我是在上海书城买的,不知道兄弟那里有没有。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-06-21 10:57 

注册: 2008-05-08 0:26
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
参考老外的帖子:
http://www.pythian.com/blogs/968/instal ... ardy-heron
中文帖子:
http://hi.baidu.com/wuxicn/blog/item/0c ... 7ef94.html
祝你好运!


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-07-01 12:17 

注册: 2007-12-14 9:39
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
我也遇到了同样的问题,在用DBCA建库的时候,在最后一步配置窗口变成了灰色,等半天也没有反应,在终端看也报了楼主的错误,RPM包也下载了。感觉是UBUNTU和RPM包之间的问题,我用的是UBNTU8.04,oracle11g,参考的是那老外的文章,前面很顺利!!在网上查看了一些资料,没有解决,希望各位帮忙!!!谢谢!!


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-07-05 7:39 

注册: 2006-09-27 10:35
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
zm508_china 写道:
我也遇到了同样的问题,在用DBCA建库的时候,在最后一步配置窗口变成了灰色,等半天也没有反应,在终端看也报了楼主的错误,RPM包也下载了。感觉是UBUNTU和RPM包之间的问题,我用的是UBNTU8.04,oracle11g,参考的是那老外的文章,前面很顺利!!在网上查看了一些资料,没有解决,希望各位帮忙!!!谢谢!!


多等等,我等了很长时间。
特别是你在装的时候选择了直接建数据库的话,等的时间更长。


页首
 用户资料  
 
15 楼 
 文章标题 : 要什么就装什么,把rpm也装上。
帖子发表于 : 2008-07-07 8:17 

注册: 2007-10-12 14:12
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
要什么就装什么,把rpm也装上。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译