MySQL安装时出现包依赖错误!!

数据库服务和管理,MySQL/PostgreSQL/Oracle/Sybase 等
回复
shushine
帖子: 3
注册时间: 2008-09-30 9:49
送出感谢: 0
接收感谢: 0

MySQL安装时出现包依赖错误!!

#1

帖子 shushine » 2008-10-02 0:02

MySQL安装时经常提示包依赖错误 不知如何解决
正在解压缩将用于更替的包文件 mysql-server-5.0 ...
dpkg:依赖关系问题使得 mysql-server-5.0 的配置工作不能继续:
mysql-server-5.0 依赖于 mysql-client-5.0 (>= 5.0.21-3ubuntu1);然而:
软件包 mysql-client-5.0 还没有被配置。
mysql-server-5.0 依赖于 libdbi-perl;然而:
软件包 libdbi-perl 还没有被配置。
dpkg:处理 mysql-server-5.0 (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
mysql-server-5.0

。。。当我安装mysql-client-5.0时候 又出错了如下:
正在解压缩将用于更替的包文件 mysql-client-5.0 ...
dpkg:依赖关系问题使得 mysql-client-5.0 的配置工作不能继续:
mysql-client-5.0 依赖于 libdbi-perl;然而:
软件包 libdbi-perl 还没有被配置。
mysql-client-5.0 依赖于 libdbd-mysql-perl (>= 1.2202);然而:
未曾安装软件包“libdbd-mysql-perl”。
dpkg:处理 mysql-client-5.0 (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
mysql-client-5.0

请问哪位大侠晓得解决之道阿
shushine
帖子: 3
注册时间: 2008-09-30 9:49
送出感谢: 0
接收感谢: 0

Re: MySQL安装时出现包依赖错误!!

#2

帖子 shushine » 2008-10-02 22:54

问题已经解决 哈哈
shushine
帖子: 3
注册时间: 2008-09-30 9:49
送出感谢: 0
接收感谢: 0

Re: MySQL安装时出现包依赖错误!!

#3

帖子 shushine » 2008-10-02 22:55

原来是 包没更新 升级的原因
lonely203
帖子: 33
注册时间: 2007-06-25 18:21
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

Re: MySQL安装时出现包依赖错误!!

#4

帖子 lonely203 » 2008-10-26 20:35

怎么更新的?我这边同样问题,
我更新源也一样有问题呀
头像
guooo
帖子: 18
注册时间: 2007-03-21 13:42
来自: http://www.cjfuture.cn
送出感谢: 0
接收感谢: 0
联系:

Re: MySQL安装时出现包依赖错误!!

#5

帖子 guooo » 2008-10-26 22:26

lonely203 写了:怎么更新的?我这边同样问题,
我更新源也一样有问题呀

执行你要安装的程序后,若说是有软件依赖关系.执行

apt-get -f install 安装即可.
lonely203
帖子: 33
注册时间: 2007-06-25 18:21
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

Re: MySQL安装时出现包依赖错误!!

#6

帖子 lonely203 » 2008-10-26 23:13

guooo 写了:
lonely203 写了:怎么更新的?我这边同样问题,
我更新源也一样有问题呀

执行你要安装的程序后,若说是有软件依赖关系.执行

apt-get -f install 安装即可.

也不行呀,还是同样的错,若是用新得力安装时再调你说的命令,直接说有个目录在使用中,无法操作。
lonely203
帖子: 33
注册时间: 2007-06-25 18:21
来自: 深圳
送出感谢: 0
接收感谢: 0
联系:

Re: MySQL安装时出现包依赖错误!!

#7

帖子 lonely203 » 2008-10-26 23:58

没有别的人遇到吗?过路了如果知道教下我,一直找不到原因,我的是8。10版的
绿色植物
帖子: 35
注册时间: 2008-12-22 19:40
送出感谢: 0
接收感谢: 0

Re: MySQL安装时出现包依赖错误!!

#8

帖子 绿色植物 » 2008-12-26 16:41

shushine 写了:原来是 包没更新 升级的原因
那么怎么给某个包升级? :em03 我是初学者。
我也有这个问题,用apt-get -f install mysql-server也不行。
看见论坛里一位高手留了一个网址,http://blog.chinaunix.net/u/21684/showart_368091.html
sudo aptitude install mysql mysql-admin mysql-client-5.0 mysql-navigator mysql-query-browser mysql-server-5.0
就成功了 :em11
但我也不明白为啥 :em02
哪位高手能给解释一下?
回复

回到 “数据库管理”