[求助]在安装软件时configure报错

数据库服务和管理,MySQL/PostgreSQL/Oracle/Sybase 等
回复
leolinux
帖子: 2
注册时间: 2009-03-11 13:53
送出感谢: 0
接收感谢: 0

[求助]在安装软件时configure报错

#1

帖子 leolinux » 2009-03-11 13:57

error: C++ compiler cannot create executables
在网上搜索解决办法几乎都是这样说:
sudo apt-get gcc libc6-dev
运行后却显示:
E: 无效的操作 libc6-dev
这是怎么回事啊
我在config.log里找到这样的信息
configure:2142: checking for g++
configure:2171: result: no
是不是说我没有安装就不行?
系统自带了gcc4.3.2
:em23
谢谢了!
leolinux
帖子: 2
注册时间: 2009-03-11 13:53
送出感谢: 0
接收感谢: 0

Re: [求助]在安装软件时configure报错

#2

帖子 leolinux » 2009-03-11 14:10

问题解决了!
在学校的bbs的linux有高手帮忙解决了这个问题!
gcc不能编译c++所以必须安装g++
运行
sudo apt-get install build-essential
可以将g++正确装。
之后问题就可以解决了!谢谢高手! :em38
头像
witcher
帖子: 9
注册时间: 2009-02-16 11:01
送出感谢: 0
接收感谢: 0

Re: [求助]在安装软件时configure报错

#3

帖子 witcher » 2009-04-10 12:28

:em11
夫君子之行,静以修身,俭以养德。非淡泊无以明志,非宁静无以致远。
回复

回到 “数据库管理”