当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : Oracle11g 安装成功 但是出现部分中文不显示! 求助~~~
帖子发表于 : 2009-03-23 17:09 

注册: 2008-11-06 22:56
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
按照坛子里面的介绍,在Ubuntu8.10上装完 Oracle 11g,整个安装过程都是显示汉字的,没什么问题。但是等到装完后进入控制台的时候,发现一些按钮不能正常显示汉字,只有一个个的空白方块。这是怎么回事啊? 有没有哪位高人给予帮助!谢谢了~~


附件:
文件注释: 截图
oracle11g.png
oracle11g.png [ 218.15 KiB | 被浏览 991 次 ]



_________________
小白一个,刚开始接触Linux!
DELL XPS 1330
T7250+2G+160G+NV8400mGS+LED
页首
 用户资料  
 
2 楼 
 文章标题 : Re: Oracle11g 安装成功 但是出现部分中文不显示! 求助~~~
帖子发表于 : 2009-03-23 21:00 
头像

注册: 2008-07-28 19:51
帖子: 805
地址: 长沙
送出感谢: 1
接收感谢: 2
解决办法: 参照http://www.eygle.com/archives/2006/03/oracle10g_em_font_change.html,这个人是专家


1. 到$ORACLE_HOME/jre/1.4.2/lib下面找一个字体配置文件替换到默认的font.properties,比如用font.properties.zh_CN.Redhat

2. 在$ORACLE_HOME/jdk/jre/lib同样操作 (是不是这两个地方都改,我也不太确定)

3. 在$ORACLE_HOME/oc4j/j2ee/oc4j_applications/applications/em/em/cabo/images/cache/zhs下,删除所有的gif文件

4. 即使这样,显示的还是乱码。

因为 font.properties.zh_CN.Redhat , 用的是 /usr/share/fonts/zh_CN/TrueType/zysong.ttf 而这个默认是没有的,所以还需要拷贝一个字体到这个地方,比如我把宋体simsun.ttc拉到了这个地方

启动EM后就可以了,我的效果图
附件:
Screenshot-4.png
Screenshot-4.png [ 89.65 KiB | 被浏览 982 次 ]



页首
 用户资料  
 
3 楼 
 文章标题 : Re: Oracle11g 安装成功 但是出现部分中文不显示! 求助~~~
帖子发表于 : 2009-03-24 10:56 

注册: 2008-11-06 22:56
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
谢谢! 我的文件怎么和你们的不一样?难道装错了? 找不到$ORACLE_HOME/jre/1.4.2/lib 提示没有这个文件或文件夹!
$ORACLE_HOME/jdk/jre/lib 这个里面完全没有汉字的配置 font*zh_CN* 找不到。
这个是怎么回事啊?


附件:
Screenshot.png
Screenshot.png [ 181.61 KiB | 被浏览 965 次 ]



_________________
小白一个,刚开始接触Linux!
DELL XPS 1330
T7250+2G+160G+NV8400mGS+LED
页首
 用户资料  
 
4 楼 
 文章标题 : Re: Oracle11g 安装成功 但是出现部分中文不显示! 求助~~~
帖子发表于 : 2009-03-24 11:09 
头像

注册: 2008-07-28 19:51
帖子: 805
地址: 长沙
送出感谢: 1
接收感谢: 2
你的贴图里面不是有很多fonconfig*的文件吗

我贴图的是10g,你装的是11g


_________________
我的乌斑兔儿:http://zhanggang.net/m/b/b1/ubuntu右键选择在新的窗体打开
右边有一只黄手 ----> 或者注册Dropbox中文版感谢我


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Oracle11g 安装成功 但是出现部分中文不显示! 求助~~~
帖子发表于 : 2009-03-24 13:21 

注册: 2008-11-06 22:56
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
对! 不过貌似没有中文的配置啊~~ 我修改了配置文件,发现还是不行! 更改为我机器上有的字体 但是还是不行!
下面是我的配置文件,我把fontconfig.RedHat.9.0.properties.src 设为了 fontconfig.properties.src

allfonts.chinese-gb18030=-misc-SimSun-medium-r-normal--*-%d-*-*-c-*-iso10646-11=/usr/share/fonts/zh_CN/TrueType/SimSun.ttc
allfonts.chinese-gb18030.motif=-isas-song ti-medium-r-normal--*-%d-*-*-c-*-gb2312.1980-0=/usr/share/fonts/zh_CN/TrueType/SimSun.ttc
allfonts.chinese-big5=-arphic technology co.-ar pl mingti2l big5-medium-r-normal--*-%d-*-*-c-*-iso10646-1
allfonts.chinese-big5.motif=-taipei-fixed-medium-r-normal--*-%d-*-*-c-*-big5-0
allfonts.lucida=-b&h-lucidasans-medium-r-normal-sans-*-%d-*-*-p-*-iso8859-1


_________________
小白一个,刚开始接触Linux!
DELL XPS 1330
T7250+2G+160G+NV8400mGS+LED


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Oracle11g 安装成功 但是出现部分中文不显示! 求助~~~
帖子发表于 : 2009-07-02 20:58 

注册: 2009-07-02 20:56
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
关注~~~~~~遇到同样的问题,急啊
你有解决吗?????


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译