mysql如何支持utf8

数据库服务和管理,MySQL/PostgreSQL/Oracle/Sybase 等
回复
freecode
帖子: 118
注册时间: 2005-05-11 8:56
送出感谢: 0
接收感谢: 0

mysql如何支持utf8

#1

帖子 freecode » 2006-07-20 15:35

我的平台是ubuntu5.10 server版本,mysql为4.0.24,我在my.cnf的[mysqld]中增加以下内容:
default-character-set=utf8

sudo /usr/sbin/mysqld时报,Character set 'utf8' is not a compiled character set and is not specified in the '/usr/share/mysql/charsets/Index' file

还有如果用sudo /etc/init.d/mysql restart启动时报:
/usr/bin/mysqladmin:connect to server at 'localhost' failed
error:'Can't connect to local Mysql server through socket 'var/run/mysql/mysqld.sock' (2)'
Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
telnetor
帖子: 48
注册时间: 2006-08-03 0:17
送出感谢: 0
接收感谢: 0

#2

帖子 telnetor » 2006-08-30 19:54

一样的问题,期待高手出招援助,谢谢!
ryan2
帖子: 29
注册时间: 2006-04-12 15:26
送出感谢: 0
接收感谢: 0

#3

帖子 ryan2 » 2006-08-30 20:07

我用源码的方式编译安装的mysql
安装完成后就支持utf8了

# MySQL 字符集: UTF-8 Unicode (utf8)
telnetor
帖子: 48
注册时间: 2006-08-03 0:17
送出感谢: 0
接收感谢: 0

#4

帖子 telnetor » 2006-09-10 10:16

在/etc/mysql/my.cnf 中修改如下配置,保存并重启服务器就行了
[mysqld]
#
# * Basic Settings
#
user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
language = /usr/share/mysql/english
skip-external-locking
max_connections = 500
wait_timeout= 200
interactive_timeout = 200
connect_timeout = 200
character_set_server = utf8
#
telnetor
帖子: 48
注册时间: 2006-08-03 0:17
送出感谢: 0
接收感谢: 0

#5

帖子 telnetor » 2006-09-10 10:17

ryan2 写了:我用源码的方式编译安装的mysql
安装完成后就支持utf8了

# MySQL 字符集: UTF-8 Unicode (utf8)

老大给说说怎么编译的嘛?我的总搞不成阿,只能用源里的。。。。
头像
xjflyttp
帖子: 281
注册时间: 2006-10-18 0:36
来自: Core
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 xjflyttp » 2006-10-18 2:11

配置文件里面在mysqld段下面写入
set-variable = default-character-set=utf8

php程序查询之前发送一个set names utf8就ok````
T60p/T7600/2G/WD1600BJKT/BT/AR5008/V5200/15' QXGA
回复

回到 “数据库管理”