当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 9.04下安装tora 2.0
帖子发表于 : 2009-05-08 0:12 

注册: 2008-11-14 17:05
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
tora是啥,我就不说了,搞oracle的人一定知道。
新出了2。0版的,网站带的deb包安装在9。04上,连接oracle后会报错。原因是 tora 2.0是用qt 4.4编写的,9.04带的是qt 4.5。
要解决这个问题,只能重新编译
1。安装oracle client 10g,并设置ORACL_HOME变量。
这个就不说了,大家自己找文章看
2。下载tora 2.0,解压
3。执行./configure --prefix=/usr/local,有遗漏的lib,自己装一下哈
4。修改src目录下所有moc_to打头的cpp文件,将
#elif Q_MOC_OUTPUT_REVISION != 59
改成
#elif Q_MOC_OUTPUT_REVISION != 61
大概有100多个文件,自己想办法改哈
5。make, make install
6。搞定,收工

2。0版的tora比1。3版的改进很多,很不错,有赶上toad的趋势。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译