当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu9.10下安装10.2.0.1成功后打补丁升级到10.2.0.4出错???
帖子发表于 : 2010-06-09 19:21 

注册: 2010-05-14 17:04
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
1、启动已安装成功的oracle
oracle@stanley-laptop:~$ sqlplus /nolog

SQL*Plus: Release 10.2.0.1.0 - Production on Wed Jun 9 19:14:45 2010

Copyright (c) 1982, 2005, Oracle. All rights reserved.

SQL> conn / as sysdba
Connected to an idle instance.
SQL> startup
ORACLE instance started.

Total System Global Area 536870912 bytes
Fixed Size 1220408 bytes
Variable Size 176160968 bytes
Database Buffers 352321536 bytes
Redo Buffers 7168000 bytes
Database mounted.
Database opened.
SQL> select * from dual;

D
-
X

2、关闭数据库
SQL> shutdown immediate;
Database closed.
Database dismounted.
ORACLE instance shut down.

3、加载补丁并安装时报错
root@stanley-laptop:~# mount -o loop /home/oracle/p6810189_10204_Linux-x86.iso /media/cdrom0
root@stanley-laptop:~# su - oracle
oracle@stanley-laptop:~$ /media/cdrom0/Disk1/runInstaller
正在启动 Oracle Universal Installer...

正在检查安装程序要求...

检查操作系统版本: 必须是redhat-3, SuSE-9, SuSE-10, redhat-4, redhat-5, UnitedLinux-1.0, asianux-1, asianux-2 or asianux-3
通过


所有安装程序要求均已满足。

检查临时空间: 必须大于 80 MB。 实际为 93496 MB 通过
检查交换空间: 必须大于 150 MB。 实际为 5867 MB 通过
检查监视器: 监视器配置至少必须显示 256 种颜色
>>> 无法执行 /usr/X11R6/bin/xdpyinfo 未通过 <<<<

未通过某些可选的先决条件检查 (参见上文)。是否继续? (y/n) [n] y
准备从以下地址启动 Oracle Universal Installer /tmp/OraInstall2010-06-09_07-10-49PM. 请稍候...
DISPLAY 尚未设置。请设置 DISPLAY 后重试。
根据所使用的 Unix Shell, 您可以使用以下命令之一作为设置 DISPLAY 环境变量的示例:
- 对于 csh: % setenv DISPLAY 192.168.1.128:0.0
- 对于 sh, ksh 和 bash: $ DISPLAY=192.168.1.128:0.0; export DISPLAY
使用以下命令来查看所使用的 shell:
echo $SHELL
使用以下命令来查看 DISPLAY 环境变量的当前设置:
echo $DISPLAY
- 确保客户机用户具有连接到 X 服务器的权限。
要允许客户机用户访问 X 服务器, 请以该用户的身份打开 xterm, dtterm 或 xconsole, 并键入以下命令:
% xhost +
要测试 DISPLAY 环境变量是否设置正确, 请运行本机操作系统自带的基于 X11 的程序, 例如 'xclock':
% <xclock 的完整路径.. 参见下文>
如果无法成功运行 xclock, 请与您的 PC-X 服务器或操作系统供应商联系以获得帮助。
xclock 的典型路径为: /usr/X11R6/bin/xclock
4、查看是否安装时钟程序
root@stanley-laptop:~# which xclock
/usr/bin/xclock
5、查看网络配置
root@stanley-laptop:~# ifconfig
eth0 Link encap:以太网 硬件地址 00:1e:ec:0f:11:cf
inet 地址:192.168.1.101 广播:192.168.1.255 掩码:255.255.255.0
inet6 地址: fe80::21e:ecff:fe0f:11cf/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 跃点数:1
接收数据包:12340 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:10655 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:12092489 (12.0 MB) 发送字节:1235623 (1.2 MB)
中断:19

lo Link encap:本地环回
inet 地址:127.0.0.1 掩码:255.0.0.0
inet6 地址: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 跃点数:1
接收数据包:10 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:10 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:540 (540.0 B) 发送字节:540 (540.0 B)
6、查看hosts文件
root@stanley-laptop:~# cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 stanley-laptop

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

root@stanley-laptop:~# export DISPLAY=192.168.1.101:0.0
root@stanley-laptop:~# xhost +
xhost: unable to open display "192.168.1.101:0.0"

我也google了些资料可惜就是没把问题解决,各位给小弟支点招,多谢了?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu9.10下安装10.2.0.1成功后打补丁升级到10.2.0.4出错???
帖子发表于 : 2010-06-12 13:05 

注册: 2010-05-14 17:04
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
这个问题俺已解决 谢谢各位看客 :em02


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu9.10下安装10.2.0.1成功后打补丁升级到10.2.0.4出错???
帖子发表于 : 2010-11-15 19:40 
头像

注册: 2009-10-22 0:08
帖子: 64
送出感谢: 0 次
接收感谢: 0 次
oracle@wyl-19:/home/wyl/database$ ./runInstaller -jreLoc /usr/lib/jvm/java-1.5.0-sun/jre
正在启动 Oracle Universal Installer...

检查临时空间: 必须大于 80 MB。 实际为 10669 MB 通过
检查交换空间: 必须大于 150 MB。 实际为 999 MB 通过
检查监视器: 监视器配置至少必须显示 256 种颜色
>>> 无法使用命令 /usr/X11R6/bin/xdpyinfo 自动检查显示器颜色。请检查是否设置了 DISPLAY 变量。 未通过 <<<<

未通过某些要求检查。必须先满足这些要求,

然后才能继续安装,那时将重新检查这些要求。

是否继续? (y/n) [n] y


正在重新检查安装程序要求....
准备从以下地址启动 Oracle Universal Installer /tmp/OraInstall2010-11-15_07-35-44PM. 请稍候...oracle@wyl-19:/home/wyl/database$ Oracle Universal Installer, 版本 11.1.0.6.0 正式版
版权所有 (c) 1999, 2007, Oracle。保留所有权利。

Can't connect to X11 window server using '192.168.1.128:0.0' as the value of the DISPLAY variable.
192.168.1.128:0.0
192.168.1.128:0.0
OUI-10025: 由于出现以下错误, 无法启动交互式安装会话: Can't connect to X11 window server using '192.168.1.128:0.0' as the value of the DISPLAY variable.。DISPLAY 环境变量应该设置为 <hostname>:<screen> 或 <IP address>:<screen>, 其中 <screen> 通常为 '0.0'。
OUI-10026: 根据所使用的 Unix Shell, 您可以使用以下命令之一作为设置 DISPLAY 环境变量的示例:
- 对于 csh: % setenv DISPLAY 192.168.1.128:0.0
- 对于 sh, ksh 和 bash: $ DISPLAY=192.168.1.128:0.0; export DISPLAY
使用以下命令来查看所使用的 shell:
echo $SHELL
使用以下命令来查看 DISPLAY 环境变量的当前设置:
echo $DISPLAY
- 确保客户机用户具有连接到 X 服务器的权限。
OUI-10027: 要允许客户机用户访问 X 服务器, 请以启动会话的用户身份打开 xterm, dtterm 或 xconsole, 并键入以下命令:
% xhost +
要测试 DISPLAY 环境变量是否设置正确, 请运行本机操作系统自带的基于 X11 的程序, 例如 'xclock':
% <xclock 的完整路径... 参见下文>
如果无法成功运行 xclock, 请与您的 PC-X 服务器或操作系统供应商联系以获得帮助。
'xclock' 的典型路径为: '/usr/X11R6/bin/xclock'




我的就是这个问题,你是怎么解决的阿?
说说哈,谢谢了 :em02


_________________
羽穹寒风。。。。。。天空之城。。。。。绝赞卡农。。。。。。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu9.10下安装10.2.0.1成功后打补丁升级到10.2.0.4出错???
帖子发表于 : 2010-11-15 20:16 

注册: 2010-05-14 17:04
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
直接以oracle用户图形界面登录,然后运行./runInstaller -jreLoc /usr/lib/jvm/java-1.5.0-sun/jre就可以了,呵呵


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu9.10下安装10.2.0.1成功后打补丁升级到10.2.0.4出错???
帖子发表于 : 2010-11-16 14:51 
头像

注册: 2009-10-22 0:08
帖子: 64
送出感谢: 0 次
接收感谢: 0 次
终于装好了。问题又一大堆,用EM登录的时候用那个用户名啊
不是sys吗?
我的那个也不对
在终端也登录不了还有就是怎么让它start 和stop啊。
用了网上的oracledb到时可以运行了就是停步下来


_________________
羽穹寒风。。。。。。天空之城。。。。。绝赞卡农。。。。。。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu9.10下安装10.2.0.1成功后打补丁升级到10.2.0.4出错???
帖子发表于 : 2010-11-17 16:39 

注册: 2010-05-14 17:04
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
wyl-19 写道:
终于装好了。问题又一大堆,用EM登录的时候用那个用户名啊
不是sys吗?
我的那个也不对
在终端也登录不了还有就是怎么让它start 和stop啊。
用了网上的oracledb到时可以运行了就是停步下来


[oracle@ora10 ~]$ emctl start dbconsole启动EM控制台
输出的提示中可以看到类似的:http://stanley:1158/em/console/aboutApplication

启动成功,我们就可以用浏览器进行登陆了.http://DBIP:1158/em/console
(DBIP根据自己的实际情况输入了,1158端口也根据实际情况输入了),然后登陆就OK啦!

同样停止OEM可以输入如下命令:emctl stop dbconsole
没必要设置其他的,使用的时候启动就可以了,类似于windows下设置手动启动,另外em也干不了啥事,还是sqlplus比较牛叉


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu9.10下安装10.2.0.1成功后打补丁升级到10.2.0.4出错???
帖子发表于 : 2010-11-19 20:12 
头像

注册: 2009-10-22 0:08
帖子: 64
送出感谢: 0 次
接收感谢: 0 次
yakun_song 写道:
wyl-19 写道:
终于装好了。问题又一大堆,用EM登录的时候用那个用户名啊
不是sys吗?
我的那个也不对
在终端也登录不了还有就是怎么让它start 和stop啊。
用了网上的oracledb到时可以运行了就是停步下来


[oracle@ora10 ~]$ emctl start dbconsole启动EM控制台
输出的提示中可以看到类似的:http://stanley:1158/em/console/aboutApplication

启动成功,我们就可以用浏览器进行登陆了.http://DBIP:1158/em/console
(DBIP根据自己的实际情况输入了,1158端口也根据实际情况输入了),然后登陆就OK啦!

同样停止OEM可以输入如下命令:emctl stop dbconsole
没必要设置其他的,使用的时候启动就可以了,类似于windows下设置手动启动,另外em也干不了啥事,还是sqlplus比较牛叉



哦,不过总算是安好了,怪不得大家都说得吐血。。。。。。。。。。


_________________
羽穹寒风。。。。。。天空之城。。。。。绝赞卡农。。。。。。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ubuntu9.10下安装10.2.0.1成功后打补丁升级到10.2.0.4出错???
帖子发表于 : 2010-11-19 20:31 
头像

注册: 2009-10-22 0:08
帖子: 64
送出感谢: 0 次
接收感谢: 0 次
还有点小问题我每次启动的时候都得设置ORACLE_SID,在那设置一下就不用了
还有就是怎么能让oracle这个用户直接使用/u01/app/oracle/product/11.1.0/db_1/bin/下的命令,我每次都是 ./去执行


_________________
羽穹寒风。。。。。。天空之城。。。。。绝赞卡农。。。。。。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: ubuntu9.10下安装10.2.0.1成功后打补丁升级到10.2.0.4出错???
帖子发表于 : 2010-11-20 19:03 
头像

注册: 2009-10-22 0:08
帖子: 64
送出感谢: 0 次
接收感谢: 0 次
搞定了在./bashrc 里设置就好了 :em11


_________________
羽穹寒风。。。。。。天空之城。。。。。绝赞卡农。。。。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译