ubuntu10.10+apache2.2.16+php5.2.10启用php5模块后无法打开页面

数据库服务和管理,MySQL/PostgreSQL/Oracle/Sybase 等
回复
waitd
帖子: 1
注册时间: 2010-03-16 19:53
送出感谢: 0
接收感谢: 0

ubuntu10.10+apache2.2.16+php5.2.10启用php5模块后无法打开页面

#1

帖子 waitd » 2011-01-10 17:43

RT
安装apache2成功后进入http://localhost可以正常显示it works
但写一个test.php文件后提示要下载

google了很多帖子后说是apache没有启用php5模块,于是安装了libapache2-mod-php5
输入:sudo a2enmod php5显示already enabled
但这时再访问locahost却显示网站网页打不开;
输入:sudo a2dismod php5之后再restart apache,又可以访问locahost了。

请问是什么原因?是不是因为apache2对php5.2支持不好?

求解答!!
头像
zuiw
帖子: 34
注册时间: 2008-10-15 20:44
送出感谢: 0
接收感谢: 0

Re: ubuntu10.10+apache2.2.16+php5.2.10启用php5模块后无法打开页面

#2

帖子 zuiw » 2011-01-31 17:10

这个模块安装的时候自动安装把
-- 我的城市我的梦 http://www.iamlintao.com
回复

回到 “数据库管理”