[问题]怎样卸载 apt安装的postgresql8.1

数据库服务和管理,MySQL/PostgreSQL/Oracle/Sybase 等
回复
vividness
帖子: 28
注册时间: 2006-11-27 23:46
送出感谢: 0
接收感谢: 0

[问题]怎样卸载 apt安装的postgresql8.1

#1

帖子 vividness » 2007-01-25 20:38

vividness@vividness-desktop:/etc/init.d$ sudo /etc/rc.d/init.d/postgresql stop
sudo: /etc/rc.d/init.d/postgresql: command not found
vividness@vividness-desktop:/etc/init.d$
vividness@vividness-desktop:/etc/init.d$
vividness@vividness-desktop:/etc/init.d$
vividness@vividness-desktop:/etc/init.d$ ps ax | grep postmaster
5187 pts/3 R+ 0:00 grep postmaster
vividness@vividness-desktop:/etc/init.d$ sudo kill -INT 5187
vividness@vividness-desktop:/etc/init.d$ sudo kill 5187
vividness@vividness-desktop:/etc/init.d$ sudo kill 5187 pts/3

vividness@vividness-desktop:/etc/postgresql/8.1/main$ sudo apt-get remove postgresql-8.1
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成

解压缩后将会空出 13.2MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 130049 个文件和目录。)
正在删除 postgresql-8.1 ...
.乱用 19: Can't open /usr/share/postgresql-common/maintscripts-functions
dpkg:处理 postgresql-8.1 (--remove)时出错:
子进程·pre-removal script·返回了错误号·2
在处理时有错误发生:
postgresql-8.1
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zhan » 2007-01-25 21:18

cd /var/lib/dpkg/info
里面有个 postgresql**.prerm 把那个文件弄得只有第一行。(不知道直接删除行不行,没有测试过)
然后再 sudo apt-get --purge remove post...
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
回复

回到 “数据库管理”