Mysql配置字符集失败,求助大神。问题已解决。

数据库服务和管理,MySQL/PostgreSQL/Oracle/Sybase 等
回复
日升月恒
帖子: 43
注册时间: 2015-09-21 13:59
系统: Ubuntu
送出感谢: 6 次
接收感谢: 0

Mysql配置字符集失败,求助大神。问题已解决。

#1

帖子 日升月恒 » 2016-04-24 1:17

目前使用是Ubutu16.04LTS系统,Mysql Ver 14.14 Distrib 5.7.11, for Linux (x86_64) ;网上的教程基本试过了,但是没用。
主要试过以下2种方法:
第一种是 sudo vi /var/lib/mysql/mysql/db.opt 并且修改为

default-character-set=utf8
default-collation=utf8_swedish_ci

第二种是 修改 /etc/mysql/my.cnf 不过这个配置文件里面是空的,于是找了找,在debain.cnf下面找到了
# Automatically generated for Debian scripts. DO NOT TOUCH!
[client]
host = localhost
user = debian-sys-maint
password = ZuE3yWXT1tLzcB0k
socket = /var/run/mysqld/mysqld.sock
default-character-set=utf8

[mysql_upgrade]
host = localhost
user = debian-sys-maint
password = ZuE3yWXT1tLzcB0k
socket = /var/run/mysqld/mysqld.sock
character_set_server=utf8
init_connect='SET NAMES utf8'
于是我自己琢磨着分别在[client]加了default-character-set=utf8,在[mysql_upgrade]下加了character_set_server=utf8
init_connect='SET NAMES utf8'
结果当然是没用的。求助大神帮忙。
上次由 日升月恒 在 2016-04-24 9:52,总共编辑 1 次。
日升月恒
帖子: 43
注册时间: 2015-09-21 13:59
系统: Ubuntu
送出感谢: 6 次
接收感谢: 0

Re: Mysql配置字符集失败,求助大神

#2

帖子 日升月恒 » 2016-04-24 9:51

问题已解决,附上解决方法。另外说一句,5.7跟之前几个版本的配置文件不太一样,对于我这种照本宣科的配置小白来说,难度着实不小。好在最终蒙对了。

打开/etc/mysql 文件夹,找到debain.cnf文件

备份debain.cnf

cp debain.cnf debain.cnf备份.cnf

vi debain.cnf

[client]下添加: default-character-set=utf8

并将以下内容复制到 /etc/mysql/my.cnf

[client]

default-character-set=utf8



sudo vi /usr/share/mysql/my-default.cnf

将以下内容复制到 /etc/mysql/my.cnf下

[mysqld]

character_set_server = utf8

init_connect='SET NAMES utf8'

#以上下划线部分为我自行添加的

 # Remove leading # and set to the amount of RAM for the most important data

# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.

# innodb_buffer_pool_size = 128M

# Remove leading # to turn on a very important data integrity option: logging

# changes to the binary log between backups.

# log_bin

# These are commonly set, remove the # and set as required.

# basedir = .....

# datadir = .....

# port = .....

# server_id = .....

保存退出,并重启。

serviec mysql start
头像
staunch
帖子: 254
注册时间: 2008-07-28 19:29
送出感谢: 0
接收感谢: 1 次

Re: Mysql配置字符集失败,求助大神。问题已解决。

#3

帖子 staunch » 2017-06-23 16:17

找了好久,网上说的改my.cnf里面加两行后直接mysql打不开了,等会儿试试你的这方法
神舟天运F5600
酷睿T5750
GMA X3100
1G DDR2

http://new.qzone.qq.com/422253866/
头像
staunch
帖子: 254
注册时间: 2008-07-28 19:29
送出感谢: 0
接收感谢: 1 次

Re: Mysql配置字符集失败,求助大神。问题已解决。

#4

帖子 staunch » 2017-06-23 21:42

刚测试了成了, 用show variables like '%char%' ;
看到都变成utf8了,
只是楼主这东西写的英语字母打错的太多,如果一点都不懂的人看反而怎么也搞不定了 ,呵呵
神舟天运F5600
酷睿T5750
GMA X3100
1G DDR2

http://new.qzone.qq.com/422253866/
日升月恒
帖子: 43
注册时间: 2015-09-21 13:59
系统: Ubuntu
送出感谢: 6 次
接收感谢: 0

Re: Mysql配置字符集失败,求助大神。问题已解决。

#5

帖子 日升月恒 » 2017-06-26 17:22

staunch 写了:刚测试了成了, 用show variables like '%char%' ;
看到都变成utf8了,
只是楼主这东西写的英语字母打错的太多,如果一点都不懂的人看反而怎么也搞不定了 ,呵呵
时间太久,不记得了。来个感谢 :em09 ,然后献上你的解决方案 :em03
回复

回到 “数据库管理”