[问题]postgreSQL 还是不能安装成功,再次求救!!!!

数据库服务和管理,MySQL/PostgreSQL/Oracle/Sybase 等
回复
feelingwu
帖子: 6
注册时间: 2007-11-15 16:05
送出感谢: 0
接收感谢: 0

[问题]postgreSQL 还是不能安装成功,再次求救!!!!

#1

帖子 feelingwu » 2007-12-21 13:21

postgresql老是无法安装成功,超郁闷

feeling@feeling-laptop:~$ sudo apt-get install postgresql
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
将会安装下列额外的软件包:
postgresql-8.2
建议安装的软件包:
oidentd ident-server
下列【新】软件包将被安装:
postgresql postgresql-8.2
共升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 161 个软件未被升级。
需要下载 0B/3420kB 的软件包。
解压缩后会消耗掉 12.3MB 的额外空间。
您希望继续执行吗?[Y/n]y
选中了曾被取消选择的软件包 postgresql-8.2。
(正在读取数据库 ... 系统当前总共安装有 136528 个文件和目录。)
正在解压缩 postgresql-8.2 (从 .../postgresql-8.2_8.2.5-1.1_i386.deb) ...
选中了曾被取消选择的软件包 postgresql。
正在解压缩 postgresql (从 .../postgresql_8.2.5-1.1_all.deb) ...
正在设置 postgresql-8.2 (8.2.5-1.1) ...
Creating new cluster (configuration: /etc/postgresql/8.2/main, data: /var/lib/postgresql/8.2/main)...
Moving configuration file /var/lib/postgresql/8.2/main/postgresql.conf to /etc/postgresql/8.2/main...
Moving configuration file /var/lib/postgresql/8.2/main/pg_hba.conf to /etc/postgresql/8.2/main...
Moving configuration file /var/lib/postgresql/8.2/main/pg_ident.conf to /etc/postgresql/8.2/main...
Warning: The socket directory for owners other than 'postgres'
defaults to /tmp. You might want to change the unix_socket_directory parameter
in postgresql.conf to a more secure directory.
Configuring postgresql.conf to use port 5432...
* Starting PostgreSQL 8.2 database server * The PostgreSQL server failed to start. Please check the log output:
2007-12-21 13:18:55 CST 日志: 无法装载根 (root) 认证文件 "root.crt": no SSL error reported
2007-12-21 13:18:55 CST 详细信息: 将不检验客户端的认证证书.
2007-12-21 13:18:55 CST 日志: 无法绑定 IPv4 套接字: Cannot assign requested address
2007-12-21 13:18:55 CST 提示: 是否有其它 postmaster 已经在端口 5432 上运行了? 如果没有, 请等待几秒钟后然后再重试.
2007-12-21 13:18:55 CST 警告: 无法为 "localhost" 创建监听套接字
2007-12-21 13:18:55 CST 致命错误: could not create any TCP/IP sockets
[fail]
invoke-rc.d: initscript postgresql-8.2, action "start" failed.
dpkg:处理 postgresql-8.2 (--configure)时出错:
子进程 post-installation script 返回了错误号 1
E: Sub-process /usr/bin/dpkg returned an error code (1)
cxczqfrx
帖子: 107
注册时间: 2007-07-11 11:10
送出感谢: 0
接收感谢: 0

#2

帖子 cxczqfrx » 2007-12-25 11:43

用新立得,在里面搜索 postgresql,选择与postgresql 8.25相关的 server 和 client 等项目试试
回复

回到 “数据库管理”