当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-04-09 0:37 

注册: 2011-01-23 16:30
帖子: 32
送出感谢: 0 次
接收感谢: 1
前几天把Ubuntu升级到了13.04 beta 2,顺便安装了fcitx 搜狗输入法,但是发现在sublime text 2中无法输入中文,之前在ubuntu 12.04.2中fcitx正常输入的,只是有一些小问题。
本着发现问题,解决问题的原则,咱就找解决方法呗,经过Google和论坛发帖,找到了解决方法。
http://my.oschina.net/Khiyuan/blog/98713
http://forum.suse.org.cn/viewtopic.php?f=16&t=333
http://www.sublimetext.com/forum/viewtopic.php?f=3&t=7006&start=10#p41343
在这里感谢oschina的Khiyuan和suse.org.cn的bruce.oy
这两位朋友耐心的为我解决问题。
接下来咱就把方法写出来。
编译共享内库

保存下述代码为
代码:
sublime-imfix.c
文件
代码:
/*
sublime-imfix.c
Use LD_PRELOAD to interpose some function to fix sublime input method support for linux.
By Cjacker Huang <jianzhong.huang at i-soft.com.cn>

gcc -shared -o libsublime-imfix.so sublime_imfix.c  `pkg-config --libs --cflags gtk+-2.0` -fPIC
LD_PRELOAD=./libsublime-imfix.so sublime_text
*/
#include <gtk/gtk.h>
#include <gdk/gdkx.h>
typedef GdkSegment GdkRegionBox;

struct _GdkRegion
{
  long size;
  long numRects;
  GdkRegionBox *rects;
  GdkRegionBox extents;
};

GtkIMContext *local_context;

void
gdk_region_get_clipbox (const GdkRegion *region,
            GdkRectangle    *rectangle)
{
  g_return_if_fail (region != NULL);
  g_return_if_fail (rectangle != NULL);

  rectangle->x = region->extents.x1;
  rectangle->y = region->extents.y1;
  rectangle->width = region->extents.x2 - region->extents.x1;
  rectangle->height = region->extents.y2 - region->extents.y1;
  GdkRectangle rect;
  rect.x = rectangle->x;
  rect.y = rectangle->y;
  rect.width = 0;
  rect.height = rectangle->height;
  //The caret width is 2;
  //Maybe sometimes we will make a mistake, but for most of the time, it should be the caret.
  if(rectangle->width == 2 && GTK_IS_IM_CONTEXT(local_context)) {
        gtk_im_context_set_cursor_location(local_context, rectangle);
  }
}

//this is needed, for example, if you input something in file dialog and return back the edit area
//context will lost, so here we set it again.

static GdkFilterReturn event_filter (GdkXEvent *xevent, GdkEvent *event, gpointer im_context)
{
    XEvent *xev = (XEvent *)xevent;
    if(xev->type == KeyRelease && GTK_IS_IM_CONTEXT(im_context)) {
       GdkWindow * win = g_object_get_data(G_OBJECT(im_context),"window");
       if(GDK_IS_WINDOW(win))
         gtk_im_context_set_client_window(im_context, win);
    }
    return GDK_FILTER_CONTINUE;
}

void gtk_im_context_set_client_window (GtkIMContext *context,
          GdkWindow    *window)
{
  GtkIMContextClass *klass;
  g_return_if_fail (GTK_IS_IM_CONTEXT (context));
  klass = GTK_IM_CONTEXT_GET_CLASS (context);
  if (klass->set_client_window)
    klass->set_client_window (context, window);

  if(!GDK_IS_WINDOW (window))
    return;
  g_object_set_data(G_OBJECT(context),"window",window);
  int width = gdk_window_get_width(window);
  int height = gdk_window_get_height(window);
  if(width != 0 && height !=0) {
    gtk_im_context_focus_in(context);
    local_context = context;
  }
  gdk_window_add_filter (window, event_filter, context);
}


安装C/C++的编译环境和gtk libgtk2.0-dev
代码:
sudo apt-get install build-essential
sudo apt-get install libgtk2.0-dev


编译共享内库
代码:
gcc -shared -o libsublime-imfix.so sublime_imfix.c  `pkg-config --libs --cflags gtk+-2.0` -fPIC


启动 Sublime Text 2

好了,现在执行下述命令启动 Sublime Text 2,就可以使用fcitx输入中文了!
代码:
LD_PRELOAD=./libsublime-imfix.so sublime_text



但是这样的话,我们每次都要在终端里面使用命令启动sublime text 2,这样很不方便,接下来我们还要通过修改sublime-text-2.desktop达到点击图标启动。

打开终端进入applications修改sublime-text-2.desktop

代码:
cd /usr/share/applications
sudo vim sublime-text-2.desktop


打开sublime-text-2.desktop后,将
代码:
Exec=/usr/bin/sublime-text-2 %F


修改为

代码:
Exec=bash -c 'LD_PRELOAD=/usr/lib/libsublime-imfix.so /usr/bin/sublime-text-2' %F


还有将
代码:
Exec=/usr/bin/sublime-text-2 --new-window


修改为
代码:
Exec=bash -c 'LD_PRELOAD=/usr/lib/libsublime-imfix.so /usr/bin/sublime-text-2' --new-window


好了,接下来你在dash中点击打开sublime text2吧,开始你的代码之旅吧。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-04-09 15:33 
头像

注册: 2011-06-26 18:28
帖子: 240
送出感谢: 3
接收感谢: 4
哎,楼主你的代码中的符号被编辑器重新解析了,我费了好久才一一查完,下面就是我的截图:
图片
:em09
另外,下面是我编译好的文件:
http://pan.baidu.com/share/link?shareid=491022&uk=3674659592


_________________
http://www.linux-unix.asia
720P电影,无损音乐,Linux教程资料:http://hdcity.leniter.org/promotionlink.php?key=64472c449c1ade6ed71c4de838745c67


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-04-09 17:05 

注册: 2011-01-23 16:30
帖子: 32
送出感谢: 0 次
接收感谢: 1
lxf1992521 写道:
哎,楼主你的代码中的符号被编辑器重新解析了,我费了好久才一一查完,下面就是我的截图:
图片
:em09
另外,下面是我编译好的文件:
http://pan.baidu.com/share/link?shareid=491022&uk=3674659592

:em06这个我就不知道怎么办了,我在OSchina发了一篇博文,那边应该是没问题的,我把地址贴出来
http://my.oschina.net/wugaoxing/blog/121281


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-04-15 9:49 

注册: 2007-06-13 9:36
帖子: 126
送出感谢: 0 次
接收感谢: 5
我怎么直接双击打不开文件,右键菜单也打不开文件


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-04-15 10:02 

注册: 2007-06-13 9:36
帖子: 126
送出感谢: 0 次
接收感谢: 5
squall724 写道:
我怎么直接双击打不开文件,右键菜单也打不开文件

解决了,快捷方式命令行有误


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-04-17 14:36 

注册: 2007-04-02 23:51
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
完美解决。讚。 :em04


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-04-26 18:25 
头像

注册: 2010-06-03 9:45
帖子: 53
送出感谢: 1
接收感谢: 0 次
你好,我也遇到了这个问题,请问你是怎么解决的啊?
squall724 写道:
squall724 写道:
我怎么直接双击打不开文件,右键菜单也打不开文件

解决了,快捷方式命令行有误


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-05-13 3:19 

注册: 2012-11-27 11:25
帖子: 4
系统: ubuntu
送出感谢: 0 次
接收感谢: 0 次
同问
郁闷了,输入法到是没问题,问题是用用subl打开文件或者目录的时候,是不行的,sublime可以启动起来,但是没有打开任何目录或者文件
楼上那么多都成功了的,说下啊 :em05


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-05-18 13:22 

注册: 2012-01-26 21:57
帖子: 2
送出感谢: 0 次
接收感谢: 2
wofeiwo 写道:
同问
郁闷了,输入法到是没问题,问题是用用subl打开文件或者目录的时候,是不行的,sublime可以启动起来,但是没有打开任何目录或者文件
楼上那么多都成功了的,说下啊 :em05


打开sublime-text-2.desktop后,将
Exec=/usr/bin/sublime-text-2 %F
修改为
Exec=bash -c 'LD_PRELOAD=/usr/lib/libsublime-imfix.so /usr/bin/sublime-text-2' %F
注意,把那个%F写到引号里面,改成
Exec=bash -c 'LD_PRELOAD=/usr/lib/libsublime-imfix.so /usr/bin/sublime-text-2 %F'
搞定,这样就可以右键打开文件了



_________________
评价: 7.41% junsgopkuphy
 
页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-08-24 20:24 

注册: 2008-08-29 17:33
帖子: 67
地址: 木有地
送出感谢: 3
接收感谢: 0 次
muguang20 写道:
wofeiwo 写道:
同问
郁闷了,输入法到是没问题,问题是用用subl打开文件或者目录的时候,是不行的,sublime可以启动起来,但是没有打开任何目录或者文件
楼上那么多都成功了的,说下啊 :em05


打开sublime-text-2.desktop后,将
Exec=/usr/bin/sublime-text-2 %F
修改为
Exec=bash -c 'LD_PRELOAD=/usr/lib/libsublime-imfix.so /usr/bin/sublime-text-2' %F
注意,把那个%F写到引号里面,改成
Exec=bash -c 'LD_PRELOAD=/usr/lib/libsublime-imfix.so /usr/bin/sublime-text-2 %F'
搞定,这样就可以右键打开文件了


这个方法好.


页首
 用户资料  
 
11 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-09-10 3:00 
头像

注册: 2007-12-01 14:59
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
楼主你好,我运行快捷方式可以打开文件,切换输入法,但是没法用ctrl+B编译python文件了
代码:
[Desktop Entry]
Type=Application
Exec=bash -c 'LD_PRELOAD=/home/SY/SublimeText2/libsublime-imfix.so /home/SY/SublimeText2/sublime_text' %F
Exec=bash -c 'LD_PRELOAD=/home/SY/SublimeText2/libsublime-imfix.so /home/SY/SublimeText2/sublime_text' --new-window
Hidden=false
X-MATE-Autostart-enabled=true
Name[en_US]=sublimetext
Name=sublimtext
Comment[en_US]=
Comment=
Icon=/home/SY/SublimeText2/Icon/256x256/sublime_text.png



而直接去打开
代码:
./sublime_text


代码:
LD_PRELOAD=./libsublime-imfix.so ./sublime_text

则没有问题,请问有办法解决吗?


页首
 用户资料  
 
12 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-11-06 11:38 

注册: 2008-11-23 7:39
帖子: 27
送出感谢: 1
接收感谢: 0 次
代码:
[Desktop Entry]
Type=Application
Exec=bash -c 'LD_PRELOAD=/home/zxd-qida/apps/Sublime\ Text\ 2/libsublime-imfix.so /home/zxd-qida/apps/Sublime\ Text\ 2/sublime_text %F'
Exec=bash -c 'LD_PRELOAD=/home/zxd-qida/apps/Sublime\ Text\ 2/libsublime-imfix.so /home/zxd-qida/apps/Sublime\ Text\ 2/sublime_text' --new-window
Hidden=false
X-MATE-Autostart-enabled=true
Name[en_US]=sublimetext
Name=sublimetext
Comment[en_US]=
Comment=
Icon=/home/zxd-qida/apps/Sublime Text 2/Icon/256x256/sublime_text.png

这个快捷方式启动的话,输入法无效,但是命令行启动就没有问题,不知道是不是空格问题。。。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-11-08 9:37 
头像

注册: 2012-05-14 18:39
帖子: 411
送出感谢: 5
接收感谢: 9
mark好贴~


_________________
崩溃是不可抗拒滴
攒钱买(第?台)macbook,然后装ubuntu
那些说unity找不到应用程序的人拜托按一下win+A好吗?
Novelty, Novelty, Give Me Novelty
发表Linux、Win、OS X的对比帖时,建议您确认一下您真的用过Linux&&Win&&OS X,而不是用过Linux||Win||OS X。
吾乃古剑奇谭NC粉!


页首
 用户资料  
 
14 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2013-11-08 9:37 
头像

注册: 2012-05-14 18:39
帖子: 411
送出感谢: 5
接收感谢: 9
mark好贴~


_________________
崩溃是不可抗拒滴
攒钱买(第?台)macbook,然后装ubuntu
那些说unity找不到应用程序的人拜托按一下win+A好吗?
Novelty, Novelty, Give Me Novelty
发表Linux、Win、OS X的对比帖时,建议您确认一下您真的用过Linux&&Win&&OS X,而不是用过Linux||Win||OS X。
吾乃古剑奇谭NC粉!


页首
 用户资料  
 
15 楼 
 文章标题 : Re: Ubuntu系统下Sublime Text 2中fcitx中文输入法的解决方法
帖子发表于 : 2014-04-19 12:12 

注册: 2014-04-19 12:06
帖子: 2
系统: ubuntu 14.04
送出感谢: 0 次
接收感谢: 0 次
Exec=env LD_PRELOAD=/usr/lib/libsublime-imfix.so /usr/bin/sublime-text
.desktop文件里用这个没问题。我用的是sublime-text 3

楼主的这个方法不知为何会导致ctrl+alt+p快捷键无效,更换其他快捷键后修复,不知有没有人也遇到这个问题,有更好的解决办法。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译