libc6更新出错-_-!求救....

为当前最终发行版之前的所有版本提供支持
回复
ldbmh
帖子: 2
注册时间: 2013-04-26 22:05
系统: ubuntu12.10
送出感谢: 0
接收感谢: 0

libc6更新出错-_-!求救....

#1

帖子 ldbmh » 2013-04-26 22:07

libc-bin 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列软件包有未满足的依赖关系:
libc6 : 依赖: libc-bin (= 2.15-0ubuntu20) 但是 2.15-0ubuntu20.1 正要被安装
libc6-dev : 依赖: libc6 (= 2.15-0ubuntu20.1) 但是 2.15-0ubuntu20 正要被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。


请高手指点!
头像
daf3707
论坛版主
帖子: 12670
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

Re: libc6更新出错-_-!求救....

#2

帖子 daf3707 » 2013-04-26 22:37

代码: 全选

运行“sudo apt-get -f install”
 不是让你运行吗
ldbmh
帖子: 2
注册时间: 2013-04-26 22:05
系统: ubuntu12.10
送出感谢: 0
接收感谢: 0

Re: libc6更新出错-_-!求救....

#3

帖子 ldbmh » 2013-04-26 22:42

正预备替换 libc6:i386 2.15-0ubuntu20 (使用 .../libc6_2.15-0ubuntu20.1_i386.deb) ...

apt-get -f install后报了一大堆丢失

然后就是下面:

A copy of the C library was found in an unexpected directory:
'/lib/i386-linux-gnu/libc-2.15.so'
It is not safe to upgrade the C library in this situation;
please remove that copy of the C library or get it out of
'/lib/i386-linux-gnu' and try again.

dpkg: error processing /var/cache/apt/archives/libc6_2.15-0ubuntu20.1_i386.deb (--unpack):
子进程 新的 pre-installation 脚本 返回了错误号 1
由于已经达到 MaxReports 限制,没有写入 apport 报告。
在处理时有错误发生:
/var/cache/apt/archives/libc6_2.15-0ubuntu20.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
sevenzero
帖子: 10
注册时间: 2009-04-16 23:29
系统: XUbuntu 12.04
送出感谢: 1 次
接收感谢: 0

Re: libc6更新出错-_-!求救....

#4

帖子 sevenzero » 2014-10-28 11:10

这个下面的链接中的处理方式。

gedit /var/lib/dpkg/status
In the resulting gedit, remove the whole section starts with :
Package : libc6
then run an update.


http://askubuntu.com/questions/488671/l ... es#tab-top
顺颂商祺
回复

回到 “老旧版本支持”