纠结这个依赖关系怎么解决掉

为当前最终发行版之前的所有版本提供支持
回复
头像
linbin95
帖子: 191
注册时间: 2011-04-17 9:21
送出感谢: 0
接收感谢: 0

纠结这个依赖关系怎么解决掉

#1

帖子 linbin95 » 2013-05-05 20:12

代码: 全选

linbin@linbin:~$ sudo apt-get -f install
[sudo] password for linbin: 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包是自动安装的并且现在不需要了:
  esound-common libaudiofile1 libesd0 libqt4-core libqt4-gui libqt4-webkit
  libsvga1 libvdpau1
Use 'apt-get autoremove' to remove them.
下列软件包将被【卸载】:
  deepin-media-player deepin-music-player
升级了 0 个软件包,新安装了 0 个软件包,要卸载 2 个软件包,有 0 个软件包未被升级。
有 2 个软件包没有被完全安装或卸载。
解压缩后将会空出 51.2 MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前共安装有 179803 个文件和目录。)
正在卸载 deepin-media-player ...
rm: 无法删除"/usr/share/deepin-media-player": 没有那个文件或目录
dpkg: error processing deepin-media-player (--remove):
 子进程 已安装 post-removal 脚本 返回了错误号 1
正在卸载 deepin-music-player ...
rm: 无法删除"/usr/share/deepin-music-player": 没有那个文件或目录
dpkg: error processing deepin-music-player (--remove):
 子进程 已安装 post-removal 脚本 返回了错误号 1
在处理时有错误发生:
 deepin-media-player
 deepin-music-player
E: Sub-process /usr/bin/dpkg returned an error code (1)
linbin@linbin:~$ 

  • 我尽情的跟你们扯淡 其实我发现我真的很无聊

代码: 全选

用操蛋的态度 面对扯淡的人生
头像
linbin95
帖子: 191
注册时间: 2011-04-17 9:21
送出感谢: 0
接收感谢: 0

Re: 纠结这个依赖关系怎么解决掉

#2

帖子 linbin95 » 2013-05-05 20:29

有人看没人说句话呀
  • 我尽情的跟你们扯淡 其实我发现我真的很无聊

代码: 全选

用操蛋的态度 面对扯淡的人生
头像
linbin95
帖子: 191
注册时间: 2011-04-17 9:21
送出感谢: 0
接收感谢: 0

Re: 纠结这个依赖关系怎么解决掉

#3

帖子 linbin95 » 2013-05-05 20:33

代码: 全选

linbin@linbin:~$  sudo apt-get autoremove

[sudo] password for linbin: 
Sorry, try again.
[sudo] password for linbin: 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
下列软件包将被【卸载】:
  deepin-media-player deepin-music-player
升级了 0 个软件包,新安装了 0 个软件包,要卸载 2 个软件包,有 0 个软件包未被升级。
有 2 个软件包没有被完全安装或卸载。
解压缩后将会空出 51.2 MB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前共安装有 179741 个文件和目录。)
正在卸载 deepin-media-player ...
rm: 无法删除"/usr/share/deepin-media-player": 没有那个文件或目录
dpkg: error processing deepin-media-player (--remove):
 子进程 已安装 post-removal 脚本 返回了错误号 1
正在卸载 deepin-music-player ...
rm: 无法删除"/usr/share/deepin-music-player": 没有那个文件或目录
dpkg: error processing deepin-music-player (--remove):
 子进程 已安装 post-removal 脚本 返回了错误号 1
在处理时有错误发生:
 deepin-media-player
 deepin-music-player
E: Sub-process /usr/bin/dpkg returned an error code (1)


  • 我尽情的跟你们扯淡 其实我发现我真的很无聊

代码: 全选

用操蛋的态度 面对扯淡的人生
头像
qy117121
论坛版主
帖子: 49891
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 334 次
联系:

Re: 纠结这个依赖关系怎么解决掉

#4

帖子 qy117121 » 2013-05-05 20:33

渠月 · QY    https://vz.rs/u
本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
头像
linbin95
帖子: 191
注册时间: 2011-04-17 9:21
送出感谢: 0
接收感谢: 0

Re: 纠结这个依赖关系怎么解决掉

#5

帖子 linbin95 » 2013-05-05 20:50

qy117121 写了:viewtopic.php?t=416672&p=2957203
试试
好啦解决啦 谢谢 :em06
  • 我尽情的跟你们扯淡 其实我发现我真的很无聊

代码: 全选

用操蛋的态度 面对扯淡的人生
回复

回到 “老旧版本支持”