当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我在ubuntu上安了wordpress,但是127.0.0.1却不能访问
帖子发表于 : 2013-05-13 21:29 

注册: 2013-05-13 21:22
帖子: 3
系统: win7
送出感谢: 0 次
接收感谢: 0 次
http://localhost/wordpress/可以
但是http://127.0.0.1/wordpress/却不行,出下面的错
Neither /etc/wordpress/config-127.0.0.1.php nor /etc/wordpress/config-0.0.1.php could be found.
Ensure one of them exists, is readable by the webserver and contains the right password/username.

ubuntu装在虚拟机里,本机通过IP访问也显示错误
host文件没有问题

想问一下这个要怎么修?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 我在ubuntu上安了wordpress,但是127.0.0.1却不能访问
帖子发表于 : 2013-05-14 14:11 
头像

注册: 2007-02-14 13:54
帖子: 308
送出感谢: 0 次
接收感谢: 0 次
引用:
Neither /etc/wordpress/config-127.0.0.1.php nor /etc/wordpress/config-0.0.1.php could be found.

就是说配置文件没找到咯,我估计 /etc/wordpress/localhost.php 是有的,可以做一个 symlink 嘛
代码:
ln -s /etc/wordpress/localhost.php /etc/wordpress/config-127.0.0.1.php


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 我在ubuntu上安了wordpress,但是127.0.0.1却不能访问
帖子发表于 : 2013-05-14 20:08 

注册: 2013-05-13 21:22
帖子: 3
系统: win7
送出感谢: 0 次
接收感谢: 0 次
sense 写道:
引用:
Neither /etc/wordpress/config-127.0.0.1.php nor /etc/wordpress/config-0.0.1.php could be found.

就是说配置文件没找到咯,我估计 /etc/wordpress/localhost.php 是有的,可以做一个 symlink 嘛
代码:
ln -s /etc/wordpress/localhost.php /etc/wordpress/config-127.0.0.1.php


这样是能解决,
但是我觉得配IP或域名之类的应该是apache做的事情
为什么wordpress还要插一脚?

而且还有个问题,
以下是apache2 的默认设置,本机应该是可以访问VM里的wordpress或phpmyadmin的
但是却不行。。。实在搞不懂,
而且本机通过http://192.168.73.131/wordpress/访问虚拟机中的wordpress,也要求有配置/etc/wordpress/config-192.168.73.131.php
这个太奇怪了。。
代码:
<VirtualHost *:80>
   ServerAdmin webmaster@localhost

   DocumentRoot /var/www
   <Directory />
      Options FollowSymLinks
      AllowOverride None
   </Directory>
   <Directory /var/www/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   <Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>

   ErrorLog ${APACHE_LOG_DIR}/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn

   CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 我在ubuntu上安了wordpress,但是127.0.0.1却不能访问
帖子发表于 : 2013-05-14 20:51 

注册: 2013-05-13 21:22
帖子: 3
系统: win7
送出感谢: 0 次
接收感谢: 0 次
1. 更改数据库中wp_options表下的siteurl内容,将其更改为宿主机的ip。如http://192.168.2.16/wordpress
2. 更改数据库中wp_options表下的home内容(这个大概在第二页),同样改为http://192.168.2.16/wordpress

http://superuser.com/questions/276902/t ... -wordpress

3. sudo ln -s /etc/wordpress/config-localhost.php /etc/wordpress/config-default.php
(this is because at last wp-config.php looks for config-default.php)

终于搞定wordpress的问题了,三个步骤都得用才行。
为什么这么普遍的问题网上一点都搜不到。。。

PS:还剩下apache的那个问题不知道肿么办。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译