安装软件提示E: 软件包 virtualbox-4.2 需要重新安装,但是我无法找到相应的安装文件。

为当前最终发行版之前的所有版本提供支持
回复
yunixyu
帖子: 1
注册时间: 2013-04-29 17:39
系统: ubutu13.04
送出感谢: 0
接收感谢: 0

安装软件提示E: 软件包 virtualbox-4.2 需要重新安装,但是我无法找到相应的安装文件。

#1

帖子 yunixyu » 2013-04-29 17:44

我想安装VIM,但装不了
日记如下我不知道怎么办了:
yhq@yhq-Z68P-DS3:~$ sudo apt-get install vim
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 软件包 virtualbox-4.2 需要重新安装,但是我无法找到相应的安装文件。

安装其它软件同样提示:
yhq@yhq-Z68P-DS3:~$ sudo apt-get install vim
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
E: 软件包 virtualbox-4.2 需要重新安装,但是我无法找到相应的安装文件。
头像
mraandtux
论坛版主
帖子: 5082
注册时间: 2009-12-12 19:29
系统: 本地大型发行版除外
来自: 随便一个地方
送出感谢: 0
接收感谢: 158 次
联系:

Re: 安装软件提示E: 软件包 virtualbox-4.2 需要重新安装,但是我无法找到相应的安装文件。

#2

帖子 mraandtux » 2013-04-29 20:10

试试换源或者删掉Virtualbox。
shockie
帖子: 19
注册时间: 2009-11-01 23:49
送出感谢: 0
接收感谢: 0

Re: 安装软件提示E: 软件包 virtualbox-4.2 需要重新安装,但是我无法找到相应的安装文件。

#3

帖子 shockie » 2013-11-24 12:22

遇到过类似问题,我是用dpkg命令解决的。也就是重新安装deb包。

$sudo dpkg -i PACKAGE

这里的PACKAGE就是下载到电脑里的deb包,包括完整路径。可以拖曳文件包到terminal窗口里(记得拖动后,把文件包路径前后的单引号去掉)
回复

回到 “老旧版本支持”