[讨论]刚刚从tw那个edu服务器升级,linux升级到2.6.24-10,结果开机没画面

为当前最终发行版之前的所有版本提供支持
头像
wavydoom
帖子: 1081
注册时间: 2008-02-15 0:08
送出感谢: 0
接收感谢: 0

[讨论]刚刚从tw那个edu服务器升级,linux升级到2.6.24-10,结果开机没画面

#1

帖子 wavydoom » 2008-02-27 14:53

刚刚从tw那个edu服务器升级,generic linux modules升级到2.6.24.10-8,结果开机没画面,显示器直接黑掉,然后led灯一闪一闪,但是有声音,可以听见ub进系统的声音。

后来没办法,开机grab的时候选择2.6.24.8.8才能进入系统。

当然,升级前提示是 发行版升级,并且是“部分升级”。
不知道怎么回事。

大家的generic linux 升级到2.6.24.10.8了吗?有碰到这个问题吗?

请问能有朋友帮我搞定这个问题不?我还是觉得新内核应该快一些了~

换回2.6.24.8.8后,进系统发现时间栏自动包含了天气,呵呵,不错,然后运行更新管理器。。。又有8个升级。
升级完成后发现2.6.24.10.8这个升级选项处于无法选择状态。。。
上次由 wavydoom 在 2008-02-27 15:17,总共编辑 1 次。
头像
smtking
帖子: 228
注册时间: 2008-02-25 13:30
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 smtking » 2008-02-27 15:07

怎么升级内核啊。??7。1的可以升级到最新的内核吗>>
头像
wavydoom
帖子: 1081
注册时间: 2008-02-15 0:08
送出感谢: 0
接收感谢: 0

#3

帖子 wavydoom » 2008-02-27 15:11

7.10的不清楚。要等其他朋友来解答你的问题了。
我的8.04直接apt-get update 然后apt-get dist-upgrade就可以了。或者去更新管理器直接更新也可以。
头像
greatgarlic
帖子: 1794
注册时间: 2007-07-11 12:31
来自: neverland
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 greatgarlic » 2008-02-27 17:38

我上午用的aptitude safe-upgrade,kernel的升级依赖不全,直接被屏蔽了,吼吼,刚学的
To be is to do--Nietzsche
To do is to be--Kant
Do be do be do---Frank Sinatra
http://ggarlic.org
头像
wavydoom
帖子: 1081
注册时间: 2008-02-15 0:08
送出感谢: 0
接收感谢: 0

#5

帖子 wavydoom » 2008-02-27 19:22

什么什么?楼上的我没看懂
头像
greatgarlic
帖子: 1794
注册时间: 2007-07-11 12:31
来自: neverland
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 greatgarlic » 2008-02-27 19:34

wavydoom 写了:什么什么?楼上的我没看懂
ggarlic@redcamp:~$ sudo aptitude safe-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 50%




正在分析软件包的依赖关系树
Reading state information... 0%
Reading state information... 完成
正在读取扩展状态文件... 0%
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
下列软件包已经被阻止升级:
bluez-gnome linux-generic linux-headers-generic linux-image-generic linux-restricted-modules-generic
下列软件包将被升级:
gnome-menus language-pack-en language-pack-gnome-en language-pack-gnome-zh language-pack-zh libgnome-menu2 python-gmenu
sound-juicer
8 个软件包被升级,新安装0 个, 0 个将被删除, 同时 5 个将不升级。
To be is to do--Nietzsche
To do is to be--Kant
Do be do be do---Frank Sinatra
http://ggarlic.org
头像
greatgarlic
帖子: 1794
注册时间: 2007-07-11 12:31
来自: neverland
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 greatgarlic » 2008-02-27 20:39

忽略我上面说的话,safe-upgrade具体能不能用来升级内核我也不清楚,我运行aptitude full-upgrade显示的是
ggarlic@redcamp:~$ sudo aptitude full-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
读取状态信息... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
下列软件包是“破损”的:
linux-restricted-modules-generic
下列软件包未被使用,将被“删除”:
linux-headers-2.6.24-8 linux-headers-2.6.24-8-generic
下列新软件包将被自动安装:
linux-headers-2.6.24-10 linux-headers-2.6.24-10-generic obex-data-server
下列“新”软件包将被安装。
linux-headers-2.6.24-10 linux-headers-2.6.24-10-generic linux-image-2.6.24-10-generic
linux-ubuntu-modules-2.6.24-10-generic obex-data-server
下列软件包将被升级:
bluez-gnome linux-generic linux-headers-generic linux-image-generic
5 个软件包被升级,新安装5 个, 2 个将被删除, 同时 0 个将不升级。
需要获取 33.3MB 的存档。 解包后将要使用 84.8MB。
下列软件包存在未满足的依赖关系:
linux-restricted-modules-generic: 依赖: linux-restricted-modules-2.6.24-10-generic 这是一个虚拟软件包。
Resolving dependencies...
下列动作将解决这些依赖关系:

删除 下列软件包:
linux-generic

保持 下列软件包于其当前版本:
linux-restricted-modules-generic [2.6.24.8.8 (hardy, now)]

分数是 189

是否接受该解决方案?[Y/n/q/?] ?
linux-restricted-modules-generic这个包源里没有更新到2.6.24.10,不能进系统就是因为这个啊
To be is to do--Nietzsche
To do is to be--Kant
Do be do be do---Frank Sinatra
http://ggarlic.org
头像
wavydoom
帖子: 1081
注册时间: 2008-02-15 0:08
送出感谢: 0
接收感谢: 0

#8

帖子 wavydoom » 2008-02-27 21:05

我现在要疯了 !!!!进 2.6.24.10不能联网!!!!我操
进2.6.24.8不能保存nvidia-settings,图标猛大一个,没办法用,分辨率只有640x380。。。终端一篇白~~我日!
救命阿!!!!
头像
wavydoom
帖子: 1081
注册时间: 2008-02-15 0:08
送出感谢: 0
接收感谢: 0

#9

帖子 wavydoom » 2008-02-27 21:06

root@wavydoom-desktop:/home/wavydoom# sudo nvidia-settings
段错误 (core dumped)
root@wavydoom-desktop:/home/wavydoom# sudo aptitude full-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
正在编辑扩展状态信息... 完成
创建标签数据库... 完成
将不会安装,升级或者删除任何软件包。
0 个软件包被升级,新安装0 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 0B 的存档。 解包后将要使用 0B。
正在编辑扩展状态信息... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
头像
阿谈
帖子: 77
注册时间: 2008-02-02 12:30
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 阿谈 » 2008-02-27 21:08

嚯嚯!怎就“猛”字一个 :lol:
向白鼠致敬!!! :em38
头像
wavydoom
帖子: 1081
注册时间: 2008-02-15 0:08
送出感谢: 0
接收感谢: 0

#11

帖子 wavydoom » 2008-02-27 21:09

楼上的我砍你~快救我阿,哭~
头像
1973liul_xxxx
帖子: 250
注册时间: 2006-07-29 20:50
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 1973liul_xxxx » 2008-02-28 8:21

wavydoom 写了:楼上的我砍你~快救我阿,哭~
:lol: 目前没救——只能等待!等待!再等待!!!
向那些默默支持Ubuntu和Linux的兄弟致敬!
我的百度空间:
http://hi.baidu.com/%B0%A2%CC%B8
头像
fortruth
帖子: 1795
注册时间: 2005-11-06 1:51
来自: 七彩云世界
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 fortruth » 2008-02-28 8:35

smtking 写了:怎么升级内核啊。??7。1的可以升级到最新的内核吗>>
使用7。10 的源不行,源里没有,要用8。04的源。
佛出寺,求索真世界 For_Truth:Free_Open_Share
OPEN GPG KEY:03D18D95
头像
fortruth
帖子: 1795
注册时间: 2005-11-06 1:51
来自: 七彩云世界
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 fortruth » 2008-02-28 8:40

wavydoom 写了:root@wavydoom-desktop:/home/wavydoom# sudo nvidia-settings
段错误 (core dumped)
root@wavydoom-desktop:/home/wavydoom# sudo aptitude full-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
正在编辑扩展状态信息... 完成
创建标签数据库... 完成
将不会安装,升级或者删除任何软件包。
0 个软件包被升级,新安装0 个, 0 个将被删除, 同时 0 个将不升级。
需要获取 0B 的存档。 解包后将要使用 0B。
正在编辑扩展状态信息... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
创建标签数据库... 完成
你是不是先前用的 nvidia 驱动是 nviida-glx-new。这里私有驱动。
更新内核可能要重新安装。!
你先在/etc/X11/xorg.conf 中把 nvidia的驱动设为nv(自由驱动)
在终端登录。sudo nano /etc/X11/xorg.conf .把nvidia 改为 nv。保存。
startx 启动 X 界面。
重新安装nvidia。或者 不改。就这样也是可以的。~!
佛出寺,求索真世界 For_Truth:Free_Open_Share
OPEN GPG KEY:03D18D95
头像
wavydoom
帖子: 1081
注册时间: 2008-02-15 0:08
送出感谢: 0
接收感谢: 0

#15

帖子 wavydoom » 2008-02-28 9:43

我先前用的是nvidia-glx,没有new
用了新内核以后在系统里面根本就找不到显卡,连受限制驱动都没有。
而且不能上网,重新配置过也不能上网。
没办法,退回了旧内核。
回复

回到 “老旧版本支持”