8.04源安装显卡驱动不能使用

为当前最终发行版之前的所有版本提供支持
回复
flyinghero
帖子: 38
注册时间: 2007-07-12 8:35
送出感谢: 0
接收感谢: 0
联系:

8.04源安装显卡驱动不能使用

#1

帖子 flyinghero » 2008-03-07 16:37

我的显卡是GForce7300GT,用新立得安装驱动之后,显卡不能正常工作。而且现在也不能卸载,出现这样的错误
dpkg:处理 nvidia-glx-new (--remove)时出错:
子进程 post-removal script 返回了错误号 2
在处理时有错误发生:
nvidia-glx-new
开机的时候提示系统进入低级图形模式, 现在只能用800*600的分辨率了。但是看从受限驱动看,显卡正在被使用,这是什么问题阿,是不是驱动本身有问题?
还有我自己编译的EVA不能登录,一登录就崩溃,怎么把它卸载掉阿?
我想早恋,但是已经晚了~~~
flyinghero
帖子: 38
注册时间: 2007-07-12 8:35
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 flyinghero » 2008-03-07 16:46

我现在安装别的软件的时候总是先试图删除nvidia-xgl-new,新立得根本就没法正常使用
我想早恋,但是已经晚了~~~
zwhuang
帖子: 157
注册时间: 2007-01-21 14:04
送出感谢: 1 次
接收感谢: 0

Re: 8.04源安装显卡驱动不能使用

#3

帖子 zwhuang » 2008-03-07 16:58

推荐直接使用官方的 .run 驱动来安装,把源里安装的 nvidia 的驱动相关的包都删掉。
可以先把显卡驱动换成 vesa 的,是个显卡都能点亮的,就是效果差了些
进到 X 后从新立得里删掉 nvidia 相关的包
到 nvidia 官方网站下载驱动,选择适合你显卡型号的版本的驱动
然后退到控制台,执行安装驱动,会自动更改 xorg.conf ,而且会保留之前设置的备份
只是这样安装需要内核头文件包,不过大家一般都装了这个包的
安装很快的,本机编译模块也会

我的 GeForce 2 MX400 的显卡用源里的驱动也是折腾好久不行,勉强点亮也只有 800x600 的分辨率,索性换 vesa 驱动启动,下载官方网站的驱动然后搞定的,一次过
flyinghero 写了:我的显卡是GForce7300GT,用新立得安装驱动之后,显卡不能正常工作。而且现在也不能卸载,出现这样的错误
dpkg:处理 nvidia-glx-new (--remove)时出错:
子进程 post-removal script 返回了错误号 2
在处理时有错误发生:
nvidia-glx-new
开机的时候提示系统进入低级图形模式, 现在只能用800*600的分辨率了。但是看从受限驱动看,显卡正在被使用,这是什么问题阿,是不是驱动本身有问题?
还有我自己编译的EVA不能登录,一登录就崩溃,怎么把它卸载掉阿?
flyinghero
帖子: 38
注册时间: 2007-07-12 8:35
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 flyinghero » 2008-03-07 17:10

谢谢ls,马上实验~ 8)
我想早恋,但是已经晚了~~~
flyinghero
帖子: 38
注册时间: 2007-07-12 8:35
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 flyinghero » 2008-03-07 17:12

E: nvidia-glx-new: 子进程 post-removal script 返回了错误号 2
这个错误怎么解决?
我想早恋,但是已经晚了~~~
头像
糊里糊涂
帖子: 43
注册时间: 2006-11-03 14:14
来自: Women's Heart
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 糊里糊涂 » 2008-03-08 12:47

别安装cn99的,那个老了。换个有新的驱动的源就可以了。
dyaquarius
帖子: 37
注册时间: 2008-10-03 2:06
送出感谢: 0
接收感谢: 0

Re: 8.04源安装显卡驱动不能使用

#7

帖子 dyaquarius » 2008-10-04 14:49

这个问题没人管吗?我也出现了同样的问题。就是不能卸载nvidia-glx-new
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: 8.04源安装显卡驱动不能使用

#8

帖子 想入非非 » 2008-10-04 15:29

我的驱动型号和你一模一样。。。我怎么能用受限驱动? :em05
Ubuntu User
回复

回到 “老旧版本支持”