当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我在升级到8.04时遇到试图覆盖文件错误. 依赖关系问题 - 仍未被配置等问题的情况及解决
帖子发表于 : 2008-03-08 12:20 

注册: 2007-06-01 22:11
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
升级时遇到
代码:
正在解压缩 openoffice.org-hyphenation-en-us (从 .../openoffice.org-hyphenation-en-us_2.3-5_all.deb) ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-hyphenation-en-us_2.3-5_all.deb (--unpack)时出错:
 正试图覆盖“/usr/share/myspell/dicts/hyph_en_US.dic”,它属于软件包 openoffice.org-hyphenation
在处理时有错误发生:
 /var/cache/apt/archives/openoffice.org-hyphenation-en-us_2.3-5_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

然后升级就停止了
执行sudo apt-get -f install也是一样的结果。
于是就:
代码:
who@what:/var/cache/apt$ sudo dpkg --force-overwrite -i  /var/cache/apt/archives/openoffice.org-hyphenation-en-us_2.3-5_all.deb
(正在读取数据库 ... 系统当前总共安装有 205518 个文件和目录。)
正在解压缩 openoffice.org-hyphenation-en-us (从 .../openoffice.org-hyphenation-en-us_2.3-5_all.deb) ...
dpkg - 警告,由于您打开了 --force 选项,我忽略了一些问题的存在:
 正试图覆盖“/usr/share/myspell/dicts/hyph_en_US.dic”,它属于软件包 openoffice.org-hyphenation
正在设置 openoffice.org-hyphenation-en-us (2.3-5) ...
Updating OpenOffice.org's dictionary list... done.

ok了。继续upgrade,顺利继续

升级到8.04的过程是一波三折的,这只是我遇到的问题之一。记得--fix-missing参数,它是很有用的。


最后由 Enigma 编辑于 2008-03-08 14:12,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-08 12:30 

注册: 2007-06-01 22:11
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
装了完整的texlive,所以昨天下载量很大,有14xxM。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-08 12:43 

注册: 2007-06-01 22:11
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
代码:
正在解压缩将用于更替的包文件 sgmltools-lite ...
在处理时有错误发生:
 /var/cache/apt/archives/aria2_0.12.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

代码:
who@what:/var/cache/apt$ sudo dpkg --force-overwrite -i   /var/cache/apt/archives/aria2_0.12.0-1_amd64.deb
(正在读取数据库 ... 系统当前总共安装有 225976 个文件和目录。)
正预备替换 aria2 0.11.0-1 (使用 .../aria2_0.12.0-1_amd64.deb) ...
正在解压缩将用于更替的包文件 aria2 ...
dpkg - 警告,由于您打开了 --force 选项,我忽略了一些问题的存在:
 正试图覆盖“/usr/share/locale/locale.alias”,它属于软件包 locales
dpkg:依赖关系问题使得 aria2 的配置工作不能继续:
 aria2 依赖于 libares0;然而:
  软件包 libares0 还没有被配置。
dpkg:处理 aria2 (--install)时出错:
 依赖关系问题 - 仍未被配置
在处理时有错误发生:
 aria2

代码:
who@what:/var/cache/apt$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成     
已经不需要下列自动安装的软件包:
......省略
使用 'apt-get autoremove' 来删除它们。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 55 个软件未被升级。
......中间省略。

done之后,再upgrade
又ok了。[/code]


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 在升级到8.04时遇到试图覆盖文件错误的情况及解决方法
帖子发表于 : 2008-03-08 12:44 

注册: 2007-06-01 22:11
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
这帖改问题直播算啦。哈哈,一边升级一边出问题一边在这里码字玩。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-08 14:11 

注册: 2007-06-01 22:11
帖子: 209
送出感谢: 0 次
接收感谢: 0 次
代码:
who@what:~$ sudo apt-get dist-upgrade --fix-missing
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成     
正在筹划升级... 完成
下列【新】软件包将被安装:
  libgmyth0 xserver-xorg-video-openchrome
下列的软件包将被升级:
  gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly xserver-xorg-video-all
共升级了 3 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 15 个软件包没有被完全安装或卸载。
需要下载 57.6kB/1319kB 的软件包。
操作完成后,会消耗掉 1634kB 的额外磁盘空间。
您希望继续执行吗?[Y/n]y> Enigma


错误 http://ubuntu.cn99.com hardy/universe libgmyth0 0.7~svn916-0ubuntu1
  404 Not Found
无法下载 http://ubuntu.cn99.com/ubuntu/pool/universe/g/gmyth/libgmyth0_0.7~svn916-0ubuntu1_amd64.deb  404 Not Found
选中了曾被取消选择的软件包 xserver-xorg-video-openchrome。
(正在读取数据库 ... 系统当前总共安装有 226265 个文件和目录。)
正在解压缩 xserver-xorg-video-openchrome (从 .../xserver-xorg-video-openchrome_1%3a0.2.901-0ubuntu4_amd64.deb) ...
正预备替换 xserver-xorg-video-all 1:7.2-5ubuntu13 (使用 .../xserver-xorg-video-all_1%3a7.3+10ubuntu4_amd64.deb) ...
正在解压缩将用于更替的包文件 xserver-xorg-video-all ...
正在设置 policykit (0.7-2ubuntu4) ...
chown: 无法访问“/var/run/PolicyKit”: No such file or directory
dpkg:处理 policykit (--configure)时出错:
 子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 hal 的配置工作不能继续:
 hal 依赖于 policykit (>= 0.7);然而:
  软件包 policykit 还没有被配置。
dpkg:处理 hal (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 policykit-gnome 的配置工作不能继续:
 policykit-gnome 依赖于 policykit;然而:
  软件包 policykit 还没有被配置。
dpkg:处理 policykit-gnome (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome-mount 的配置工作不能继续:
 gnome-mount 依赖于 hal;然而:
  软件包 hal 还没有被配置。
 gnome-mount 依赖于 policykit-gnome;然而:
  软件包 policykit-gnome 还没有被配置。
dpkg:处理 gnome-mount (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome-power-manager 的配置工作不能继续:
 gnome-power-manager 依赖于 hal (>= 0.5.10);然而:
  软件包 hal 还没有被配置。
dpkg:处理 gnome-power-manager (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome-session 的配置工作不能继续:
 gnome-session 依赖于 gnome-power-manager;然而:
  软件包 gnome-power-manager 还没有被配置。
dpkg:处理 gnome-session (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome-volume-manager 的配置工作不能继续:
 gnome-volume-manager 依赖于 gnome-mount;然而:
  软件包 gnome-mount 还没有被配置。
 gnome-volume-manager 依赖于 hal (>= 0.5.5.1);然而:
  软件包 hal 还没有被配置。
dpkg:处理 gnome-volume-manager (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 hal-cups-utils 的配置工作不能继续:
 hal-cups-utils 依赖于 hal;然而:
  软件包 hal 还没有被配置。
dpkg:处理 hal-cups-utils (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 hwdb-client-common 的配置工作不能继续:
 hwdb-client-common 依赖于 hal;然而:
  软件包 hal 还没有被配置。
dpkg:处理 hwdb-client-common (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 hwdb-client-gnome 的配置工作不能继续:
 hwdb-client-gnome 依赖于 hwdb-client-common (>= 0.6-0ubuntu23);然而:
  软件包 hwdb-client-common 还没有被配置。
dpkg:处理 hwdb-client-gnome (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 kdebase 的配置工作不能继续:
 kdebase 依赖于 hal | kfreebsd-gnu | hurd;然而:
  软件包 hal 还没有被配置。
  未曾安装软件包“kfreebsd-gnu”。
  未曾安装软件包“hurd”。
dpkg:处理 kdebase (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 network-manager 的配置工作不能继续:
 network-manager 依赖于 hal (>= 0.5.7.1);然而:
  软件包 hal 还没有被配置。
dpkg:处理 network-manager (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 network-manager-gnome 的配置工作不能继续:
 network-manager-gnome 依赖于 network-manager (>= 0.6.5);然而:
  软件包 network-manager 还没有被配置。
dpkg:处理 network-manager-gnome (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 sound-juicer 的配置工作不能继续:
 sound-juicer 依赖于 hal;然而:
  软件包 hal 还没有被配置。
dpkg:处理 sound-juicer (--configure)时出错:
 依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 update-notifier 的配置工作不能继续:
 update-notifier 依赖于 hal;然而:
  软件包 hal 还没有被配置。
dpkg:处理 update-notifier (--configure)时出错:
 依赖关系问题 - 仍未被配置
正在设置 xserver-xorg-video-openchrome (1:0.2.901-0ubuntu4) ...
正在设置 xserver-xorg-video-all (1:7.3+10ubuntu4) ...
在处理时有错误发生:
 policykit
 hal
 policykit-gnome
 gnome-mount
 gnome-power-manager
 gnome-session
 gnome-volume-manager
 hal-cups-utils
 hwdb-client-common
 hwdb-client-gnome
 kdebase
 network-manager
 network-manager-gnome
 sound-juicer
 update-notifier
E: Sub-process /usr/bin/dpkg returned an error code (1)

解决办法是
代码:
sudo fc-cache -fv 2>&1 | grep failed | cut -f1 -d":" | xargs -i sudo touch {} && sudo fc-cache -fv


代码:
who@what:~$ sudo fc-cache -fv 2>&1 | grep failed | cut -f1 -d":" | xargs -i sudo touch {} && sudo fc-cache -fv
/usr/share/fonts: caching, new cache contents: 0 fonts, 5 dirs
/usr/share/fonts/X11: caching, new cache contents: 0 fonts, 6 dirs
/usr/share/fonts/X11/100dpi: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/X11/75dpi: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/X11/Type1: caching, new cache contents: 48 fonts, 0 dirs
/usr/share/fonts/X11/encodings: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/X11/encodings/large: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/X11/misc: caching, new cache contents: 8 fonts, 0 dirs
/usr/share/fonts/X11/util: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap: caching, new cache contents: 0 fonts, 2 dirs
/usr/share/fonts/cmap/adobe-cns1: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/cmap/adobe-gb1: caching, new cache contents: 0 fonts, 0 dirs
/usr/share/fonts/truetype: caching, new cache contents: 0 fonts, 16 dirs
/usr/share/fonts/truetype/arphic: caching, new cache contents: 2 fonts, 0 dirs
/usr/share/fonts/truetype/freefont: caching, new cache contents: 12 fonts, 0 dirs
/usr/share/fonts/truetype/kochi: caching, new cache contents: 4 fonts, 0 dirs
/usr/share/fonts/truetype/latex-xft-fonts: caching, new cache contents: 7 fonts, 0 dirs
/usr/share/fonts/truetype/msttcorefonts: caching, new cache contents: 60 fonts, 0 dirs
/usr/share/fonts/truetype/openoffice: caching, new cache contents: 1 fonts, 0 dirs
/usr/share/fonts/truetype/thai: caching, new cache contents: 35 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-arabeyes: caching, new cache contents: 39 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-bitstream-vera: caching, new cache contents: 10 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-dejavu: caching, new cache contents: 21 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-indic-fonts-core: caching, new cache contents: 11 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-lao: caching, new cache contents: 1 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-malayalam-fonts: caching, new cache contents: 2 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-mgopen: caching, new cache contents: 16 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-sil-gentium: caching, new cache contents: 4 fonts, 0 dirs
/usr/share/fonts/truetype/unfonts: caching, new cache contents: 4 fonts, 0 dirs
/usr/share/fonts/type1: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/type1/gsfonts: caching, new cache contents: 35 fonts, 0 dirs
/usr/share/fonts/zh_CN: caching, new cache contents: 0 fonts, 1 dirs
/usr/share/fonts/zh_CN/TrueType: caching, new cache contents: 5 fonts, 0 dirs
/usr/share/X11/fonts: skipping, no such directory
/usr/local/share/fonts: caching, new cache contents: 0 fonts, 0 dirs
/home/who/.fonts: skipping, no such directory
/usr/share/texmf/fonts/type1/public/lm: caching, new cache contents: 92 fonts, 0 dirs
/usr/share/fonts/truetype/ttf-gentium: skipping, no such directory
/var/cache/fontconfig: cleaning cache directory
/home/who/.fontconfig: cleaning cache directory
fc-cache: succeeded

再update,ok

后记:
如果以后apt-get -f install再出现还没有被配置什么的,就把它们都先remove掉,然后install。就应该能解决了。比如
代码:
who@what:~$ sudo apt-get remove  policykit hal policykit-gnome gnome-mount gnome-volume-manager hal-cups-utils hwdb-client-common hwdb-client-gnome kdebase network-manager network-manager-gnome sound-juicer update-notifier
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成     
已经不需要下列自动安装的软件包:
  ktip kdeprint kpager klipper ksysguard kmenuedit ksplash poster khelpcenter
  ksysguardd kappfinder kate kdepasswd
使用 'apt-get autoremove' 来删除它们。
下列软件包将被【卸载】:
  gnome-mount gnome-volume-manager hal hal-cups-utils hal-device-manager
  hwdb-client-common hwdb-client-gnome kdebase network-manager
  network-manager-gnome policykit policykit-gnome sound-juicer update-notifier
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 14 个软件包,有 2 个软件未被升级。
有 13 个软件包没有被完全安装或卸载。
操作完成后,会释放 17.6MB 的磁盘空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 225141 个文件和目录。)
正在删除 gnome-volume-manager ...
正在删除 gnome-mount ...
正在删除 hal-device-manager ...
正在删除 update-notifier ...
正在删除 sound-juicer ...
正在删除 network-manager-gnome ...
正在删除 network-manager ...
正在删除 kdebase ...
正在删除 hwdb-client-gnome ...
正在删除 hwdb-client-common ...
正在删除 hal-cups-utils ...
正在删除 hal ...
正在删除 policykit-gnome ...
正在删除 policykit ...

代码:
who@what:~$ sudo apt-get install  policykit hal policykit-gnome gnome-mount gnome-volume-manager hal-cups-utils hwdb-client-common hwdb-client-gnome kdebase network-manager network-manager-gnome sound-juicer update-notifier gnome-power-manager gnome-session
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成     
建议安装的软件包:
  desktop-base gnome-user-guide gnome2-user-guide wine gnome-device-manager
  kdebase-doc-html
推荐安装的软件包:
  libsmbios-bin kdm
下列【新】软件包将被安装:
  gnome-mount gnome-power-manager gnome-session gnome-volume-manager hal
  hal-cups-utils hwdb-client-common hwdb-client-gnome kdebase network-manager
  network-manager-gnome policykit policykit-gnome sound-juicer update-notifier
共升级了 0 个软件包,新安装了 15 个软件包,要卸载 0 个软件包,有 2 个软件未被升级。
需要下载 0B/6036kB 的软件包。
操作完成后,会消耗掉 34.4MB 的额外磁盘空间。
正在预设定软件包 ...
选中了曾被取消选择的软件包 policykit。
(正在读取数据库 ... 系统当前总共安装有 224597 个文件和目录。)
正在解压缩 policykit (从 .../policykit_0.7-2ubuntu4_amd64.deb) ...
选中了曾被取消选择的软件包 hal。
正在解压缩 hal (从 .../hal_0.5.10-5ubuntu6_amd64.deb) ...
选中了曾被取消选择的软件包 policykit-gnome。
正在解压缩 policykit-gnome (从 .../policykit-gnome_0.7-2_amd64.deb) ...
选中了曾被取消选择的软件包 gnome-mount。
正在解压缩 gnome-mount (从 .../gnome-mount_0.7-2ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 gnome-power-manager。
正在解压缩 gnome-power-manager (从 .../gnome-power-manager_2.21.1-0ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 gnome-session。
正在解压缩 gnome-session (从 .../gnome-session_2.21.91-0ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 gnome-volume-manager。
正在解压缩 gnome-volume-manager (从 .../gnome-volume-manager_2.22.1-1ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 hal-cups-utils。
正在解压缩 hal-cups-utils (从 .../hal-cups-utils_0.6.13+svn86-0ubuntu2_amd64.deb) ...
选中了曾被取消选择的软件包 hwdb-client-common。
正在解压缩 hwdb-client-common (从 .../hwdb-client-common_0.6.13_all.deb) ...
选中了曾被取消选择的软件包 hwdb-client-gnome。
正在解压缩 hwdb-client-gnome (从 .../hwdb-client-gnome_0.6.13_all.deb) ...
选中了曾被取消选择的软件包 kdebase。
正在解压缩 kdebase (从 .../kdebase_4%3a3.5.8-2ubuntu20_all.deb) ...
选中了曾被取消选择的软件包 network-manager。
正在解压缩 network-manager (从 .../network-manager_0.6.5-0ubuntu17_amd64.deb) ...
选中了曾被取消选择的软件包 network-manager-gnome。
正在解压缩 network-manager-gnome (从 .../network-manager-gnome_0.6.5-0ubuntu11_amd64.deb) ...
选中了曾被取消选择的软件包 sound-juicer。
正在解压缩 sound-juicer (从 .../sound-juicer_2.21.91-0ubuntu1_amd64.deb) ...
选中了曾被取消选择的软件包 update-notifier。
正在解压缩 update-notifier (从 .../update-notifier_0.70.4_amd64.deb) ...
正在设置 policykit (0.7-2ubuntu4) ...

正在设置 hal (0.5.10-5ubuntu6) ...
正在安装新版本的配置文件 /etc/init.d/hal ...
正在安装新版本的配置文件 /etc/hal/fdi/policy/preferences.fdi ...
正在安装新版本的配置文件 /etc/dbus-1/system.d/hal.conf ...
 * Reloading system message bus config...                                [ OK ]
 * Starting Hardware abstraction layer hald                                     /usr/sbin/hald already running.
                                                                         [ OK ]

正在设置 policykit-gnome (0.7-2) ...
正在设置 gnome-mount (0.7-2ubuntu1) ...

正在设置 gnome-power-manager (2.21.1-0ubuntu1) ...
正在安装新版本的配置文件 /etc/xdg/autostart/gnome-power-manager.desktop ...

正在设置 gnome-session (2.21.91-0ubuntu1) ...

正在设置 gnome-volume-manager (2.22.1-1ubuntu1) ...
正在安装新版本的配置文件 /etc/xdg/autostart/gnome-volume-manager.desktop ...

正在设置 hal-cups-utils (0.6.13+svn86-0ubuntu2) ...
正在设置 hwdb-client-common (0.6.13) ...

正在设置 hwdb-client-gnome (0.6.13) ...
正在设置 kdebase (4:3.5.8-2ubuntu20) ...
正在设置 network-manager (0.6.5-0ubuntu17) ...
 * Reloading system message bus config...                                [ OK ]
 * Restarting network connection manager NetworkManager                  [ OK ]
 * Restarting network events dispatcher NetworkManagerDispatcher         [ OK ]

正在设置 network-manager-gnome (0.6.5-0ubuntu11) ...

正在设置 sound-juicer (2.21.91-0ubuntu1) ...

正在设置 update-notifier (0.70.4) ...

然后
代码:
who@what:~$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
Reading state information... 完成     
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 2 个软件未被升级。

现在应该舒心多了。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-08 23:08 
头像

注册: 2007-08-30 5:39
帖子: 1670
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo fc-cache -fv 2>&1 | grep failed | cut -f1 -d":" | xargs -i sudo touch {} && sudo fc-cache -fv
这个无敌命令,7.04的时候很卡,也是这样用的。


_________________
深度,值得深入!
http://bbs.deepin.org/?u=348684

最新的综艺魔法相册
http://www.77studio.net/?fromuid=344


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-23 0:00 
头像

注册: 2006-07-08 14:07
帖子: 1771
送出感谢: 14
接收感谢: 1
SecretZero 写道:
代码:
sudo fc-cache -fv 2>&1 | grep failed | cut -f1 -d":" | xargs -i sudo touch {} && sudo fc-cache -fv
这个无敌命令,7.04的时候很卡,也是这样用的。
dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-03-23 0:01 
头像

注册: 2006-07-08 14:07
帖子: 1771
送出感谢: 14
接收感谢: 1
sudo dpkg --configure -a
正在设置 texlive-base (2007-13) ...
Running mktexlsr. This may take some time... done.
Building format(s) --all.
This may take some time... done.
Running updmap-sys. This may take some time...
updmap-sys failed. Output has been stored in
/tmp/updmap.KHb11958
Please include this file if you report a bug.

Sometimes, not accepting conffile updates in /etc/texmf/updmap.d
causes updmap-sys to fail. Please check for files with extension
.dpkg-dist or .ucf-dist in this directory

dpkg:处理 texlive-base (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 texlive-generic-recommended 的配置工作不能继续:
texlive-generic-recommended 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-generic-recommended (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 policykit (0.7-2ubuntu4) ...
chown: 无法访问“/var/run/PolicyKit”: No such file or directory
dpkg:处理 policykit (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 texlive-fonts-recommended 的配置工作不能继续:
texlive-fonts-recommended 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-fonts-recommended (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-pictures 的配置工作不能继续:
texlive-pictures 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-pictures (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-fonts-extra 的配置工作不能继续:
texlive-fonts-extra 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-fonts-extra (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-croatian 的配置工作不能继续:
texlive-lang-croatian 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-croatian (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 tetex-extra 的配置工作不能继续:
tetex-extra 依赖于 texlive-pictures (>= 2007-11);然而:
软件包 texlive-pictures 还没有被配置。
tetex-extra 依赖于 texlive-lang-croatian (>= 2007);然而:
软件包 texlive-lang-croatian 还没有被配置。
tetex-extra 依赖于 texlive-fonts-extra (>= 2007);然而:
软件包 texlive-fonts-extra 还没有被配置。
dpkg:处理 tetex-extra (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-dutch 的配置工作不能继续:
texlive-lang-dutch 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-dutch (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-danish 的配置工作不能继续:
texlive-lang-danish 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-danish (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 hal 的配置工作不能继续:
hal 依赖于 policykit (>= 0.7);然而:
软件包 policykit 还没有被配置。
dpkg:处理 hal (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-latin 的配置工作不能继续:
texlive-lang-latin 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-latin (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome-mount 的配置工作不能继续:
gnome-mount 依赖于 hal;然而:
软件包 hal 还没有被配置。
dpkg:处理 gnome-mount (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-spanish 的配置工作不能继续:
texlive-lang-spanish 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-spanish (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-hungarian 的配置工作不能继续:
texlive-lang-hungarian 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-hungarian (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-pstricks 的配置工作不能继续:
texlive-pstricks 依赖于 texlive-generic-recommended (>= 2007-11);然而:
软件包 texlive-generic-recommended 还没有被配置。
texlive-pstricks 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-pstricks (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-math-extra 的配置工作不能继续:
texlive-math-extra 依赖于 texlive-fonts-recommended (>= 2007-11);然而:
软件包 texlive-fonts-recommended 还没有被配置。
dpkg:处理 texlive-math-extra (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-latex-base 的配置工作不能继续:
texlive-latex-base 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-latex-base (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-czechslovak 的配置工作不能继续:
texlive-lang-czechslovak 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
texlive-lang-czechslovak 依赖于 texlive-latex-base (>= 2007-11);然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 texlive-lang-czechslovak (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-italian 的配置工作不能继续:
texlive-lang-italian 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-italian (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-portuguese 的配置工作不能继续:
texlive-lang-portuguese 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-portuguese (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 latex-cjk-common 的配置工作不能继续:
latex-cjk-common 依赖于 texlive-latex-base;然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 latex-cjk-common (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-font-utils 的配置工作不能继续:
texlive-font-utils 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-font-utils (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-latex-extra 的配置工作不能继续:
texlive-latex-extra 依赖于 texlive-pictures (>= 2007-11);然而:
软件包 texlive-pictures 还没有被配置。
texlive-latex-extra 依赖于 texlive-latex-base (>= 2007-11);然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 texlive-latex-extra (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-polish 的配置工作不能继续:
texlive-lang-polish 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
texlive-lang-polish 依赖于 texlive-latex-base (>= 2007-11);然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 texlive-lang-polish (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-vietnamese 的配置工作不能继续:
texlive-lang-vietnamese 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-vietnamese (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 latex-cjk-chinese 的配置工作不能继续:
latex-cjk-chinese 依赖于 latex-cjk-common (= 4.7.0+git20070708-1.1);然而:
软件包 latex-cjk-common 还没有被配置。
dpkg:处理 latex-cjk-chinese (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-greek 的配置工作不能继续:
texlive-lang-greek 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-greek (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive 的配置工作不能继续:
texlive 依赖于 texlive-fonts-recommended (>= 2007-11);然而:
软件包 texlive-fonts-recommended 还没有被配置。
texlive 依赖于 texlive-latex-base (>= 2007-11);然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 texlive (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-norwegian 的配置工作不能继续:
texlive-lang-norwegian 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-norwegian (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-swedish 的配置工作不能继续:
texlive-lang-swedish 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-swedish (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 lmodern (1.010x-4) ...
Running mktexlsr. This may take some time... done.
Running updmap-sys. This may take some time...
updmap-sys failed. Output has been stored in
/tmp/updmap.Sis12432
Please include this file if you report a bug.

Sometimes, not accepting conffile updates in /etc/texmf/updmap.d
causes updmap-sys to fail. Please check for files with extension
.dpkg-dist or .ucf-dist in this directory

dpkg:处理 lmodern (--configure)时出错:
子进程 post-installation script 返回了错误号 1
dpkg:依赖关系问题使得 texlive-lang-french 的配置工作不能继续:
texlive-lang-french 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-french (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-other 的配置工作不能继续:
texlive-lang-other 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-other (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 policykit-gnome 的配置工作不能继续:
policykit-gnome 依赖于 policykit;然而:
软件包 policykit 还没有被配置。
dpkg:处理 policykit-gnome (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-publishers 的配置工作不能继续:
texlive-publishers 依赖于 texlive-latex-base (>= 2007-11);然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 texlive-publishers (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-cyrillic 的配置工作不能继续:
texlive-lang-cyrillic 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-cyrillic (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-german 的配置工作不能继续:
texlive-lang-german 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-german (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome-power-manager 的配置工作不能继续:
gnome-power-manager 依赖于 hal (>= 0.5.10);然而:
软件包 hal 还没有被配置。
dpkg:处理 gnome-power-manager (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 prosper 的配置工作不能继续:
prosper 依赖于 texlive-latex-base;然而:
软件包 texlive-latex-base 还没有被配置。
prosper 依赖于 texlive-pstricks;然而:
软件包 texlive-pstricks 还没有被配置。
dpkg:处理 prosper (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-mongolian 的配置工作不能继续:
texlive-lang-mongolian 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-mongolian (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-lang-finnish 的配置工作不能继续:
texlive-lang-finnish 依赖于 texlive-base (>= 2007-11);然而:
软件包 texlive-base 还没有被配置。
dpkg:处理 texlive-lang-finnish (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 ubuntustudio-desktop 的配置工作不能继续:
ubuntustudio-desktop 依赖于 gnome-power-manager;然而:
软件包 gnome-power-manager 还没有被配置。
ubuntustudio-desktop 依赖于 hal;然而:
软件包 hal 还没有被配置。
dpkg:处理 ubuntustudio-desktop (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 sound-juicer 的配置工作不能继续:
sound-juicer 依赖于 hal;然而:
软件包 hal 还没有被配置。
dpkg:处理 sound-juicer (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 pulseaudio-module-hal 的配置工作不能继续:
pulseaudio-module-hal 依赖于 hal;然而:
软件包 hal 还没有被配置。
dpkg:处理 pulseaudio-module-hal (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-bibtex-extra 的配置工作不能继续:
texlive-bibtex-extra 依赖于 texlive-latex-base (>= 2007-11);然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 texlive-bibtex-extra (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lyx-common 的配置工作不能继续:
lyx-common 依赖于 texlive-latex-base;然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 lyx-common (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 texlive-latex-recommended 的配置工作不能继续:
texlive-latex-recommended 依赖于 texlive-latex-base (>= 2007-11);然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 texlive-latex-recommended (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome-session 的配置工作不能继续:
gnome-session 依赖于 gnome-power-manager;然而:
软件包 gnome-power-manager 还没有被配置。
dpkg:处理 gnome-session (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 tipa 的配置工作不能继续:
tipa 依赖于 texlive-latex-base;然而:
软件包 texlive-latex-base 还没有被配置。
dpkg:处理 tipa (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 tetex-bin 的配置工作不能继续:
tetex-bin 依赖于 texlive (>= 2007-11);然而:
软件包 texlive 还没有被配置。
dpkg:处理 tetex-bin (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:出现过多错误,正在终止
dpkg: ../../src/packages.c:252: process_queue: 断言 `!queuelen' 失败.
忽略 (core dumped)


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-03-23 0:02 
头像

注册: 2006-07-08 14:07
帖子: 1771
送出感谢: 14
接收感谢: 1
sudo fc-cache -fv 2>&1 | grep failed | cut -f1 -d":" | xargs -i sudo touch {} && sudo fc-cache -fv :cry: :cry: :cry:


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-03-23 7:35 
头像

注册: 2006-07-08 14:07
帖子: 1771
送出感谢: 14
接收感谢: 1
how del software :roll:


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-03-25 10:31 
头像

注册: 2006-07-08 14:07
帖子: 1771
送出感谢: 14
接收感谢: 1
texlive一直装不上。 :cry:


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-03-27 16:34 

注册: 2006-09-20 14:36
帖子: 145
送出感谢: 0 次
接收感谢: 0 次
升級升出問題就是一個學習的過程。
每次升級都希望出點什麼問題,那才有學習的動力,呵呵。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译