当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [分享]ubuntu安装软件出现的错误代码详解
帖子发表于 : 2008-03-08 18:20 

注册: 2007-11-01 14:27
帖子: 39
地址: 西北工业大学
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install 软件包 这个是更新你指定的软件包
sudo apt-get update 获取更新列表
sudo apt-get dist-upgrade 开始更新
./configure的问题

错误: C compiler cannot create executables
原因:
解决:sudo apt-get gcc libc6-dev

错误:checking for C compiler default output... configure: error: C compiler cannot create executables
原因:
解决:sudo apt-get install libc6-dev

错误:configure: error: C++ preprocessor "/lib/cpp" fails sanity check
原因:gcc的组件没装全
解决:apt-get install build-essential

错误: Can't find X includes. Please check your installation and add the correct paths!
原因:没有X的包含文件
解决:安装xlibs-dev即可

错误: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
原因:查找提供qt的lib&&headers的软件包,并安装之
解决:apt-get install libqt3-headers libqt3-mt-dev

错误:in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!
原因:install a KDE application in a Gnome environment。
解决:which basically means its going to want to install a lot of KDE specific packages to work. This 'configure:error'
is due to it expecting you to be running KDE and again refers to some 'headers'.
sudo apt-get update
sudo apt-get install kdelibs4-dev kdelibs4c2a

错误:./admin/cvs.sh: 585: autoconf: not found
原因:
解决:apt-get install autoconf

错误: *** GTK >= 2.4.0 not installed! ***
原因:没装GTK
解决:apt-get build-dep gedit

错误:heching for gtk-config... no
checking for GTK - version = 1.2.0... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG enviroment variable to the
*** full path to gtk-config.
configure: error: Cannot find GTK: Is gtk-config in path?
原因:
解决:sudo apt-get install libgtk1.2-dev

问题:eclipse中encoding不支持中文
解决:编辑/var/lib/locales/supported.d/local,加一行zh_CN.GBK GBK,执行sudo locale-gen

错误:gnome.h: No such file or directory

错误: No package 'libpanelapplet-2.0' found
原因:
解决:sudo apt-get install gnome-panel

问题:eva不弹出输入法
解决:sudo apt-get install scim-qtimm

问题:No package 'gtk+-2.0' found
No package 'gtksourceview-1.0' found
No package 'libgnomeui-2.0' found
No package 'libglade-2.0' found
No package 'libgnomeprintui-2.2' found
解决:sudo apt-get install libgtk2.0-dev libgtksourceview-dev libgnomeui-dev libglade2-dev libgnomeprint2.2-dev

问题:No package 'libpanelapplet-2.0' found
解决:sudo apt-get install libpanelappletmm-2.6-dev

编译安装 Pidgin 的步骤

1. 下载 Pidgin 的源代码包 pidgin-2.1.1.tar.bz2 (官方最新的版本)。
wget http://jaist.dl.sourceforge.net/sourceforge/pidgin/pidgin-2.1.1.tar.bz2

2. 安装编译 Pidgin 所需的依赖:
sudo apt-get install libgtk2.0-dev libxml2-dev gettext libnss-dev libnspr-dev

3. 解压源代码包
tar jxvf pidgin-2.1.1.tar.bz2
cd pidgin-2.1.1

4. 编译
./configure (建议使用 –help 查询需要用到的参数)
make
sudo make install
如果在 ./configure 这一步出现错误

错误一:
configure: error:

You must have the GTK+ 2.0 development headers installed to compile Pidgin.
If you only want to build Finch then specify –disable-gtkui when running configure.
解决:
sudo apt-get install libgtk2.0-dev

错误二:
configure: error:

You must have libxml2 >= 2.6.0 development headers installed to build.
解决:
sudo apt-get install libxml2-dev

错误三:
configure: error:

The msgfmt command is required to build libpurple. If it is installed on your system, ensure that it is in your path. If it is not, install GNU gettext to continue.
解决:
sudo apt-get install gettext
如果在使用 GTalk 或 MSN 时出现错误

错误:
SSL Library/Libraries……… : None (MSN and Google Talk will not work
without SSL!)
解决:
sudo apt-get install libnss-dev libnspr-dev


Ubuntu编译时找不到Makefile的解决办法ZDNet 软件频道 更新时间:2007-09-26作者: korn 来源:赛迪网 
本文关键词: Ubuntu Proftp
如果是需要编译的环境,推荐安装"build essential"包,

#sudo apt-get install "build-essential"

在用./configure ,make , makeinstall ,方法安装软件是,经常会发生发生各种错误,而导致无法生成 makefile 文件。现在我把我安装过程中遇到的问题以及解决办法写下来,希望对大家有点帮助。

以我安装 pidgin-2.0.0为例

#./configure 出现错误 :

configure: error: C compiler cannot create executables

按照错误提示安装缺少的包

#sudo apt-get install libc6-dev

再次

#./configure

出现错误

checking for GLIB... no

no

configure: error:

You must have the GLib 2.0 development headers installed to build.

根据错误提示,用新得立搜索 GLib 2.0 或者 用命令

#sudo apt-cache search GLib 2.0

发现有个包 libglib2.0-dev - Development files for the GLib library 。

选择安装;

#sudo apt-get install libglib2.0-dev

这里原文为libglib2.0-0-dev,似乎有误。

#./configure #又出现错误

checking for X... no

checking for GTK... no

no

configure: error:

You must have the GTK+ 2.0 development headers installed to compile Pidgin.

If you only want to build Finch then specify --disable-gtkui when running configure.

用如上同样的方法查找到缺少的包 并安装

sudo apt-get install libgtkmm2.0-dev

./configure 出现错误

checking for LIBXML... no

no

configure: error:

You must have libxml2 >= 2.6.0 development headers installed to build.

于是安装

sudo apt-get install libxml2-dev

经过上面包的安装,在次./configure 没有再出现错误,这次成功的生成了makefile 文件。

然后执行:

#make

#make install

成功安装软件。

如果在./configure中还出现问题,那么要找到问题所在,安装缺失的包即可。

在配置过程中,config.log文件是很有帮助的。我们可以在这里面找出错误的根源,从而寻找应对措施。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-10 19:44 
头像

注册: 2007-11-18 19:25
帖子: 123
地址: 中国浙江
送出感谢: 0 次
接收感谢: 0 次
支持一下楼主,这么好的贴,怎么没有人回呢
做个记号,方便查找


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-29 23:24 
头像

注册: 2008-07-18 23:16
帖子: 81
系统: Ubuntu
送出感谢: 0 次
接收感谢: 0 次
太详细了
绝对精华!
严重支持,顶顶顶...


_________________
我相信linux会笑傲"江湖"的! : P


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-30 10:09 

注册: 2008-08-24 21:29
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
请教下这个问题哈
E: havp: 子进程 post-installation script 返回了错误号 1
E: amavisd-new: 子进程 post-installation script 返回了错误号 1
E: amavisd-new-milter: 依赖关系问题 - 仍未被配置


无论我用新还是终端装都有这个问题,怎么解决阿,我百度了一下没找到。。。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [分享]ubuntu安装软件出现的错误代码详解
帖子发表于 : 2009-08-19 18:59 

注册: 2008-10-15 20:48
帖子: 22
系统: ubuntu 12.10
送出感谢: 0 次
接收感谢: 0 次
非常有用,谢谢~


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [分享]ubuntu安装软件出现的错误代码详解
帖子发表于 : 2009-08-19 19:08 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
楼主总结的不错,顶之。 :em11
引用:
E: havp: 子进程 post-installation script 返回了错误号 1
E: amavisd-new: 子进程 post-installation script 返回了错误号 1
E: amavisd-new-milter: 依赖关系问题 - 仍未被配置

需要提供更多信息才行,至少你得说明装的是什么软件,应该能贴出更多详细信息才行。


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [分享]ubuntu安装软件出现的错误代码详解
帖子发表于 : 2009-08-21 11:08 

注册: 2008-02-10 12:35
帖子: 49
送出感谢: 0 次
接收感谢: 0 次
好贴,楼主太无私了
:em05 :em05


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [分享]ubuntu安装软件出现的错误代码详解
帖子发表于 : 2009-09-13 11:01 

注册: 2009-07-23 11:03
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
顶,正在用。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [分享]ubuntu安装软件出现的错误代码详解
帖子发表于 : 2009-11-03 11:18 

注册: 2009-10-30 12:39
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
多谢分享


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [分享]ubuntu安装软件出现的错误代码详解
帖子发表于 : 2010-03-15 18:30 
头像

注册: 2009-02-23 17:55
帖子: 342
送出感谢: 0 次
接收感谢: 0 次
:em09 成功安装pidgin-2.6.6 多谢来~ :em05


_________________
我的linux网站:http://www.kudouzi.com 欢迎访问!!!
我的QQ:53273291 敬请骚扰


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [分享]ubuntu安装软件出现的错误代码详解
帖子发表于 : 2010-03-15 20:04 
头像

注册: 2008-04-26 12:41
帖子: 10971
送出感谢: 11
接收感谢: 38
:em09


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译