当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : "网络连接每次开机都连不上,非要手动改一下连接配置才行"的解决办法!
帖子发表于 : 2008-03-19 12:03 

注册: 2005-11-15 15:04
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
我的ubuntu 8.04版本升级后,每次开机,网络都不能连接上,非要手动改一下配置才行,刚才逛了下“网卡问题以及网络和拨号“这个版块,对照人家的配置文件,发现/etc/network/interfaces文件里面少了一行auto eth0,把这行手动加上去就解决问题了。附上我的这个文件内容:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.100
netmask 255.255.255.0
gateway 192.168.1.1


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-19 12:21 
头像

注册: 2008-02-15 0:08
帖子: 1081
送出感谢: 0 次
接收感谢: 0 次
手动配置的时候会提示是否自动连接当系统登录时。选择yes。
如果更改不生效,估计是权限问题。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-19 12:33 

注册: 2005-11-15 15:04
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
我手动配置的时候从来没有提示过当系统登陆时是否自动连接的。 :( :( :( ,我都更新好多次,手动数十次改变配置了,原来行的,后来某次更新后就没有自动连接了,郁闷呢!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-20 17:08 

注册: 2006-05-18 21:13
帖子: 78
送出感谢: 0 次
接收感谢: 0 次
我的也有这个问题,看样子可以解决一下了,谢谢。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-21 10:57 

注册: 2007-08-24 12:55
帖子: 59
送出感谢: 0 次
接收感谢: 0 次
我的做法是。。。。把/etc/udev/rules.d/75-persistent-net-generator.rules文件里的内容都给注释掉!
之前我的问题是每次开机网卡号都会自动加1,eth0++
还有 70-persistent-net-rules 文件,只留一行就行了!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译