当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]升级到8.04后出现 启动 GNOME 设置守护进程出错
帖子发表于 : 2008-03-25 0:33 
头像

注册: 2007-10-16 10:13
帖子: 37
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
升级到8.04后,出现一系列问题。进系统时 ,出现这个提示

引用:
启动 GNOME 设置守护进程时出错。
主题、声音或者背景设置等可能不会正常工作。
设置守护进程重新启动的次数太多。
GNOME 在您下次登录时仍将试图重启动设置守护进程


在首选项里点外观时,会先出现这个提示
引用:
无法启动设置管理器“gnome-settings-daemon”。
如果不运行 GNOME 设置管理器,某些首选项不会生效。这可能表明 Bonobo 出现问题,或者非 GNOME(如 KDE)设置管理器可能已经处于活动状态,它与 GNOME 设置管理器发生冲突


控制台sudo gnome-settings-daemon后出现错误信息
引用:
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
(Details: serial 89 error_code 1 request_code 151 minor_code 6)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)


期待各位高手给点帮帮忙,给点建议,先谢了......................


_________________
莪身茬江鍸,江鍸卻莈洧關於莪啲傳詤……


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-25 1:43 
头像

注册: 2006-09-10 22:36
帖子: 10663
地址: 北京
送出感谢: 1
接收感谢: 16
7.10有这问题,所以用7.10升级到8.04也出这问题不奇怪


_________________
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-25 14:20 
头像

注册: 2007-10-16 10:13
帖子: 37
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
我7.10没遇到过这个问题,就升到8.04才出现的。
在网上找了好久的资料了,都还没有解决
有人说是升级不完整造成的,这几天我又接着升级了,可还是没好。
还有没有人遇到这个情况啊.......


_________________
莪身茬江鍸,江鍸卻莈洧關於莪啲傳詤……


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-25 14:28 
头像

注册: 2006-09-10 22:36
帖子: 10663
地址: 北京
送出感谢: 1
接收感谢: 16
jellywgd 写道:
我7.10没遇到过这个问题,就升到8.04才出现的。
在网上找了好久的资料了,都还没有解决
有人说是升级不完整造成的,这几天我又接着升级了,可还是没好。
还有没有人遇到这个情况啊.......

跟升级完整否没关系,刚装的系统第一次启动就出过这个问题,gnome的bug,和acpi有关


_________________
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-25 14:34 
头像

注册: 2008-01-02 17:26
帖子: 199
送出感谢: 0 次
接收感谢: 0 次
我从7.10升到8.04也出现过这种问题,后来把nvidia显卡驱动删了就好了,耐心等待正式版出来吧。
正因为ubuntu跨版本升级做得不好我现在改投arch linux阵营了,用了一阵子感觉比ubuntu强,
平滑升级,包依赖少。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-25 15:17 
头像

注册: 2007-09-16 8:29
帖子: 14252
送出感谢: 172
接收感谢: 271
楼上个叛徒。 :lol: :lol:


_________________
闻到死太贵, 麦克价更高。 有了笨笨兔, 二者皆可抛。
+ 我的六轮折腾
+ 折腾6轮的结果(对40余种WM的测试和分析,多种DE和WM并存的方案)
+ 折腾的中间成果:可以独立运行的一个Wharf(图标化的启动菜单)
+ 强烈推荐----折腾的终极成果:一个自己开发的DE环境
+ 签名空闲链接位置招租


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-28 2:59 
头像

注册: 2007-10-16 10:13
帖子: 37
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上的各位了,看来只能等正式版出来了,哎,现在用着真的太不爽了,每次进系统都报错 :( :(


_________________
莪身茬江鍸,江鍸卻莈洧關於莪啲傳詤……


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-03-28 3:44 
头像

注册: 2006-09-10 22:36
帖子: 10663
地址: 北京
送出感谢: 1
接收感谢: 16
jellywgd 写道:
谢谢楼上的各位了,看来只能等正式版出来了,哎,现在用着真的太不爽了,每次进系统都报错 :( :(

我的偶尔,不是每次~~~


_________________
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-03-30 17:54 

注册: 2008-03-12 23:16
帖子: 57
送出感谢: 0 次
接收感谢: 0 次
我的问题也是和LZ一样的,而且系统的字体超小,把字体大小改成18都没用,DPI还是96的,

把在网上用百度谷歌,搜了个遍都没有解决的问题,郁闷了,难道要重新安装回7.10吗?


有没有高手解答下啊?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-03-30 17:57 

注册: 2008-03-12 23:16
帖子: 57
送出感谢: 0 次
接收感谢: 0 次
但是启动到gnome安全模式之后就没有这个问题了,打开什么都正常,郁闷了。。。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-04-01 7:37 

注册: 2008-03-15 0:34
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
mgn2008 写道:
但是启动到gnome安全模式之后就没有这个问题了,打开什么都正常,郁闷了。。。

我的也是,找了好久都没解决,只能每次都进gnome安全模式了


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-04-01 9:49 

注册: 2007-09-27 13:31
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
我在一个论坛上发现一个方法
应用程序--系统工具--配置编辑器

apps/gnome_settings_daemon/plugins/xrandr

把active关掉,开机就不会有这个提示。

但是文件浏览的时候只能用列表形式,如果用图标方式,窗口会不正常(花瓶),求更好的解决方式。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-04-01 20:53 
头像

注册: 2007-04-23 13:34
帖子: 524
送出感谢: 0 次
接收感谢: 0 次
我升级的问题和楼主一样~ 唉~


_________________
我的微博:http://weibo.com/likewaterwater 欢迎关注~!


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-04-03 8:33 
头像

注册: 2007-10-16 10:13
帖子: 37
地址: 湖南长沙
送出感谢: 0 次
接收感谢: 0 次
看来遇到这个问题的人还不少啊


_________________
莪身茬江鍸,江鍸卻莈洧關於莪啲傳詤……


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-04-09 11:11 
头像

注册: 2008-03-27 19:04
帖子: 117
送出感谢: 0 次
接收感谢: 0 次
我也是这个问题哦,还没解决。郁闷中。。。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译