当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]8.04VMware server启动出错,虽用论坛上的一个方法已解决,但不明白,求教了
帖子发表于 : 2008-03-26 13:54 
头像

注册: 2008-01-02 23:08
帖子: 156
送出感谢: 0 次
接收感谢: 0 次
参考http://forum.ubuntu.org.cn/viewtopic.php?t=104646的方法安装了VMware server1.04,但启时出现了如下错误信息
引用:
$ vmware
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_3.4' not found (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_3.4' not found (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_3.4' not found (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)

然后参考http://forum.ubuntu.org.cn/viewtopic.php?t=17220&sid=b97a82e98865c82f8532b7237ed5a6f4的方法删了 /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1及 /usr/lib/vmware/lib/libpng12.so.0/libpng12.so,便解决了,且运行一切正常,不知是何原因。


_________________
被kubuntu-kde4“K”得好爽!!!!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-27 2:53 

注册: 2006-10-23 7:58
帖子: 227
送出感谢: 0 次
接收感谢: 0 次
Ubuntu8.04上vmware的问题解决
转载本站文章请注明,转载自:扶凯[http://www.php-oa.com]

本文链接: http://www.php-oa.com/2008/03/19/ubuntu804shangvmwaredewentijiejue/

在Ubuntu下做小白,因为等不急8.04。所以先升级起来在玩.但发现升级到8.08后我的vmware-server跑不起来.查了一下,下面是解决方法,当个笔记.

/usr/lib/vmware-server-console/bin/vmware-server-console: /usr/lib/vmware-server-console/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)

解决办法:
$ cd /usr/lib/vmware-server-console/lib/
$ sudo mv libpng12.so.0/libpng12.so.0 libpng12.so.0/libpng12.so.0.disabled
$ sudo ln -sf /usr/lib/libpng12.so.0 libpng12.so.0/libpng12.so.0

/usr/lib/vmware-server-console/bin/vmware-server-console: /usr/lib/vmware-server-console/lib/libgcc_s.so.1/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)

解决办法:
cd /usr/lib/vmware-server-console/lib/libgcc_s.so.1/
sudo mv libgcc_s.so.1 libgcc_s.so.1.disabled
sudo ln -sf /lib/libgcc_s.so.1 libgcc_s.so.1


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译