[问题] 小白不好做啊!8.04怎么不显示ntfs分区的中文名的文件和文件夹?

为当前最终发行版之前的所有版本提供支持
回复
happyu
帖子: 8
注册时间: 2008-04-01 15:02
送出感谢: 0
接收感谢: 0

[问题] 小白不好做啊!8.04怎么不显示ntfs分区的中文名的文件和文件夹?

#1

帖子 happyu » 2008-04-01 15:07

大家救救我啊!
今天这么倒霉阿,原来的7.04被我装ati驱动,装的进不去xwindows了,就下了个8.04
可刚刚装上8.04lts装完中文安装包之后,就看不到ntfs分区的中文名的文件和文件夹了!
让我全改成英文太有困难了!

先谢谢各位了!告诉我怎么解决
头像
yiding_he
帖子: 2677
注册时间: 2006-10-25 18:10
来自: 长沙
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 yiding_he » 2008-04-01 15:16

不知道,自从我用起来,Ubuntu 显示 windows 分区下的中文名文件是毫无问题的。我建议谁贴一下自己的 fstab,里面有挂载参数,而 Linux 对文件名编码的识别就是依靠挂载参数的。
你是自由的。别人也是。
头像
outersky
帖子: 188
注册时间: 2007-04-25 10:07
来自: 上海
送出感谢: 0
接收感谢: 0

#3

帖子 outersky » 2008-04-01 15:23

我这里可以看得到中文目录的啊,我的fstab里面是这样的:

代码: 全选

    UUID=D40A6E3D0A6E1D2C /mnt/share     ntfs    defaults,uid=1000,gid=1000 0    1
风起云飞扬
vvvli
帖子: 441
注册时间: 2006-10-26 7:02
送出感谢: 0
接收感谢: 0

Re: [问题] 小白不好做啊!8.04怎么不显示ntfs分区的中文名的文件和文件夹?

#4

帖子 vvvli » 2008-04-01 16:56

happyu 写了:大家救救我啊!
今天这么倒霉阿,原来的7.04被我装ati驱动,装的进不去xwindows了,就下了个8.04
可刚刚装上8.04lts装完中文安装包之后,就看不到ntfs分区的中文名的文件和文件夹了!
让我全改成英文太有困难了!

先谢谢各位了!告诉我怎么解决
fstab 里 把ntfs 放在最后几行。
happyu
帖子: 8
注册时间: 2008-04-01 15:02
送出感谢: 0
接收感谢: 0

#5

帖子 happyu » 2008-04-01 23:28

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0

# /dev/sda9
UUID=e6253b02-9808-4ce6-b05e-c4b9416ec8ad none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0


# /dev/sda2
UUID=bbeffd03-54a0-4121-9fda-c6b68f14f2ae / ext3 relatime,errors=remount-ro 0 1
# /dev/sda1
UUID=4E601F0E601EFC81 /media/sda1 ntfs zh-cn,umask=007,gid=46 0 1
# /dev/sda5
UUID=16085D27085D0761 /media/sda5 ntfs zh-cn,umask=007,gid=46 0 1
# /dev/sda6
UUID=A26CB6E06CB6AE83 /media/sda6 ntfs zh-cn,umask=007,gid=46 0 1
# /dev/sda7
UUID=13C4A3913951CE31 /media/sda7 ntfs defaults,umask=007,gid=46 0 1
# /dev/sda8
UUID=00087CFB087CF150 /media/sda8 ntfs defaults,umask=007,gid=46 0 1


这是我的 fstab 里面参数不是很明白,但是我感觉没什么错误,晕了,不想重装阿
jova
帖子: 230
注册时间: 2007-11-16 15:24
送出感谢: 1 次
接收感谢: 0

#6

帖子 jova » 2008-04-02 1:48

我是写了一个mount.sh,每次手动umount,然后mount。就可以显示中文的。
文件如下:
sudo umount /media/sda2
sudo mount /dev/sda2 /media/sda2
sudo umount /media/sda5
sudo mount /dev/sda5 /media/sda5
头像
wavydoom
帖子: 1081
注册时间: 2008-02-15 0:08
送出感谢: 0
接收感谢: 0

#7

帖子 wavydoom » 2008-04-02 4:56

#安装NTFS读写支持

sudo apt-get install ntfs-config

#点击“应用程序” - “系统工具” - “NTFS写入支持配置程序”
#输入密码,选中对内部设备的读写支持,和外部设备的读写支持,
#系统会自动扫描你硬盘上的NTFS分区并重新挂载,这样NTFS分区就能完美读写了!


#NTFS 非正常挂载支持:需要在终端用ROOT打开nautilus,然后手动选择挂载。
#如有异常,删除 sudo gedit /etc/fstab 内挂载的分区,并重新启动,启动后运行ntfs-3g,
#则会重新提示找到ntfs分区,此时重新选择挂载点并命名挂载。
#(!建议采用英文名,重命名时会在命名框内出现路径+硬盘名,此时请在栏目内只输入名称,比如nthd1,nthd2。而不是路径+名称)
blog : wavydoom.is-programmer.com/
http://www.kaixin001.com/home/?t=83
头像
qiaoling
帖子: 93
注册时间: 2007-04-12 15:19
送出感谢: 0
接收感谢: 0

#8

帖子 qiaoling » 2008-04-02 11:37

在 /etc/fstab里先挂载share和/分区,再挂载win分区即可
vvvli
帖子: 441
注册时间: 2006-10-26 7:02
送出感谢: 0
接收感谢: 0

#9

帖子 vvvli » 2008-04-02 22:18

zh-cn 是什么参数? 全部default
happyu
帖子: 8
注册时间: 2008-04-01 15:02
送出感谢: 0
接收感谢: 0

#10

帖子 happyu » 2008-04-02 23:46

zh-cn是我随便改的,没什么意思。
我已经重装系统了,不过还是那样。这次找到问题的根源了,装好系统后上网更新中文包,然后重启,这样中文名的文件夹和文件就显示不出来了。这次更郁闷的是,openoffice也没有了!!
头像
ciclo
帖子: 786
注册时间: 2007-01-25 16:43
来自: 塔尔塔洛斯
送出感谢: 0
接收感谢: 0

#11

帖子 ciclo » 2008-04-03 4:42

挂载先挂/usr /
后挂载 ntfs分区
修改你的fstab
我生平瞧不起两种人:
1.那些瞧不起用windows的人的人
2.用windows的人
3.不识数的人

博客:http://blog.chunhao.net
主页:http://chunhao.net
happyu
帖子: 8
注册时间: 2008-04-01 15:02
送出感谢: 0
接收感谢: 0

#12

帖子 happyu » 2008-04-03 16:14

谢谢大家的回答

我在想会不会是源的问题?
7。04 7。10 8。04的会有什么不同?
我用的cn99,才发现上面几个版本的源不同,我用的是7。10的
pcg1234
帖子: 35
注册时间: 2008-03-16 18:16
送出感谢: 0
接收感谢: 0

#13

帖子 pcg1234 » 2008-04-04 23:04

请问11楼, 怎么样才 能先挂 ?我有一次把/usr单独分出来了,结果就看不到中文文件和夹了!不单分出来就行
回复

回到 “老旧版本支持”